Results 1 to 3 of 3

Thread: Intel NUC and the screen will not turn off

  1. #1

    Default Intel NUC and the screen will not turn off

    I have just installed LEAP 15.2 on an a NUC. Install went well with no issues. I'm running KDE and I have this weird thing where the screen is always on (locked after my specified time), but it stays powered. I would like the screen to power off after 10 minutes to conserve power and monitor life.

    Using the power management I can select when I want the screen to turn off. The screen will go black, and I can see that the input from the HDMI is turned off (screen displays the message no HDMI input) and two seconds later the screen comes back on and stays on at the lock screen.

    I have multiple installs of LEAP on another desktop and a laptop and have never seen this behavior. I'm at a loss of what to try next. Any thoughts?

  2. #2
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,440

    Default Re: Intel NUC and the screen will not turn off

    A similar report was made here in June, but the user with the problem was using a DisplayPort cable, and it didn't reproduce when using HDMI. Still, you might try what was tried or suggested in that thread.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.1, TW, 15.2 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&15.1 on i965P/Radeon
    Tertiary: TW,15.2,15.1,Fedora,Debian,more on Kaby Lake,iQ45,iQ43,iG41,iG3X,i965G,AMD,NVidia&&&

  3. #3

    Default Re: Intel NUC and the screen will not turn off

    Well, the suggestions in the other linked post worked.

    Disable Application Menu -> System Settings -> Workspace -> Startup and Shutdown -> Background services -> KScreen 2.

    Screen will now turn off and stay off. It comes back on with the click of mouse or a press of the keyboard key.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •