Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 50

Thread: Audio Conferecing - Unable to get Microphone Working

  1. #21
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,000

    Default AW: Audio Conferecing - Unable to get Microphone Working

    Bought it on ebay.de for 10€.

  2. #22

    Default Re: AW: Audio Conferecing - Unable to get Microphone Working

    Quote Originally Posted by Sauerland View Post
    Bought it on ebay.de for 10€.

    Does it have a brand / model ? I would be happy to get a usb microphone that is detected/supported by the OS

  3. #23

    Default Re: Audio Conferecing - Unable to get Microphone Working

    Quote Originally Posted by MarcoMeswara View Post
    Hi .. These are my PulseAudio screenshots ...

    a. Configuration - https://pasteboard.co/JvWYd3g.png

    Pls notice that i dont have " Analog Output + Analog input ", therefore the nearest thing that i can think off
    is "Analog Stereo Duplex"

    b. Input Devices - https://pasteboard.co/JvX0EfD.png

    Correct ?

    c. Output Devices - https://pasteboard.co/JvX4aKP.png

    Movies / Youtube, etc is working fine.

    d. Recording - https://pasteboard.co/JvX6Ez2l.png - Blank except when an application is recording -

    Do i select "Monitor of Built-in Audio Analog Stereo" or "Built-in Audio Analog Stereo"


    e. Playback - https://pasteboard.co/JvX6W56.png - Application name appears when in use -

    Movies / Youtube, etc is working fine.



    Thanks in advance ...

    I have tried recording multiple times .. used audicaty and online microphone tests... AND JUST FAILURE ..
    jUST STATIC NOISE ....

    Will try a usb microphone solutio0n ? If i can get a usb microphone that works properly in linux ...

  4. #24
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,704
    Blog Entries
    39

    Default Re: Audio Conferecing - Unable to get Microphone Working

    I am coming in a bit late to this thread.

    Once you sort/decide on your hardware configuration, it would assist in understanding your PC configuration, such that hopefully additional helpful recommendations can be given, if you would run a diagnostic script on your GNU/Linux sound configuration, and share those configuration results with us.

    You can do that by with 'regular user' permissions, with PC connected to the internet, copying and pasting the following command into an xterm, and execute the command to run the diagnostic script:
    Code:
    /usr/sbin/alsa-info.sh
    select "UPLOAD/SHARE" when prompted. Let the script run to completion. When the script is complete, look in the xterm, and you will read
    Code:
    Your ALSA information is located at http://alsa-project.org/db/somenumber
    Please inform the person helping you.
    share here please that " http://alsa-project.org/db/somenumber " and we can look at the script and (1) advise you of anything misconfigured in your mixer, (2) possibly identify other issues, and (3) possibly come up with a recording test to prove your recording works properly.

  5. #25
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,704
    Blog Entries
    39

    Default Re: Audio Conferecing - Unable to get Microphone Working

    I notice you ran the diagnostic script earlier. In the dmesg I note:
    Code:
    [   13.757186] snd_hda_codec_realtek hdaudioC0D0: ALC262: SKU not ready 0x411111f0
    My hope that is not a serious message.

    Looking at the script, according to arecord, your PC has two recording devices:
    Code:
    ARECORD
    
    **** List of CAPTURE Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: ALC262 Analog [ALC262 Analog]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 2: ALC262 Alt Analog [ALC262 Alt Analog]
      Subdevices: 2/2
      Subdevice #0: subdevice #0
      Subdevice #1: subdevice #1
    which are hw:0,0 and hw:0,2

    Looking at your PC's mixer settings:
    Code:
    Simple mixer control 'Front Mic',0
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 31
      Mono:
      Front Left: Playback 31 [100%] [12.00dB] [on]
      Front Right: Playback 31 [100%] [12.00dB] [on]
    Simple mixer control 'Front Mic Boost',0
      Capabilities: volume
      Playback channels: Front Left - Front Right
      Capture channels: Front Left - Front Right
      Limits: 0 - 3
      Front Left: 2 [67%] [20.00dB]
      Front Right: 2 [67%] [20.00dB]
    Simple mixer control 'Capture',1
      Capabilities: cvolume cswitch
      Capture channels: Front Left - Front Right
      Limits: Capture 0 - 31
      Front Left: Capture 31 [100%] [34.50dB] [on]
      Front Right: Capture 31 [100%] [34.50dB] [on]
    Simple mixer control 'Capture',2
      Capabilities: cvolume cswitch
      Capture channels: Front Left - Front Right
      Limits: Capture 0 - 31
      Front Left: Capture 0 [0%] [-12.00dB] [off]
      Front Right: Capture 0 [0%] [-12.00dB] [off]
    Simple mixer control 'Input Source',0
      Capabilities: cenum
      Items: 'Front Mic' 'Rear Mic' 'Line'
      Item0: 'Line'
    Simple mixer control 'Input Source',1
      Capabilities: cenum
      Items: 'Front Mic' 'Rear Mic' 'Line'
      Item0: 'Front Mic'
    Simple mixer control 'Input Source',2
      Capabilities: cenum
      Items: 'Front Mic' 'Rear Mic' 'Line'
      Item0: 'Rear Mic'
    Simple mixer control 'Rear Mic',0
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 31
      Mono:
      Front Left: Playback 0 [0%] [-34.50dB] [on]
      Front Right: Playback 0 [0%] [-34.50dB] [on]
    Simple mixer control 'Rear Mic Boost',0
      Capabilities: volume
      Playback channels: Front Left - Front Right
      Capture channels: Front Left - Front Right
      Limits: 0 - 3
      Front Left: 0 [0%] [0.00dB]
      Front Right: 0 [0%] [0.00dB]
    For your HP Z600 workstation I note the following:
    • Front Mic while ON is @ 100% playback and boost at 67%.
    • Rear Mic while ON is @ 0% playback, and boost at 0% boost.
    • Capture-1 is at 100%, Capture-2 is muted (0% and OFF).
    • Input source '0' is assigned to "Line" (and hence it will not record audio). Further Line is OFF at 0%.
    • Input source '1' is assigned to Front Mic
    • Input source '2' is assigned to Rear Mic


    From the above, any Microphone connected to Line or to the Rear Mic won't record.

    Is it the 'front mic' that you are physically using? (You have not told us)

    First lets try and determine which jack is the rear jack and/or the front jack.

    From script I note your PC has input for recording on hw:0,0 and hw:0,2. So with mic plugged to the front mic slot try as a regular user in an xterm:
    Code:
    arecord -vv -f S16_LE -c2 -D hw:0,0 soundtest.wav
    Talk into the mic for 10 seconds, then press <CTRL><C> to abort the recording. Then test to see if that recorded sound by sending the command:
    Code:
    aplay soundtest.wav
    Does that give any sound?

    Also try (again as a regular user in an xterm):
    Code:
    arecord -vv -f S16_LE -c2 -D hw:0,2 soundtest.wav
    Again talk into the mic for 10 seconds, then press <CTRL><C> to abort the recording. Then test to see if that recorded sound by sending the command:
    Code:
    aplay soundtest.wav
    Does that give any sound?

    Repeat the above with headset w/mic plugged into the rear mic slot.

  6. #26

    Default Re: Audio Conferecing - Unable to get Microphone Working

    Quote Originally Posted by oldcpu View Post
    I notice you ran the diagnostic script earlier. In the dmesg I note:
    Code:
    [   13.757186] snd_hda_codec_realtek hdaudioC0D0: ALC262: SKU not ready 0x411111f0
    My hope that is not a serious message.

    Looking at the script, according to arecord, your PC has two recording devices:
    [code]
    ARECORD

    .
    .
    .



    Hi OldCPU, kindly allow me to re-run the script as i have done svereal modifications to the settings, many modifications infact ....

    Here is the new link : - Your ALSA information is located at http://alsa-project.org/db/?f=c21a07e5de4266f227daa6df1a4856585ec908dd

    May we start with this ?

    Also, yes, I am recording with the Front Mic.

    Below, I reattach all my PulseAudio Screenshots.

    a. Configuration - https://pasteboard.co/JvWYd3g.png

    Pls notice that i dont have " Analog Output + Analog input ", therefore the nearest thing that i can think off
    is "Analog Stereo Duplex"

    b. Input Devices - https://pasteboard.co/JvX0EfD.png

    Correct ?

    c. Output Devices - https://pasteboard.co/JvX4aKP.png

    Movies / Youtube, etc is working fine.

    d. Recording - https://pasteboard.co/JvX6Ez2l.png - Blank except when an application is recording -

    Do i select "Monitor of Built-in Audio Analog Stereo" or "Built-in Audio Analog Stereo"


    e. Playback - https://pasteboard.co/JvX6W56.png - Application name appears when in use -

    Movies / Youtube, etc is working fine.

    Thanks.

  7. #27

    Default Re: Audio Conferecing - Unable to get Microphone Working

    Also ...

    arecord -l


    **** List of CAPTURE Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: ALC262 Analog [ALC262 Analog]
    Subdevices: 1/1
    Subdevice #0: subdevice #0


    card 0: Intel [HDA Intel], device 2: ALC262 Alt Analog [ALC262 Alt Analog]
    Subdevices: 2/2
    Subdevice #0: subdevice #0
    Subdevice #1: subdevice #1


    Next, my xfce4-mixer screenshots are below ...

    Playback - https://pasteboard.co/JwtnisQ.png
    Capture - https://pasteboard.co/JwtnpFr.png
    Options - https://pasteboard.co/Jwtnwrf.png

  8. #28
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,704
    Blog Entries
    39

    Default Re: Audio Conferecing - Unable to get Microphone Working

    Some comments wrt pavucontrol:

    Recording, you asked: "Do i select "Monitor of Built-in Audio Analog Stereo" or "Built-in Audio Analog Stereo" " - my recommendation is to try both as I do not have your hardware.

    Output devices - your setting for "built in audio analog/stero" looks suspicous to me, but I can not be certain as I do not have your hardware.

    I note from that script that the arecord output is still:
    Code:
    ARECORD
    
    **** List of CAPTURE Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: ALC262 Analog [ALC262 Analog]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 2: ALC262 Alt Analog [ALC262 Alt Analog]
      Subdevices: 2/2
      Subdevice #0: subdevice #0
      Subdevice #1: subdevice #
    I don't know what type of microphone you have, if it is dedicated, or if it is integrated as part of a headphone?

    I note the headphone is muted:
    Code:
    Simple mixer control 'Headphone',0
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 31
      Mono:
      Front Left: Playback 0 [0%] [-46.50dB] [off]
      Front Right: Playback 0 [0%] [-46.50dB] [off]
    Front Mic appears to be appropriately enabled:
    Code:
    Simple mixer control 'Front Mic',0
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 31
      Mono:
      Front Left: Playback 25 [81%] [3.00dB] [on]
      Front Right: Playback 25 [81%] [3.00dB] [on]
    Simple mixer control 'Front Mic Boost',0
      Capabilities: volume
      Playback channels: Front Left - Front Right
      Capture channels: Front Left - Front Right
      Limits: 0 - 3
      Front Left: 2 [67%] [20.00dB]
      Front Right: 2 [67%] [20.00dB]
    I note any mic plugged into Line will be muted:
    Code:
    Simple mixer control 'Line',0
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 31
      Mono:
      Front Left: Playback 0 [0%] [-34.50dB] [on]
      Front Right: Playback 0 [0%] [-34.50dB] [on]
    Simple mixer control 'Line Boost',0
      Capabilities: volume
      Playback channels: Front Left - Front Right
      Capture channels: Front Left - Front Right
      Limits: 0 - 3
      Front Left: 0 [0%] [0.00dB]
      Front Right: 0 [0%] [0.00dB]
    I note capture 0 and 1 set to capture, and capture 2 switched OFF. I do not know your hardware, so I do not know what capture-0, nor capture-1, nor capture-2 mean in relation to your hardware (although I have suspicions). My understanding thou is the appropriate capture must be enabled to record audio - I think < but not sure > capture-0 is likely your front mic.
    Code:
    Simple mixer control 'Capture',0
      Capabilities: cvolume cswitch
      Capture channels: Front Left - Front Right
      Limits: Capture 0 - 31
      Front Left: Capture 31 [100%] [34.50dB] [on]
      Front Right: Capture 31 [100%] [34.50dB] [on]
    Simple mixer control 'Capture',1
      Capabilities: cvolume cswitch
      Capture channels: Front Left - Front Right
      Limits: Capture 0 - 31
      Front Left: Capture 31 [100%] [34.50dB] [on]
      Front Right: Capture 31 [100%] [34.50dB] [on]
    Simple mixer control 'Capture',2
      Capabilities: cvolume cswitch
      Capture channels: Front Left - Front Right
      Limits: Capture 0 - 31
      Front Left: Capture 27 [87%] [28.50dB] [off]
      Front Right: Capture 27 [87%] [28.50dB] [off]
    You have an auto-mute mode set which could be complicating this:
    Code:
    Simple mixer control 'Auto-Mute Mode',0
      Capabilities: enum
      Items: 'Disabled' 'Speaker Only' 'Line Out Speaker'
      Item0: 'Line Out Speaker'
    I would recommend disabling the above auto-mute for this testing. We don't want the auto-mute disabling inappropriately blocking your recording efforts, while trying to figure out how your PC hardware works. ie change from "Line Out Speaker" to "Disabled".

    I note input source-0 set to Front Mic, and input source-1 set to Front Mic, and input source-2 set to Rear Mic
    Code:
    Simple mixer control 'Input Source',0
      Capabilities: cenum
      Items: 'Front Mic' 'Rear Mic' 'Line'
      Item0: 'Front Mic'
    Simple mixer control 'Input Source',1
      Capabilities: cenum
      Items: 'Front Mic' 'Rear Mic' 'Line'
      Item0: 'Front Mic'
    Simple mixer control 'Input Source',2
      Capabilities: cenum
      Items: 'Front Mic' 'Rear Mic' 'Line'
      Item0: 'Rear Mic'
    I don't know if setting 2 input sources (ie source 0 and source 1) to the same mic could cause an issue (I don't know as I don't have your hardware).

    I note rear Mic disabled so that should not cause an issue if your PC is wired correctly and if you are using the front Mic:
    Code:
    Simple mixer control 'Rear Mic',0
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 31
      Mono:
      Front Left: Playback 0 [0%] [-34.50dB] [on]
      Front Right: Playback 0 [0%] [-34.50dB] [on]
    Simple mixer control 'Rear Mic Boost',0
      Capabilities: volume
      Playback channels: Front Left - Front Right
      Capture channels: Front Left - Front Right
      Limits: 0 - 3
      Front Left: 0 [0%] [0.00dB]
      Front Right: 0 [0%] [0.00dB]
    Did you try the 'arecord' commands that I provided in an earlier post? Please try them. If you see any errors when trying them, please post the errors.

  9. #29

    Default Re: Audio Conferecing - Unable to get Microphone Working

    Quote Originally Posted by oldcpu View Post
    Some comments wrt pavucontrol:

    Recording, you asked: "Do i select "Monitor of Built-in Audio Analog Stereo" or "Built-in Audio Analog Stereo" " - my recommendation is to try both as I do not have your hardware.

    Noted ...





    Output devices - your setting for "built in audio analog/stero" looks suspicous to me, but I can not be certain as I do not have your hardware.

    Noted... Its integrated on the motherboard of the machine.





    I don't know what type of microphone you have, if it is dedicated, or if it is integrated as part of a headphone?
    Its a standalone lapel mic with 3.5mm jack which is plugged into the Front Mic socket.
    Its not part of a headphone.





    Front Mic appears to be appropriately enabled:
    Code:
    Simple mixer control 'Front Mic',0
      Capabilities: pvolume pswitch
      Playback channels: Front Left - Front Right
      Limits: Playback 0 - 31
      Mono:
      Front Left: Playback 25 [81%] [3.00dB] [on]
      Front Right: Playback 25 [81%] [3.00dB] [on]
    Simple mixer control 'Front Mic Boost',0
      Capabilities: volume
      Playback channels: Front Left - Front Right
      Capture channels: Front Left - Front Right
      Limits: 0 - 3
      Front Left: 2 [67%] [20.00dB]
      Front Right: 2 [67%] [20.00dB]

    Noted. Good.




    I note capture 0 and 1 set to capture, and capture 2 switched OFF. I do not know your hardware, so I do not know what capture-0, nor capture-1, nor capture-2 mean in relation to your hardware (although I have suspicions). My understanding thou is the appropriate capture must be enabled to record audio - I think < but not sure > capture-0 is likely your front mic.
    Code:
    Simple mixer control 'Capture',0
      Capabilities: cvolume cswitch
      Capture channels: Front Left - Front Right
      Limits: Capture 0 - 31
      Front Left: Capture 31 [100%] [34.50dB] [on]
      Front Right: Capture 31 [100%] [34.50dB] [on]
    Simple mixer control 'Capture',1
      Capabilities: cvolume cswitch
      Capture channels: Front Left - Front Right
      Limits: Capture 0 - 31
      Front Left: Capture 31 [100%] [34.50dB] [on]
      Front Right: Capture 31 [100%] [34.50dB] [on]
    Simple mixer control 'Capture',2
      Capabilities: cvolume cswitch
      Capture channels: Front Left - Front Right
      Limits: Capture 0 - 31
      Front Left: Capture 27 [87%] [28.50dB] [off]
      Front Right: Capture 27 [87%] [28.50dB] [off]


    Capture needs to be ON right ?
    This is the Master for the Mic Capture ? Or are these separate controls for auxiliary capture devices ?




    You have an auto-mute mode set which could be complicating this:
    Code:
    Simple mixer control 'Auto-Mute Mode',0
      Capabilities: enum
      Items: 'Disabled' 'Speaker Only' 'Line Out Speaker'
      Item0: 'Line Out Speaker'
    I would recommend disabling the above auto-mute for this testing. We don't want the auto-mute disabling inappropriately blocking your recording efforts, while trying to figure out how your PC hardware works. ie change from "Line Out Speaker" to "Disabled".

    Noted ..Where do i do this change ?




    I note input source-0 set to Front Mic, and input source-1 set to Front Mic, and input source-2 set to Rear Mic
    Code:
    Simple mixer control 'Input Source',0
      Capabilities: cenum
      Items: 'Front Mic' 'Rear Mic' 'Line'
      Item0: 'Front Mic'
    Simple mixer control 'Input Source',1
      Capabilities: cenum
      Items: 'Front Mic' 'Rear Mic' 'Line'
      Item0: 'Front Mic'
    Simple mixer control 'Input Source',2
      Capabilities: cenum
      Items: 'Front Mic' 'Rear Mic' 'Line'
      Item0: 'Rear Mic'
    I don't know if setting 2 input sources (ie source 0 and source 1) to the same mic could cause an issue (I don't know as I don't have your hardware).


    Noted. I tried removing it via the xfce4-mixer but to no avail ...Will try a reboot or desktop restart




    Did you try the 'arecord' commands that I provided in an earlier post? Please try them. If you see any errors when trying them, please post the errors.

    Yes ... Just plain static when i run 'aplay soundtest.wav'

  10. #30

    Default Re: Audio Conferecing - Unable to get Microphone Working

    Hi ...Also my output of alsamixer ( from a terminal )
    shows my Card/Chip as PulseAudio ..

    alsamixer - https://pasteboard.co/Jwwj1tR.png

    Is this normal ? It doesnt show my mic as a capture source ?
    I have to goto F6 - > Select '0 HDA Intel' to get to the controls
    of the Front Mic as shown below;

    F6 - https://pasteboard.co/JwwkEnZ.png

Page 3 of 5 FirstFirst 12345 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •