Results 1 to 3 of 3

Thread: impossible to launch KDE-plasma on Leap15.2 on WSL2 virtual machine

  1. #1

    Post impossible to launch KDE-plasma on Leap15.2 on WSL2 virtual machine

    hi all,

    i recently installed openSUSE 15.2 on a virtual machine based W10 / WSL6, running on a AMD radeon (CPU + GPU) processor.

    yast is running only on text mode (yast --qt don't change anaything)

    i trie to launch plasmashel manually, i received :

    --------------------------
    admin@PC-AMD-Alain:~> plasmashell
    qt.qpa.xcb: could not connect to display
    qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
    qt.qpa.plugin: Could not find the Qt platform plugin "wayland" in ""
    This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.


    Available platform plugins are: wayland-org.kde.kwin.qpa, eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.


    Aborted

    ---------------------

    i saw many of this type of messages on forums & internet, but never a working a solution

    other important information : i'm a new new new linux user

    many thanks for your time

  2. #2

    Default SOLVED - Re: impossible to launch KDE-plasma on Leap15.2 on WSL2 virtual machine

    Hello dears,

    i read WSL 2 doesn't support graphical environments...
    solution : in windows, just launch a X server (VcXsrv) and then, from terminal screen launch the app. it works !

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,285
    Blog Entries
    2

    Default Re: impossible to launch KDE-plasma on Leap15.2 on WSL2 virtual machine

    Officially,
    I don't think that a graphical DE is supposed to be supported... just yet.

    But, there are some articles around that describe exporting your display to localhost (127.0.9.1) which passes to your Windows graphics driver, and then you can SSH into your graphical Desktop.

    I haven't tried that yet, but it's supposed to either work now or soon... Might require Windows Build 2004 instead of the more normal 1909.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •