Results 1 to 5 of 5

Thread: GOG linux games ubuntu - running on opensuse - KDE

  1. #1

    Default GOG linux games ubuntu - running on opensuse - KDE

    I'm fully up to date on all software.

    I tried to run the GOG linux game XRebirth, but I was unable to get sound working. I can duel boot with Ubuntu, assuming this is same one GOG references.

    https://ubuntu.com/

    Is any there compatibility mode in opensuse, like mswin? Running it in a virtual environment? (slower). Is there some other mode to emulate it?

    I tried getting help getting it to run, no one answered. There are other games I can try. Like Neverwinter Nights

    Need help...

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    27,331

    Default Re: GOG linux games ubuntu - running on opensuse - KDE

    Moved to Games, because that is where the gamers are supposed to watch.
    Henk van Velden

  3. #3

    Default Re: GOG linux games ubuntu - running on opensuse - KDE

    https://gist.github.com/ubervison/1f...fca0bedaf5ad2d

    Prerequisites

    First make sure that you have the following tools and libraries installed on your system:
    innoextract, unzip, 7z, tar, unrar (to extract the game files)
    For the nwmovies, nwlogger, nwuser and nwmouse tools, you will need the 32-bit version of these libraries, including their development headers (-dev or -devel packages):
    elfutils
    glulibgl
    libstdc++5
    libxcursor
    openal
    perl
    sdl_mixer
    SDL-1.2
    libX11
    zlib


    These are the libraries it needs. Does opensuse have all of them?

  4. #4

    Default Re: GOG linux games ubuntu - running on opensuse - KDE

    Code:
    # ldd --version
    ldd (GNU libc) 2.26
    Copyright (C) 2017 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions.  There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
    Written by Roland McGrath and Ulrich Drepper.
    This game needs v2.27 Can opensuse upgrade it?

  5. #5

    Default Re: GOG linux games ubuntu - running on opensuse - KDE

    Does this help?

    https://software.opensuse.org/package/glibc

    There is also 2.27 for openSUSE leap. Click the red square.

    For Tumbleweed this problem should not exist from what I found on the net. Newer versions of gibc should be backwards compatible with older versions.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •