Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 37

Thread: LEAP 15.2 Yast Error Failed to load Module 'Packages'

  1. #11

    Default Re: LEAP 15.2 Yast Error Failed to load Module 'Packages'

    OK, I had actually used zypper to remove the older kernel:

    [CODE]zypper rm kernel-syms-4.12.14-lp151.28.67.1.x86_64
    zypper rm kernel-default-devel-4.12.14-lp151.28.67.2.x86_64
    zypper rm kernel-source-4.12.14-lp151.28.67.1.noarch
    zypper rm kernel-devel-4.12.14-lp151.28.67.1.noarch
    zypper rm kernel-default-4.12.14-lp151.28.67.2.x86_64[CODE]

    Rebooted, still

    Code:
    uname -aLinux linux-3wjh.site 5.3.18-lp152.41-default #1 SMP Thu Sep 3 23:02:59 UTC 2020 (a4d139b) x86_64 x86_64 x86_64 GNU/Linux
    Then ran the prescribed commands again:

    Code:
    zypper dup --allow-vendor-change --from Packman


    and

    Code:
    LANG=C zypper se -si | grep -Ei 'systemp|system-p|system p|system_p'
    
    i+ | Q7Z                                          | package | 0.8.0-1.5                                       | noarch | (System Packages)
    i+ | VirtualBox-6.0                               | package | 6.0.14_133895_openSUSE150-1                     | x86_64 | (System Packages)
    i+ | VirtualBox-6.1                               | package | 6.1.14_140239_openSUSE150-1                     | x86_64 | (System Packages)
    i  | adwaita-qt-common                            | package | 0.3-1.1                                         | x86_64 | (System Packages)
    i+ | agnclient                                    | package | 1.0-2.0.1.3000c                                 | i386   | (System Packages)
    i  | aspell-en-huge                               | package | 6.0-164.2                                       | x86_64 | (System Packages)
    i+ | avidemux3-help                               | package | 2.6.12-1.3                                      | noarch | (System Packages)
    i+ | chromium-pdf-plugin                          | package | 17.0.0.134-1.1                                  | x86_64 | (System Packages)
    i+ | code                                         | package | 1.49.2-1600965486.el7                           | x86_64 | (System Packages)
    i+ | expressvpn                                   | package | 2.6.3.3-1                                       | x86_64 | (System Packages)
    i  | gconf-cleaner                                | package | 0.0.3-0.pm.2.1                                  | i586   | (System Packages)
    i  | gmerlin-jpeg                                 | package | 1.0.0-39.36                                     | x86_64 | (System Packages)
    i  | gmerlin-x11                                  | package | 1.0.0-39.36                                     | x86_64 | (System Packages)
    i+ | google-earth-pro-stable                      | package | 7.3.3.7699-0                                    | x86_64 | (System Packages)
    i  | gsk7bas                                      | package | 7.0-3.18                                        | i386   | (System Packages)
    i+ | heldenviewer                                 | package | 1.0.5-3.2                                       | x86_64 | (System Packages)
    i+ | libHalf12                                    | package | 2.2.0-4.3                                       | x86_64 | (System Packages)
    i+ | libIex-2_2-12                                | package | 2.2.0-4.3                                       | x86_64 | (System Packages)
    i+ | libIlmThread-2_2-12                          | package | 2.2.0-4.3                                       | x86_64 | (System Packages)
    i+ | libaudcore1                                  | package | 3.4.2-1.1                                       | x86_64 | (System Packages)
    i+ | libaudcore2                                  | package | 3.5.2-3.1                                       | x86_64 | (System Packages)
    i+ | libaudcore3                                  | package | 3.7.2-1.3                                       | x86_64 | (System Packages)
    i+ | libaudgui1                                   | package | 3.4.2-1.1                                       | x86_64 | (System Packages)
    i+ | libaudgui2                                   | package | 3.5.2-3.1                                       | x86_64 | (System Packages)
    i+ | libaudgui3                                   | package | 3.7.2-1.3                                       | x86_64 | (System Packages)
    i+ | libaudio2                                    | package | 1.9.4-1.6                                       | x86_64 | (System Packages)
    i+ | libaudqt0                                    | package | 3.7.2-1.3                                       | x86_64 | (System Packages)
    i+ | libaudtag1                                   | package | 3.5.2-3.1                                       | x86_64 | (System Packages)
    i+ | libaudtag2                                   | package | 3.7.2-1.3                                       | x86_64 | (System Packages)
    i+ | libavformat58_45                             | package | 4.3.1-6.6                                       | x86_64 | (System Packages)
    i+ | libbinio1                                    | package | 1.4-4.4                                         | x86_64 | (System Packages)
    i+ | libdvdcss2                                   | package | 1.4.2-lp150.1.2                                 | x86_64 | (System Packages)
    i  | libebml3                                     | package | 1.2.2-8.1.2                                     | x86_64 | (System Packages)
    i+ | libfdk-aac1                                  | package | 0.1.6-pm151.2.3                                 | x86_64 | (System Packages)
    i+ | libgmyth0                                    | package | 0.7.1-12.7                                      | x86_64 | (System Packages)
    i  | libgpac2                                     | package | 0.5.0.svn4668-3.61                              | x86_64 | (System Packages)
    i+ | libgpac4                                     | package | 0.5.2-4.2                                       | x86_64 | (System Packages)
    i+ | libgpac6                                     | package | 0.6.1-10.2                                      | x86_64 | (System Packages)
    i  | libgpac8                                     | package | 0.8.0-pm151.1.10                                | x86_64 | (System Packages)
    i  | libgssdp-1_0-2                               | package | 0.8.2-2.1                                       | x86_64 | (System Packages)
    i  | libgupnp-1_0-3                               | package | 0.14.1-3.1                                      | x86_64 | (System Packages)
    i  | libicu-suse64_2                              | package | 64.2-lp151.3.3.1                                | x86_64 | (System Packages)
    i  | libicu64_2-ledata                            | package | 64.2-lp151.3.3.1                                | noarch | (System Packages)
    i  | libjs1                                       | package | 1.8.0-2.2                                       | x86_64 | (System Packages)
    i  | libmatroska3                                 | package | 1.1.0-0.pm.31.1                                 | x86_64 | (System Packages)
    i  | libmatroska4                                 | package | 1.2.0-1.pm.33.1                                 | x86_64 | (System Packages)
    i  | libmetacity3                                 | package | 3.37.1-lp151.1.1                                | x86_64 | (System Packages)
    i  | libmlt4                                      | package | 0.7.8-2.8.1                                     | x86_64 | (System Packages)
    i  | libmp4v2-0                                   | package | 2.0-14.37                                       | x86_64 | (System Packages)
    i  | libmp4v2-1                                   | package | 1.9.1-2.5                                       | x86_64 | (System Packages)
    i+ | libmp4v2-2                                   | package | 2.0.0-1.5                                       | x86_64 | (System Packages)
    i+ | libmp4v2-devel                               | package | 2.0.0-1.5                                       | x86_64 | (System Packages)
    i+ | libmysqlclient18                             | package | 10.0.35-35.1                                    | x86_64 | (System Packages)
    i  | liboil-0_3-0                                 | package | 0.3.17-1.pm.2.5                                 | i586   | (System Packages)
    i+ | libopencore-amrnb0-32bit                     | package | 0.1.5-1.47                                      | x86_64 | (System Packages)
    i+ | libopencore-amrwb0-32bit                     | package | 0.1.5-1.47                                      | x86_64 | (System Packages)
    i  | liborc0_4-0                                  | package | 0.4.6-0.pm.1.1                                  | i586   | (System Packages)
    i+ | libreoffice6.0-ure                           | package | 6.0.4.2-2                                       | x86_64 | (System Packages)
    i  | libresid-builder0                            | package | 2.1.1-8.1                                       | x86_64 | (System Packages)
    i  | libresid0                                    | package | 2.1.1-8.1                                       | x86_64 | (System Packages)
    i  | librtmp0                                     | package | 2.4.git20121102-1.3                             | x86_64 | (System Packages)
    i  | libsidplay2-1                                | package | 2.1.1-8.1                                       | x86_64 | (System Packages)
    i+ | libslv2-9                                    | package | 0.6.6-4.7                                       | x86_64 | (System Packages)
    i  | libstdc++33-32bit                            | package | 3.3.3-41.1.3                                    | x86_64 | (System Packages)
    i  | libthreadutil3                               | package | 1.6.10-1.pm.1.2                                 | x86_64 | (System Packages)
    i  | libupnp3                                     | package | 1.6.6-2.pm.2.1                                  | x86_64 | (System Packages)
    i+ | libvo-aacenc0-32bit                          | package | 0.1.3-1.37                                      | x86_64 | (System Packages)
    i+ | libweed0                                     | package | 2.8.9-1.61                                      | x86_64 | (System Packages)
    i+ | libwx_baseu-nostl1                           | package | 3.0.2-1.2                                       | x86_64 | (System Packages)
    i+ | libwx_baseu_net-nostl1                       | package | 3.0.2-1.2                                       | x86_64 | (System Packages)
    i+ | libwx_baseu_xml-nostl1                       | package | 3.0.2-1.2                                       | x86_64 | (System Packages)
    i+ | libx264-152                                  | package | 0.152svn20180305-lp150.3.2                      | x86_64 | (System Packages)
    i+ | libx264-155                                  | package | 0.155svn20190201-pm151.3.1                      | x86_64 | (System Packages)
    i  | libx264-157                                  | package | 0.157svn20191217-pm151.1.1                      | x86_64 | (System Packages)
    i+ | libx264-159                                  | package | 0.159+git20191127.1771b556-pm151.3.1            | x86_64 | (System Packages)
    i+ | libx265-151                                  | package | 2.7-lp150.3.1                                   | x86_64 | (System Packages)
    i+ | libx265-165                                  | package | 2.9-lp150.1.4                                   | x86_64 | (System Packages)
    i+ | libx265-169                                  | package | 3.0-lp150.1.7                                   | x86_64 | (System Packages)
    i+ | libx265-176                                  | package | 3.1.2-lp151.1.2                                 | x86_64 | (System Packages)
    i+ | libx265-179                                  | package | 3.2.1-pm151.3.3                                 | x86_64 | (System Packages)
    i+ | libx265-188                                  | package | 3.3-pm151.1.2                                   | x86_64 | (System Packages)
    i  | melt4                                        | package | 0.7.8-2.8.1                                     | x86_64 | (System Packages)
    i  | mozilla-js                                   | package | 17.0.10-1.1                                     | x86_64 | (System Packages)
    i  | openSUSE-release-dvd                         | package | 15.2-lp152.575.1                                | x86_64 | (System Packages)
    i+ | opera-stable                                 | package | 71.0.3770.171-0                                 | x86_64 | (System Packages)
    i+ | purple-facebook                              | package | 20170608~c40d9fa~c9b74a765767~128-1.1           | x86_64 | (System Packages)
    i+ | teams                                        | package | 1.3.00.16851-1                                  | x86_64 | (System Packages)
    i+ | teams-insiders                               | package | 1.3.00.25560-1                                  | x86_64 | (System Packages)
    i+ | telepathy-account-widgets                    | package | 20140203-1.ram0.99                              | i686   | (System Packages)
    i+ | zoom                                         | package | 5.1.418436.0628_openSUSE-1                      | x86_64 | (System Packages)
    From YaST -> Online Update, I still see the newer 15.2 kernel.

    Other YaST operation yield the same error as previously stated.

  2. #12
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,885

    Default AW: LEAP 15.2 Yast Error Failed to load Module 'Packages'

    You can delete most of the packages shown in the thread before.

    Leap 15.2 has an lp152 string in their Version number.
    See above, there are packages without any lp15x string, some with lp150 orlp151 in their version string.
    These are all outdated packages and can be removed.
    Also packages without these lp152 string.

    But this is not your problem. have you done such an command as here:
    https://forums.opensuse.org/showthre...12#post2923012

  3. #13

    Default Re: LEAP 15.2 Yast Error Failed to load Module 'Packages'

    I ran through the step described in

    https://forums.opensuse.org/showthre...12#post2923012

    Code:
    /var/lib/YaST2 # ls -ltotal 6016
    .
    .-rw------- 1 root root    1108 Sep 29 07:06 system_packages_repos.yaml
    .
    .
    
    /var/lib/YaST2 # ls -l
    
    <file deleted>
    Restarted YaST, same issue still.

  4. #14

    Default Re: LEAP 15.2 Yast Error Failed to load Module 'Packages'

    Forgot to add

    Code:
    /var/lib/YaST2 # rm system_packages_repos.yaml
    to my previous post.

  5. #15
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,885

    Default AW: LEAP 15.2 Yast Error Failed to load Module 'Packages'

    Try
    Code:
    zypper in -f ruby2.5-rubygem-gem2rpm ruby2.5-rubygem-fast_gettext ruby2.5-rubygem-ruby-augeas ruby2.5-rubygem-ruby-dbus

  6. #16

    Default Re: LEAP 15.2 Yast Error Failed to load Module 'Packages'

    The prescribed command and output:

    Code:
    zypper in -f ruby2.5-rubygem-gem2rpm ruby2.5-rubygem-fast_gettext ruby2.5-rubygem-ruby-augeas ruby2.5-rubygem-ruby-dbusLoading repository data...
    Reading installed packages...
    Forcing installation of 'ruby2.5-rubygem-gem2rpm-0.10.1-lp152.5.26.x86_64' from repository 'openSUSE-Leap-15.2-1'.
    Forcing installation of 'ruby2.5-rubygem-fast_gettext-1.6.0-lp152.3.5.x86_64' from repository 'openSUSE-Leap-15.2-1'.
    Forcing installation of 'ruby2.5-rubygem-ruby-augeas-0.5.0-lp152.3.6.x86_64' from repository 'openSUSE-Leap-15.2-1'.
    Forcing installation of 'ruby2.5-rubygem-ruby-dbus-0.14.0-lp152.3.4.x86_64' from repository 'openSUSE-Leap-15.2-1'.
    Resolving package dependencies...
    
    
    The following 4 packages are going to be reinstalled:
      ruby2.5-rubygem-fast_gettext ruby2.5-rubygem-gem2rpm ruby2.5-rubygem-ruby-augeas ruby2.5-rubygem-ruby-dbus
    
    
    4 packages to reinstall.
    Overall download size: 295.4 KiB. Already cached: 0 B. No additional space will be used or freed after the operation.
    Continue? [y/n/v/...? shows all options] (y): 
    Retrieving package ruby2.5-rubygem-fast_gettext-1.6.0-lp152.3.5.x86_64                                                                            (1/4),  57.9 KiB (100.1 KiB unpacked)
    Retrieving: ruby2.5-rubygem-fast_gettext-1.6.0-lp152.3.5.x86_64.rpm .............................................................................................................[done]
    Retrieving package ruby2.5-rubygem-gem2rpm-0.10.1-lp152.5.26.x86_64                                                                               (2/4),  42.3 KiB ( 60.7 KiB unpacked)
    Retrieving: ruby2.5-rubygem-gem2rpm-0.10.1-lp152.5.26.x86_64.rpm ................................................................................................................[done]
    Retrieving package ruby2.5-rubygem-ruby-augeas-0.5.0-lp152.3.6.x86_64                                                                             (3/4),  58.6 KiB (108.8 KiB unpacked)
    Retrieving: ruby2.5-rubygem-ruby-augeas-0.5.0-lp152.3.6.x86_64.rpm ..............................................................................................................[done]
    Retrieving package ruby2.5-rubygem-ruby-dbus-0.14.0-lp152.3.4.x86_64                                                                              (4/4), 136.5 KiB (259.4 KiB unpacked)
    Retrieving: ruby2.5-rubygem-ruby-dbus-0.14.0-lp152.3.4.x86_64.rpm ...............................................................................................................[done]
    
    
    Checking for file conflicts: ....................................................................................................................................................[done]
    (1/4) Installing: ruby2.5-rubygem-fast_gettext-1.6.0-lp152.3.5.x86_64 ...........................................................................................................[done]
    (2/4) Installing: ruby2.5-rubygem-gem2rpm-0.10.1-lp152.5.26.x86_64 ..............................................................................................................[done]
    (3/4) Installing: ruby2.5-rubygem-ruby-augeas-0.5.0-lp152.3.6.x86_64 ............................................................................................................[done]
    (4/4) Installing: ruby2.5-rubygem-ruby-dbus-0.14.0-lp152.3.4.x86_64 .............................................................................................................[done]
    YaST still produces that same error:

    Code:
    Internal error. Please report a bug report with logs.Run save_y2logs to get complete logs.
    
    Caller: /usr/lib64/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
    
    Details: Failed to load Module 'Packages' due to: Failed to load Module 'AddOnProduct' due to: cannot load such file -- y2packager/repository

  7. #17

    Default Re: LEAP 15.2 Yast Error Failed to load Module 'Packages'

    Here is the tail of the YaST log when I attempted to start the Software Management from the GUI:

    Code:
    2020-10-01 09:22:09 <1> linux-3wjh.site(31397) [Ruby] modules/Progress.rb:343 Progress::New(Starting the Software Manager, 2, ["Initialize the Target System", "Load the Configured Repositories"])2020-10-01 09:22:09 <3> linux-3wjh.site(31397) [Y2Ruby] binary/Y2RubyUtils.cc(y2_require):26 cannot require yast:cannot load such file -- y2packager/repository at /usr/lib64/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
    2020-10-01 09:22:09 <3> linux-3wjh.site(31397) [Y2Ruby] binary/Y2RubyComponent.cc(import):100 Reporting runtime error for import of module 'AddOnProduct' message 'cannot load such file -- y2packager/repository'
    2020-10-01 09:22:09 <3> linux-3wjh.site(31397) [Interpreter] yast/i18n.rb:169 Runtime error when loading module 'AddOnProduct'
    2020-10-01 09:22:09 <3> linux-3wjh.site(31397) [Y2Ruby] binary/Y2RubyUtils.cc(y2_require):26 cannot require yast:Failed to load Module 'AddOnProduct' due to: cannot load such file -- y2packager/repository at /usr/lib64/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
    2020-10-01 09:22:09 <3> linux-3wjh.site(31397) [Y2Ruby] binary/Y2RubyComponent.cc(import):100 Reporting runtime error for import of module 'Packages' message 'Failed to load Module 'AddOnProduct' due to: cannot load such file -- y2packager/repository'
    2020-10-01 09:22:09 <3> linux-3wjh.site(31397) [Interpreter] yast/i18n.rb:169 Runtime error when loading module 'Packages'
    2020-10-01 09:22:09 <2> linux-3wjh.site(31397) [Ruby] yast/builtins.rb:586 tostring builtin called on wrong type Class
    2020-10-01 09:22:09 <3> linux-3wjh.site(31397) [Ruby] yast/wfm.rb:253 Client /usr/share/YaST2/clients/sw_single.rb failed with 'Failed to load Module 'Packages' due to: Failed to load Module 'AddOnProduct' due to: cannot load such file -- y2packager/repository' (RuntimeError).
    Backtrace:
    /usr/lib64/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
    /usr/lib64/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
    /usr/share/YaST2/modules/AddOnProduct.rb:7:in `<top (required)>'
    /usr/lib64/ruby/vendor_ruby/2.5.0/yast/yast.rb:186:in `import_pure'
    /usr/lib64/ruby/vendor_ruby/2.5.0/yast/yast.rb:186:in `import'
    /usr/share/YaST2/modules/Packages.rb:47:in `main'
    /usr/share/YaST2/modules/Packages.rb:2714:in `<module:Yast>'
    /usr/share/YaST2/modules/Packages.rb:15:in `<top (required)>'
    /usr/lib64/ruby/vendor_ruby/2.5.0/yast/yast.rb:186:in `import_pure'
    /usr/lib64/ruby/vendor_ruby/2.5.0/yast/yast.rb:186:in `import'
    /usr/share/YaST2/clients/sw_single.rb:512:in `StartSWSingle'
    /usr/share/YaST2/clients/sw_single.rb:76:in `main'
    /usr/share/YaST2/clients/sw_single.rb:819:in `<top (required)>'
    /usr/lib64/ruby/vendor_ruby/2.5.0/yast/wfm.rb:318:in `eval'
    /usr/lib64/ruby/vendor_ruby/2.5.0/yast/wfm.rb:318:in `run_client'
    /usr/lib64/ruby/vendor_ruby/2.5.0/yast/wfm.rb:206:in `call_builtin'
    /usr/lib64/ruby/vendor_ruby/2.5.0/yast/wfm.rb:206:in `call_builtin_wrapper'
    /usr/lib64/ruby/vendor_ruby/2.5.0/yast/wfm.rb:195:in `CallFunction'
    /usr/lib/YaST2/bin/y2start:60:in `<main>'
    2020-10-01 09:22:09 <3> linux-3wjh.site(31397) [Ruby] yast/wfm.rb:281 Internal error. Please report a bug report with logs.<br />Run save_y2logs to get complete logs.<br /><br />Caller:  /usr/lib64/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'<br /><br />Details: Failed to load Module 'Packages' due to: Failed to load Module 'AddOnProduct' due to: cannot load such file -- y2packager/repository
    2020-10-01 09:22:09 <1> linux-3wjh.site(31397) [ui] YPushButton.cc(setFunctionKey):202 Guessing button role YOKButton for YPushButton "OK" at 0x7f7308484930 from function key F10

  8. #18
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,885

    Default AW: LEAP 15.2 Yast Error Failed to load Module 'Packages'

    As root:
    Code:
    zypper in -f ruby2.5-stdlib

  9. #19
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,885

    Default AW: LEAP 15.2 Yast Error Failed to load Module 'Packages'

    I would install all installed ruby packages once more.
    Code:
    zypper se -si ruby
    copy/paste them to another Terminal to install them with:
    Code:
    zypper in -f

  10. #20

    Default Re: LEAP 15.2 Yast Error Failed to load Module 'Packages'

    I have performed the prescribed re-installation as prescribed with

    Code:
     zypper in -f


    This output is the same both before and after:

    Code:
    # zypper se -si rubyLoading repository data...
    Reading installed packages...
    
    
    S  | Name                            | Type    | Version            | Arch   | Repository
    ---+---------------------------------+---------+--------------------+--------+-----------------------
    i+ | libruby2_5-2_5                  | package | 2.5.8-lp152.1.11   | x86_64 | Main Repository
    i+ | libstorage-ng-ruby              | package | 4.2.76-lp152.2.6.1 | x86_64 | Main Update Repository
    i  | ruby                            | package | 2.5-lp152.3.6      | x86_64 | Main Repository
    i+ | ruby-common                     | package | 2.1-lp152.5.2      | noarch | Main Repository
    i  | ruby-solv                       | package | 0.7.14-lp152.2.7.1 | x86_64 | Main Update Repository
    i+ | ruby2.5                         | package | 2.5.8-lp152.1.11   | x86_64 | Main Repository
    i  | ruby2.5-rubygem-abstract_method | package | 1.2.1-lp152.3.5    | x86_64 | Main Repository
    i  | ruby2.5-rubygem-cfa             | package | 1.0.2-lp152.1.1    | x86_64 | Main Repository
    i+ | ruby2.5-rubygem-cfa_grub2       | package | 2.0.0-lp152.1.5    | x86_64 | Main Repository
    i  | ruby2.5-rubygem-cheetah         | package | 0.5.2-lp152.1.1    | x86_64 | Main Repository
    i+ | ruby2.5-rubygem-fast_gettext    | package | 1.6.0-lp152.3.5    | x86_64 | Main Repository
    i+ | ruby2.5-rubygem-gem2rpm         | package | 0.10.1-lp152.5.26  | x86_64 | Main Repository
    i+ | ruby2.5-rubygem-ruby-augeas     | package | 0.5.0-lp152.3.6    | x86_64 | Main Repository
    i+ | ruby2.5-rubygem-ruby-dbus       | package | 0.14.0-lp152.3.4   | x86_64 | Main Repository
    i  | ruby2.5-rubygem-simpleidn       | package | 0.0.9-lp152.3.5    | x86_64 | Main Repository
    i+ | ruby2.5-stdlib                  | package | 2.5.8-lp152.1.11   | x86_64 | Main Repository
    i  | yast2-ruby-bindings             | package | 4.2.8-lp152.1.3    | x86_64 | Main Repository
    with the listed Main Repository being

    Code:
     zypper lr -d#  | Alias                     | Name                               | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                      | Service
    ---+---------------------------+------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------+--------
     1 | MS_Teams                  | MS_Teams                           | Yes     | (r ) Yes  | Yes     |   90     | NONE   | https://packages.microsoft.com/opensuse/15/prod/                         | 
     2 | NVIDIA                    | NVIDIA                             | Yes     | (r ) Yes  | Yes     |   99     | NONE   | https://download.nvidia.com/opensuse/leap/15.2                           | 
     3 | Packman                   | Packman                            | Yes     | (r ) Yes  | Yes     |   90     | NONE   | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.2/       | 
     4 | VLC_repo                  | VLC_repo                           | Yes     | (r ) Yes  | Yes     |   90     | NONE   | http://download.videolan.org/pub/vlc/SuSE/Leap_15.2/                     | 
     5 | openSUSE-Leap-15.2-1      | openSUSE-Leap-15.2-1               | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/oss/            | 
     6 | repo-debug                | Debug Repository                   | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/distribution/leap/15.2/repo/oss/      | 
     7 | repo-debug-non-oss        | Debug Repository (Non-OSS)         | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/distribution/leap/15.2/repo/non-oss/  | 
     8 | repo-debug-update         | Update Repository (Debug)          | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/update/leap/15.2/oss/                 | 
     9 | repo-debug-update-non-oss | Update Repository (Debug, Non-OSS) | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/debug/update/leap/15.2/non-oss/             | 
    10 | repo-non-oss              | Non-OSS Repository                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/non-oss/        | 
    11 | repo-oss                  | Main Repository                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/oss/            | 
    12 | repo-source               | Source Repository                  | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/source/distribution/leap/15.2/repo/oss/     | 
    13 | repo-source-non-oss       | Source Repository (Non-OSS)        | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/source/distribution/leap/15.2/repo/non-oss/ | 
    14 | repo-update               | Main Update Repository             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.2/oss                        | 
    15 | repo-update-non-oss       | Update Repository (Non-Oss)        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.2/non-oss/                   |
    Same error from YaST.

Page 2 of 4 FirstFirst 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •