Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: xterm changed layout

  1. #1
    Join Date
    Nov 2008
    Location
    Bath UK
    Posts
    278

    Default xterm changed layout

    Not sure this is te correct forum but...

    A couple of days ago when i booted my Lenovo X270 Thinkpad I noticed many of the keys had changed (#now sift-3 rater than the laelled key extree right). Also my attemt to disable capslock no longer worked.

    using yast2 I said I had an English UK keyboard and some stuff returned to @normal@ but it did not survive a rebot.

    I am sure i never fiddled with that area; I have been regulatly running zypper up

    I do not run gnome or kde, but fvwm with xterm and emacs mainly. No desktop in the common meaning.

    Any suggestions as how to recover a keyboard that corresponds to the labels on the keys?

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,734
    Blog Entries
    2

    Default Re: xterm changed layout

    Running just a WM and not a full Desktop,
    I'd expect that your system settings would be the only place to set language and locale.

    Not knowing exactly what you did in YaST,
    Here is the specific documentation that should apply to your situation

    https://doc.opensuse.org/documentati...2.lang.primsec

    Just out of curiosity, just doublechecking that you know that you are supposed to use the Alternatives sub-system (command update-alternatives) to set your WM as well as selecting fvwm2 if necessary from the logon screen?

    HTH,
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Nov 2008
    Location
    Bath UK
    Posts
    278

    Default Re: xterm changed layout

    Quote Originally Posted by tsu2 View Post
    Running just a WM and not a full Desktop,
    I'd expect that your system settings would be the only place to set language and locale.

    Not knowing exactly what you did in YaST,
    Here is the specific documentation that should apply to your situation

    https://doc.opensuse.org/documentati...2.lang.primsec

    Just out of curiosity, just doublechecking that you know that you are supposed to use the Alternatives sub-system (command update-alternatives) to set your WM as well as selecting fvwm2 if necessary from the logon screen?

    HTH,
    TSU
    I cannot see how any of this relates. I have been running this scheme for decades and it suddenly changed the keyboard to US (I think). The two questions are why did it happen and how to restore what was the case.
    The logon screen is standard xdm and all I need are my user name and my password.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,411
    Blog Entries
    3

    Default Re: xterm changed layout

    Quote Originally Posted by jpff View Post
    The two questions are why did it happen and how to restore what was the case.
    I don't know the answer.

    I use "xterm" a lot, but I have not noticed any problems. But maybe I wouldn't notice because I use a US keyboard anyway.

    Have you check the Yast settings:

    Yast --> System --> Language
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

  5. #5
    Join Date
    Nov 2008
    Location
    Bath UK
    Posts
    278

    Default Re: xterm changed layout

    Quote Originally Posted by nrickert View Post
    I don't know the answer.

    I use "xterm" a lot, but I have not noticed any problems. But maybe I wouldn't notice because I use a US keyboard anyway.

    Have you check the Yast settings:

    Yast --> System --> Language
    Yes I checked and it was EnglishUK. I think the culprit might be iceWM which seems to have been installed/updated recently and changed alternatives/default-xsession.desktop but we may see when I reboot tomorrow

  6. #6
    Join Date
    Nov 2008
    Location
    Bath UK
    Posts
    278

    Default Re: xterm changed layout

    Just booted this computer and the provem persists.

    owever There is a little more information;

    1: I used yast to configure the keyboard as UK. The first artempt changed nothing. -- still got \ for # key. Tried again with yast2 but this time it changed it.

    2: Now when Ido things I get messages ****
    svn: warning: cannot set LC_CTYPE locale
    svn: warning: environment variable LC_CTYPE is en_US.UTF-8,LANG=en_GB.UTF-8
    svn: warning: please check that your locale name is correct
    Updating '.':

    I have not knowing changed anything to do with locales. Where should I find the configuration and what should it say?

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,411
    Blog Entries
    3

    Default Re: xterm changed layout

    You can check your ".bashrc" and ".profile".

    If you are not setting those variables there, then it is probably being done in "/etc/bash.bashrc" and related files.

    If you can find a good setting, you can put that in your own ".bashrc".
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

  8. #8
    Join Date
    Nov 2008
    Location
    Bath UK
    Posts
    278

    Default Re: xterm changed layout

    Just booted this computer and the provem persists.

    owever There is a little more information;

    1: I used yast to configure the keyboard as UK. The first artempt changed nothing. -- still got \ for # key. Tried again with yast2 but this time it changed it.

    2: Now when Ido things I get messages ****
    svn: warning: cannot set LC_CTYPE locale
    svn: warning: environment variable LC_CTYPE is en_US.UTF-8,LANG=en_GB.UTF-8
    svn: warning: please check that your locale name is correct
    Updating '.':

    I have not knowing changed anything to do with locales. Where should I find the configuration and what should it say?

  9. #9
    Join Date
    Nov 2008
    Location
    Bath UK
    Posts
    278

    Default Re: xterm changed layout

    Quote Originally Posted by nrickert View Post
    You can check your ".bashrc" and ".profile".

    If you are not setting those variables there, then it is probably being done in "/etc/bash.bashrc" and related files.

    If you can find a good setting, you can put that in your own ".bashrc".
    I do not use bash normally, always csh but I looked at those files and did not see any reference to locales.
    Not sure what a good setting is -- I just want the keys on the keyboard to correspond to the character on the screen.

  10. #10
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,411
    Blog Entries
    3

    Default Re: xterm changed layout

    I actually use "csh", but most people use bash.

    For "csh", the files are ".cshrc" and ".login" in your home directory. And the system-wide files are "/etc/csh.cshrc" and "/etc/csh.login". The system-wide shell startup files also source some files from "/etc/profile.d". Possibly "/etc/profile.d/lang.csh" is the one causing problems for you.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •