Results 1 to 8 of 8

Thread: libvkd3d1-32bit-1.2-1.1.x86_64 requires libvkd3d-shader.so.1, but this requirement cannot be provide

  1. #1
    Join Date
    Jul 2020
    Posts
    6

    Default libvkd3d1-32bit-1.2-1.1.x86_64 requires libvkd3d-shader.so.1, but this requirement cannot be provide

    Hi,

    The latest Tumbleweed updates are causing zypper some problems resolving dependencies.
    I don't know if I've screwed up something or if it's a packaging problem/bug, and would like some advice on the matter and how to proceed please.

    First off, my repo list is as follows:
    Code:
    zypper lr -P
    
    # | Alias                            | Name                       | Enabled | GPG Check | Refresh | Priority
    --+----------------------------------+----------------------------+---------+-----------+---------+---------
    4 | packman-essentials               | packman-essentials         | Yes     | (r ) Yes  | Yes     |   90
    5 | packman-multimedia               | packman-multimedia         | Yes     | (r ) Yes  | Yes     |   90
    1 | download.opensuse.org-non-oss    | Main Repository (NON-OSS)  | Yes     | (r ) Yes  | Yes     |   99
    2 | download.opensuse.org-oss        | Main Repository (OSS)      | Yes     | (r ) Yes  | Yes     |   99
    3 | download.opensuse.org-tumbleweed | Main Update Repository     | Yes     | (r ) Yes  | Yes     |   99
    6 | repo-debug                       | openSUSE-Tumbleweed-Debug  | No      | ----      | ----    |   99
    7 | repo-source                      | openSUSE-Tumbleweed-Source | No      | ----      | ----    |   99
    The actual output from zypper dup is as follows:
    Code:
    sudo zypper dup -dD --details
    Loading repository data...
    Reading installed packages...
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Computing distribution upgrade...
    
    Problem: libvkd3d1-32bit-1.2-1.1.x86_64 requires libvkd3d-shader.so.1, but this requirement cannot be provided
      not installable providers: libvkd3d-shader1-1.2-1.1.i586[download.opensuse.org-oss]
     Solution 1: Following actions will be done:
      deinstallation of libvkd3d1-32bit-1.1-2.1.x86_64
      deinstallation of wine-mono-5.1.0-2.2.noarch
     Solution 2: install libvkd3d-shader1-1.2-1.1.i586 despite the inferior architecture
     Solution 3: keep obsolete libvkd3d1-32bit-1.1-2.1.x86_64
     Solution 4: break libvkd3d1-32bit-1.2-1.1.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/3/4/c/d/?] (c): c
    I tried searching for a package called libvkd3d-shader and got the following output:
    Code:
    zypper search -s libvkd3d-shader
    Loading repository data...
    Reading installed packages...
    
    S | Name             | Type    | Version | Arch   | Repository
    --+------------------+---------+---------+--------+----------------------
      | libvkd3d-shader1 | package | 1.2-1.1 | x86_64 | Main Repository (OSS)
      | libvkd3d-shader1 | package | 1.2-1.1 | i586   | Main Repository (OSS)
    Essentially, for zypper to perform a dup it wants to change wine and a library from x86_64 to i586:
    Code:
    sudo zypper dup -dD                        
    Loading repository data...
    Reading installed packages...
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Computing distribution upgrade...
    
    Problem: libvkd3d1-32bit-1.2-1.1.x86_64 requires libvkd3d-shader.so.1, but this requirement cannot be provided
      not installable providers: libvkd3d-shader1-1.2-1.1.i586[download.opensuse.org-oss]
     Solution 1: Following actions will be done:
      deinstallation of libvkd3d1-32bit-1.1-2.1.x86_64
      deinstallation of wine-mono-5.1.0-2.2.noarch
     Solution 2: install libvkd3d-shader1-1.2-1.1.i586 despite the inferior architecture
     Solution 3: keep obsolete libvkd3d1-32bit-1.1-2.1.x86_64
     Solution 4: break libvkd3d1-32bit-1.2-1.1.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/3/4/c/d/?] (c): 2
    Resolving dependencies...
    Computing distribution upgrade...
    
    Problem: libvkd3d1-1.2-1.1.x86_64 requires libvkd3d-shader.so.1()(64bit), but this requirement cannot be provided
      not installable providers: libvkd3d-shader1-1.2-1.1.x86_64[download.opensuse.org-oss]
     Solution 1: deinstallation of libvkd3d1-1.1-2.1.x86_64
     Solution 2: install libvkd3d1-1.2-1.1.i586 despite the inferior architecture
     Solution 3: keep obsolete libvkd3d1-1.1-2.1.x86_64
     Solution 4: do not install libvkd3d-shader1-1.2-1.1.i586
     Solution 5: break libvkd3d1-1.2-1.1.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/3/4/5/c/d/?] (c): 2
    Resolving dependencies...
    Computing distribution upgrade...
    
    Problem: wine-5.17-1.2.x86_64 requires libvkd3d.so.1()(64bit), but this requirement cannot be provided
      deleted providers: libvkd3d1-1.1-2.1.x86_64
    not installable providers: libvkd3d1-1.2-1.1.x86_64[download.opensuse.org-oss]
     Solution 1: deinstallation of wine-5.17-1.2.x86_64
     Solution 2: install wine-5.17-1.2.i586 despite the inferior architecture
     Solution 3: do not install libvkd3d1-1.2-1.1.i586
     Solution 4: break wine-5.17-1.2.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/3/4/c/d/?] (c): 2
    Resolving dependencies...
    Computing distribution upgrade...
    
    The following 4 NEW packages are going to be installed:
      kernel-default-5.8.10-1.2 libvkd3d-shader1 python3-nftables vhba-kmp-default-20200106_k5.8.10_1-1.23
    
    The following package is going to be REMOVED:
      gimp-plugins-python
    
    The following 173 packages are going to be upgraded:
      apparmor-abstractions apparmor-docs apparmor-parser apparmor-parser-lang apparmor-profiles apparmor-utils apparmor-utils-lang autoyast2-installation clamav dhcp dhcp-client elfutils firebird firewalld
      firewalld-lang gdb gimp gimp-lang gimp-plugin-aa graphviz graphviz-gd graphviz-gnome graphviz-plugins-core gvim hwdata ImageMagick ImageMagick-config-7-SUSE info info-std kbd kbd-legacy kernel-firmware-all
      kernel-firmware-amdgpu kernel-firmware-ath10k kernel-firmware-atheros kernel-firmware-bluetooth kernel-firmware-bnx2 kernel-firmware-brcm kernel-firmware-chelsio kernel-firmware-dpaa2 kernel-firmware-i915
      kernel-firmware-intel kernel-firmware-iwlwifi kernel-firmware-liquidio kernel-firmware-marvell kernel-firmware-media kernel-firmware-mediatek kernel-firmware-mellanox kernel-firmware-mwifiex
      kernel-firmware-network kernel-firmware-nfp kernel-firmware-nvidia kernel-firmware-platform kernel-firmware-prestera kernel-firmware-qlogic kernel-firmware-radeon kernel-firmware-realtek
      kernel-firmware-serial kernel-firmware-sound kernel-firmware-ti kernel-firmware-ueagle kernel-firmware-usb-network kpartx libapparmor1 libasm1 libclamav9 libdbusmenu-qt5-2 libdw1 libdw1-32bit libelf1
      libelf1-32bit libell0 libfbclient2 libfido2-1 libfido2-udev libfreshclam2 libgbm1 libgimp-2_0-0 libgimpui-2_0-0 libgraphviz6 libib_util libldap-2_4-2 libldap-2_4-2-32bit libldap-data libMagickCore-7_Q16HDRI7
      libMagickWand-7_Q16HDRI7 libminizip1 libmpath0 libOSMesa8 libOSMesa8-32bit libpipeline1 libqrencode4 libreoffice libreoffice-base libreoffice-base-drivers-firebird libreoffice-calc libreoffice-draw
      libreoffice-filters-optional libreoffice-icon-themes libreoffice-impress libreoffice-l10n-en libreoffice-l10n-en_GB libreoffice-mailmerge libreoffice-math libreoffice-pyuno libreoffice-qt5 libreoffice-writer
      libsnmp30 libsolv-tools libsvn_auth_kwallet-1-0 libvdpau_r300 libvdpau_r600 libvdpau_radeonsi libvkd3d1 libvkd3d1-32bit libvulkan_radeon libvulkan_radeon-32bit libyui-qt13 libz1 libz1-32bit libzstd1
      libzstd1-32bit mcelog Mesa Mesa-32bit Mesa-dri Mesa-dri-32bit Mesa-gallium Mesa-gallium-32bit Mesa-libEGL1 Mesa-libGL1 Mesa-libGL1-32bit Mesa-libglapi0 Mesa-libglapi0-32bit Mesa-libva mokutil multipath-tools
      net-snmp noto-coloremoji-fonts okular okular-lang openldap2-client openSUSE-release openSUSE-release-appliance-custom openvpn os-prober perl perl-apparmor perl-base perl-Bootloader perl-SNMP python3-apparmor
      python3-firewall python3-solv ruby-solv shadow snmp-mibs spectacle spectacle-lang subversion subversion-bash-completion subversion-perl tor ucode-amd vim vim-data vim-data-common xf86-video-vesa xterm
      xterm-bin yast2-core yast2-perl-bindings yast2-trans-en_GB
    
    The following product is going to be upgraded:
      openSUSE Tumbleweed  20200919-0 -> 20200923-0
    
    The following 2 packages are going to change architecture:
      libvkd3d1  x86_64 -> i586
      wine       x86_64 -> i586
    
    The following package requires a system reboot:
      kernel-default-5.8.10-1.2
    
    173 packages to upgrade, 4 new, 1 to remove, 2 to change arch.
    Overall download size: 680.0 MiB. Already cached: 0 B. Download only.


    I've found another user on this forum with what looks to be the same basic problem:
    https://forums.opensuse.org/showthre...e-LMMS-related

    Does anyone have any idea how I proceed from here?

    If anyone requires any more information please ask.

    Thank you for your time.
    Ian.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,691
    Blog Entries
    15

    Default Re: libvkd3d1-32bit-1.2-1.1.x86_64 requires libvkd3d-shader.so.1, but this requirement cannot be pro

    Hi
    There were two snapshots released today (20200922 and 20200923), it could be out of sync mirrors, suggest you force a refresh and try again...

    Code:
    zypper ref -f
    zypper -vvv dup
    Add verbosity for more information....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jul 2018
    Location
    Loma Linda, Mo
    Posts
    327

    Default Re: libvkd3d1-32bit-1.2-1.1.x86_64 requires libvkd3d-shader.so.1, but this requirement cannot be pro

    I chose option 5.
    Wine still works fine.
    Opensuse 15.2 with VirtualBox VM's (XP, 10 & OpenSUSE 15.0)
    Pi4 with Ubuntu MATE 20.04
    Unix since 1974 (pdp-11 in "B" , Interdata 7/32 in "C") (AT&T, Tandy, Convergent, IBM, NCR, HP flavors)
    Linux since 1995 (mandrake, redhat, fedora, centos, now OpenSUSE)

  4. #4
    Join Date
    Jul 2020
    Posts
    6

    Default Re: libvkd3d1-32bit-1.2-1.1.x86_64 requires libvkd3d-shader.so.1, but this requirement cannot be pro

    Thanks for the advice.

    I can't post the full logs directly here, they're too long.

    sudo zypper -vvv refresh -f gives the following output:
    https://paste.opensuse.org/48239138

    As before, if I then do sudo zypper -vvv dup -dD I get the following depending on the path I instruct zypper to take.

    If I choose to keep the package which zypper reports as obsolete I get this output:
    https://paste.opensuse.org/43307635

    If I choose to let zypper switch the packages from x86_64 to i586 I get this output:
    https://paste.opensuse.org/78548914


    I wasn't aware there where two snapshots today.
    Looking at my previous logs and my current ones they all show the same snapshot numbers:
    Code:
    The following product is going to be upgraded:
      openSUSE Tumbleweed  20200919-0 -> 20200923-0  x86_64  Main Repository (OSS)  openSUSE
    Once again, thanks for your help.
    Ian.

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,882

    Default AW: libvkd3d1-32bit-1.2-1.1.x86_64 requires libvkd3d-shader.so.1, but this requirement cannot be pro

    Breaking a dependency is not a good solution.
    Edit by Sauerland
    See bugreport, there will be an update.

    Edit: do not do this, see bugreport:
    Code:
    Problem: libvkd3d1-32bit-1.2-1.1.x86_64 requires libvkd3d-shader.so.1, but this requirement cannot be provided
      not installable providers: libvkd3d-shader1-1.2-1.1.i586[download.opensuse.org-oss]
     Solution 1: Following actions will be done:
      deinstallation of libvkd3d1-32bit-1.1-2.1.x86_64
      deinstallation of wine-mono-5.1.0-2.2.noarch
    This is the Solution:
    ibvkd3d1-32bit-1.1-2.1.x86_64 is replaced by libvkd3d1-32bit-1.2-1.1.x86_64
    Also the next dependency...

    Maybe wine is not working any more but that might be a bugreport.

    Edit:
    https://lists.opensuse.org/opensuse-.../msg00371.html
    Last edited by Sauerland; 24-Sep-2020 at 23:29.

  6. #6
    Join Date
    Jan 2016
    Location
    UK
    Posts
    688

    Default Re: libvkd3d1-32bit-1.2-1.1.x86_64 requires libvkd3d-shader.so.1, but this requirement cannot be pro

    I rsn into this today first thing, just cancelled and reran now some 4 hours later and all is fine. Obviously it caught up with it elf!

    Stuart

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,691
    Blog Entries
    15

    Default Re: libvkd3d1-32bit-1.2-1.1.x86_64 requires libvkd3d-shader.so.1, but this requirement cannot be pro

    Quote Originally Posted by broadstairs View Post
    I rsn into this today first thing, just cancelled and reran now some 4 hours later and all is fine. Obviously it caught up with it elf!

    Stuart
    Hi
    Yes the update was pushed to the Tumbleweed update repo instead of waiting for the next snapshot release...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8
    Join Date
    Jul 2020
    Posts
    6

    Default Re: libvkd3d1-32bit-1.2-1.1.x86_64 requires libvkd3d-shader.so.1, but this requirement cannot be pro

    Hello,

    Thank you for all your help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •