Results 1 to 9 of 9

Thread: Boot erst schnell, dann langsam

  1. #1

    Default Boot erst schnell, dann langsam

    Hallo,

    Ich habe für meine Frau einen Dell E7470 mit Suse 15.1 installiert und getestet. Alles OK. Bootzeit ca 40sec vom Powerknopf zum Desktop. Ich habe ihr dann den Laptop gegeben, bin aber beruflich nicht daheim. D.h. es ist auch jetzt ein anders Netzwerk um den Laptop. In der 'neuen' Umgebung dauert das Boot 2min. Wo muss ich da nachschauen, um herauszufinden was klemmt ? Ich vermute irgendein Netzwerk / Sharing Zeugs wartet auf meinen Router, kriegt aber nur die Fritzbox meiner Frau und hängt. Aber wie finde ich das heraus?

    Danke für Ideen,
    Gert

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,011

    Default AW: Boot erst schnell, dann langsam

    Als root:
    Code:
    systemctl list-units --failed
    Code:
    systemd-analyze blame
    systemd warte 90 Sek (1 min 30 sec) darauf, das ein unit startet/stoppt. Wenn der Unit nicht startet, wird erst dann weitergearbeitet.

    Oft ist es auch ein falscher resume-Eintrag im grub.

    Code:
    cat /proc/cmdline
    zeigt die Bootzeile an,
    kannst du dann vergleichen mit der /etc/fstab.

  3. #3

    Default Re: Boot erst schnell, dann langsam

    Hallo,

    Danke für die Tipps. Es sieht nach dem Samba Treiber aus. Der wird als 'failed' gelistet. wahrscheinlich denkt der, er ist in der falschen Workgroup. Das geht so ein bischen in meine andere Frage zum Samba 'browsen' bzgl. Rechnernamen.

    Kann man Samba im Momoent einfach erstmal total abschalten?

    Cheers,
    Gert

    Code:
    sibylle@E7470:~> systemctl list-units --failed
      UNIT        LOAD   ACTIVE SUB    DESCRIPTION
    ● smb.service loaded failed failed Samba SMB Daemon
    
    LOAD   = Reflects whether the unit definition was properly loaded.
    ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
    SUB    = The low-level unit activation state, values depend on unit type.
    
    1 loaded units listed. Pass --all to see loaded but inactive units, too.
    To show all installed unit files use 'systemctl list-unit-files'.
    sibylle@E7470:~> systemd-analyze blame
             34.771s fstrim.service
             10.110s nmb.service
              9.583s backup-rpmdb.service
              8.243s NetworkManager-wait-online.service
              5.702s mandb.service
              2.981s display-manager.service
              2.649s dracut-initqueue.service
              2.554s btrfsmaintenance-refresh.service
              2.437s plymouth-quit-wait.service
              1.651s logrotate.service
              1.615s postfix.service
               567ms firewalld.service
               564ms lvm2-monitor.service
               494ms smb.service
               484ms ModemManager.service
               448ms apparmor.service
               421ms initrd-switch-root.service
               415ms backup-sysconfig.service
               345ms opt.mount
               339ms boot-grub2-i386\x2dpc.mount
               292ms usr-local.mount
               287ms home.mount
               286ms boot-grub2-x86_64\x2defi.mount
               281ms srv.mount
               219ms upower.service
               191ms var.mount
               178ms user@1000.service
               172ms \x2esnapshots.mount
               148ms kbdsettings.service
               147ms avahi-daemon.service
               146ms sshd.service
               145ms systemd-journal-flush.service
               142ms rsyslog.service
               140ms tmp.mount
               117ms klog.service
               113ms NetworkManager.service
               110ms mcelog.service
               107ms teamviewerd.service
               103ms initrd-parse-etc.service
                99ms udisks2.service
                99ms chronyd.service
                96ms systemd-backlight@backlight:intel_backlight.service
                94ms systemd-rfkill.service
                94ms systemd-random-seed.service
                93ms systemd-backlight@leds:dell::kbd_backlight.service
                87ms systemd-vconsole-setup.service
                82ms root.mount
                79ms systemd-udev-trigger.service
                74ms polkit.service
                71ms systemd-update-utmp-runlevel.service
                70ms systemd-udevd.service
                65ms rtkit-daemon.service
                61ms bluetooth.service
                61ms check-battery.service
                60ms wpa_supplicant.service
                57ms plymouth-start.service
                57ms dev-disk-by\x2duuid-99e8cca5\x2dc365\x2d4721\x2db87d\x2d57c2110e104a.swap
                57ms auditd.service
                53ms iscsi.service
                51ms systemd-user-sessions.service
                51ms nscd.service
                44ms dracut-cmdline.service
                41ms systemd-tmpfiles-clean.service
                40ms systemd-tmpfiles-setup.service
                39ms plymouth-read-write.service
                38ms dracut-shutdown.service
                35ms systemd-logind.service
                34ms systemd-journald.service
                31ms plymouth-switch-root.service
                31ms systemd-update-utmp.service
                24ms initrd-cleanup.service
                22ms sysroot.mount
                21ms systemd-sysctl.service
                20ms systemd-tmpfiles-setup-dev.service
                20ms kmod-static-nodes.service
                18ms systemd-modules-load.service
                17ms dev-mqueue.mount
                15ms sys-kernel-debug.mount
                13ms dev-hugepages.mount
                12ms systemd-fsck-root.service
                11ms systemd-remount-fs.service
                11ms dracut-pre-trigger.service
                 5ms initrd-udevadm-cleanup-db.service
    sibylle@E7470:~> cat /proc/cmdline
    BOOT_IMAGE=/boot/vmlinuz-4.12.14-lp151.28.63-default root=UUID=351025b9-f28f-46d8-b4ec-2a27073bd517 splash=silent resume=/dev/disk/by-id/ata-CT250MX500SSD4_2003E28211AE-part4 quiet mitigations=auto

    Ich habe hier gleich mal nach dem smb.conf geschaut. eswundert mich, dass da überhaupt keine Workgroup Referenz drinsteht.

    Code:
    /etc/samba> cat smb.conf
    # smb.conf is the main Samba configuration file. You find a full commented
    # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
    # samba-doc package is installed.
    [global]
            passdb backend = tdbsam
            printing = cups
            printcap name = cups
            printcap cache time = 750
            cups options = raw
            map to guest = Bad User
            logon path = \\%L\profiles\.msprofile
            logon home = \\%L\%U\.9xprofile
            logon drive = P:
            usershare allow guests = Yes
            security = domain
            usershare max shares = 100
            netbios name = E7470
            wins support = Yes
            idmap gid = 10000-20000
            idmap uid = 10000-20000
    [homes]
            comment = Home Directories
            valid users = %S, %D%w%S
            browseable = No
            read only = No
            inherit acls = Yes
    [profiles]
            comment = Network Profiles Service
            path = %H
            read only = No
            store dos attributes = Yes
            create mask = 0600
            directory mask = 0700
    
    [users]
            comment = All users
            path = /home
            read only = No
            inherit acls = Yes
            veto files = /aquota.user/groups/shares/
    [groups]
            comment = All groups
            path = /home/groups
            read only = No
            inherit acls = Yes
    [printers]
            comment = All Printers
            path = /var/tmp
            printable = Yes
            create mask = 0600
            browseable = No
    [print$]
            comment = Printer Drivers
            path = /var/lib/samba/drivers
            write list = @ntadmin root
            force group = ntadmin
            create mask = 0664
            directory mask = 0775

  4. #4

    Default Re: Boot erst schnell, dann langsam

    Oh, nochwas. Ich habe noch einen Tipp bekommen, journalctl -r zu versuchen. Das hat folgenden Eintrag beim Boot geliefert. Was ist da mit dem Device los ?

    Code:
    Sep 27 02:12:31 E7470 systemd[1]:  Dependency failed for Resume from hibernation using device  /dev/disk/by-id/ata-CT250MX500SSD4_2003E28211AE-part4.
    Sep 27  02:12:31 E7470 systemd[1]: Timed out waiting for device  dev-disk-by\x2did-ata\x2dCT250MX500SSD4_2003E28211AE\x2dpart4.device.
    Sep  27 02:12:31 E7470 systemd[1]:  dev-disk-by\x2did-ata\x2dCT250MX500SSD4_2003E28211AE\x2dpart4.device:  Job  dev-disk-by\x2did-ata\x2dCT250MX500SSD4_2003E28211AE\x2dpart4.device/start  timed out.
    Sep 27 02:11:04 E7470 systemd[1]: Reached target Initrd Root Device.
    Sep 27 02:11:04 E7470 systemd[1]: Reached target Remote File Systems.

  5. #5

    Default Re: Boot erst schnell, dann langsam

    Ich hab nochwas gefunden.

    Das ist in fstab :

    Code:
    cat /etc/fstab
    UUID=351025b9-f28f-46d8-b4ec-2a27073bd517  /                       btrfs  defaults                      0  0
    UUID=351025b9-f28f-46d8-b4ec-2a27073bd517  /var                    btrfs  subvol=/@/var                 0  0
    UUID=351025b9-f28f-46d8-b4ec-2a27073bd517  /usr/local              btrfs  subvol=/@/usr/local           0  0
    UUID=351025b9-f28f-46d8-b4ec-2a27073bd517  /tmp                    btrfs  subvol=/@/tmp                 0  0
    UUID=351025b9-f28f-46d8-b4ec-2a27073bd517  /srv                    btrfs  subvol=/@/srv                 0  0
    UUID=351025b9-f28f-46d8-b4ec-2a27073bd517  /root                   btrfs  subvol=/@/root                0  0
    UUID=351025b9-f28f-46d8-b4ec-2a27073bd517  /opt                    btrfs  subvol=/@/opt                 0  0
    UUID=351025b9-f28f-46d8-b4ec-2a27073bd517  /home                   btrfs  subvol=/@/home                0  0
    UUID=351025b9-f28f-46d8-b4ec-2a27073bd517  /boot/grub2/x86_64-efi  btrfs  subvol=/@/boot/grub2/x86_64-efi  0  0
    UUID=351025b9-f28f-46d8-b4ec-2a27073bd517  /boot/grub2/i386-pc     btrfs  subvol=/@/boot/grub2/i386-pc  0  0
    UUID=351025b9-f28f-46d8-b4ec-2a27073bd517  /.snapshots             btrfs  subvol=/@/.snapshots          0  0
    UUID=99e8cca5-c365-4721-b87d-57c2110e104a  swap                    swap   defaults                      0  0
    Ich hab die Vermutung, dass der swap Eintrag zu einer alten Device ID zeigt, die nicht mehr im System ist.
    Was ist die beste Idee :
    1. Zeile mit swap ganz löschen
    2. In Zeile mit swap die Device ID editieren, so dass sie aussieht wie in den anderen Zeilen?


    Oder gibt es da Probleme? Ich kann mir vorstellen, dass man erstmal auf der Platte (SSD) eine Swap Partition anlegen muss.
    Ist das eigentlich für SSD eine gute Idee? (bzgl Flash-Zellen Abnutzung?)

    Cheers,
    Gert

  6. #6
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    2,057
    Blog Entries
    1

    Default Re: Boot erst schnell, dann langsam

    Quote Originally Posted by gert4SFde View Post
    Oh, nochwas. Ich habe noch einen Tipp bekommen, journalctl -r zu versuchen. Das hat folgenden Eintrag beim Boot geliefert. Was ist da mit dem Device los ?

    Code:
    Sep 27 02:12:31 E7470 systemd[1]:  Dependency failed for Resume from hibernation using device  /dev/disk/by-id/ata-CT250MX500SSD4_2003E28211AE-part4.
    Sep 27  02:12:31 E7470 systemd[1]: Timed out waiting for device  dev-disk-by\x2did-ata\x2dCT250MX500SSD4_2003E28211AE\x2dpart4.device.
    Sep  27 02:12:31 E7470 systemd[1]:  dev-disk-by\x2did-ata\x2dCT250MX500SSD4_2003E28211AE\x2dpart4.device:  Job  dev-disk-by\x2did-ata\x2dCT250MX500SSD4_2003E28211AE\x2dpart4.device/start  timed out.
    Sep 27 02:11:04 E7470 systemd[1]: Reached target Initrd Root Device.
    Sep 27 02:11:04 E7470 systemd[1]: Reached target Remote File Systems.
    Systemd wartet 1:30 min auf den Device, findet ihn nicht und macht weiter. Wenn du die Funktion nicht brauchst lösche einfach den Eintrag und installiere Grub neu.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

  7. #7
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,011

    Default AW: Boot erst schnell, dann langsam

    Und wenn du swap brauchst, lösche das alte in Yast----System----Partitionierer und erstelle dort einen neue swap, wenn du noch Platz auf der Festplatte hast.

    Auch hier wieder grub neu schreiben lassen:
    Yast---System----Bootloader-----Bootloader-Optionen ------ Zeitüberschreitung in Sekunden -------einfach 1 Sekunde mehr einstellen.
    Das bedeutet, das das Grub Bootmenü 1 Sekunde länger erscheint, ist zu verkraften.

    Ok klicken uns neu starten.
    Last edited by Sauerland; 26-Sep-2020 at 23:23.

  8. #8

    Default Re: Boot erst schnell, dann langsam

    Hallo,

    Die Idee mit grub hat das Problem gelöst.

    Was war passiert? Bei meiner Installation auf meinem Laptop hat sich irgendwann in /etc/default/grub ein Eintrag für die Hibernations-Datei gebildet.
    GRUB_CMDLINE_LINUX_DEFAULT="splash=silent resume=/dev/disk/by-id/ata-CT250MX500SSD4_2003E28211AE-part4 quiet mitigations=auto"

    Das installierte grub.cfg in /boot war aber zuerst unbeeinträchtigt. Als ich mit CloneZilla die SSD übertragen habe, ist der Eintrag in /etc/default/grub mitgekommen. Zuerst hatte das keinen Effekt. Erst beim nächsten update ist wohl ein Paket dabei gewesen, was eine neu Compilierung des grub.cfg in /boot getriggert hat. Das hat dann angefangen nach der Hibernations-Dateizu schauen und dabei den Boot aufgehalten.

    Sicher ein Sonderfall, da ich die SSD mit CloneZilla gespiegelt habe. Aber man kann fragen, ob der grub Compilierprozess nicht robuster sein könnte, angegeben Datei-IDs zu prüfen, bevor irgendwas ins /boot geschrieben wird. Wäre ja eine einfache Abfrage.

    Naja, ist jetzt Vergangenheit.

    Cheers,
    Gert

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,011

    Default AW: Boot erst schnell, dann langsam

    Aber man kann fragen, ob der grub Compilierprozess nicht robuster sein könnte, angegeben Datei-IDs zu prüfen, bevor irgendwas ins /boot geschrieben wird.
    Jetzt aber bitte nicht die Verantwortung für den Fehler auf grub schieben.........

    Schön, das es wieder läuft.....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •