Results 1 to 9 of 9

Thread: Need help updating xreader (ninja: build stopped: subcommand failed.)

  1. #1
    Join Date
    Oct 2018
    Location
    Atlantis
    Posts
    191

    Unhappy Need help updating xreader (ninja: build stopped: subcommand failed.)

    Hello,

    I need help updating xreader. It use meson and ninja.
    https://build.opensuse.org/package/s...actory/xreader

    The error simply says,

    Code:
    [  176s] ninja: build stopped: subcommand failed.
    It look like it just gave up with no indication.
    I'm pretty lost, since I copy spec file from Fedora which Fedora manage to build the package.
    https://src.fedoraproject.org/rpms/xreader

    Thank you.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,704
    Blog Entries
    15

    Default Re: Need help updating xreader (ninja: build stopped: subcommand failed.)

    Quote Originally Posted by andythe_great View Post
    Hello,

    I need help updating xreader. It use meson and ninja.
    https://build.opensuse.org/package/s...actory/xreader

    The error simply says,

    Code:
    [  176s] ninja: build stopped: subcommand failed.
    It look like it just gave up with no indication.
    I'm pretty lost, since I copy spec file from Fedora which Fedora manage to build the package.
    https://src.fedoraproject.org/rpms/xreader

    Thank you.
    Hi
    No it's a build error, need to look at the log file

    Code:
    [  175s] ../libdocument/ev-annotation.c:704: Warning: XreaderDocument: multiple comment blocks documenting 'ev_annotation_set_area:' identifier (already seen at ev-annotation.c:685).
    [  175s] ../libdocument/ev-file-helpers.c:200: Error: XreaderDocument: identifier not found on the first line:
    [  175s]  * This function is copied from
    [  175s]    ^
    [  175s] ../libdocument/ev-document-misc.c:31: Error: XreaderDocument: identifier not found on the first line:
    [  175s]  * Returns a new GdkPixbuf that is suitable for placing in the thumbnail view.
    [  175s]    ^
    and more.....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Oct 2018
    Location
    Atlantis
    Posts
    191

    Default Re: Need help updating xreader (ninja: build stopped: subcommand failed.)

    Quote Originally Posted by malcolmlewis View Post
    Hi
    No it's a build error, need to look at the log file

    Code:
    [  175s] ../libdocument/ev-annotation.c:704: Warning: XreaderDocument: multiple comment blocks documenting 'ev_annotation_set_area:' identifier (already seen at ev-annotation.c:685).
    [  175s] ../libdocument/ev-file-helpers.c:200: Error: XreaderDocument: identifier not found on the first line:
    [  175s]  * This function is copied from
    [  175s]    ^
    [  175s] ../libdocument/ev-document-misc.c:31: Error: XreaderDocument: identifier not found on the first line:
    [  175s]  * Returns a new GdkPixbuf that is suitable for placing in the thumbnail view.
    [  175s]    ^
    and more.....
    Hmmm, does it mean missing dependencies or mistake in build recipe? What does
    Code:
    identifier not found
    mean?

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,704
    Blog Entries
    15

    Default Re: Need help updating xreader (ninja: build stopped: subcommand failed.)

    Quote Originally Posted by andythe_great View Post
    Hmmm, does it mean missing dependencies or mistake in build recipe? What does
    Code:
    identifier not found
    mean?
    Hi
    Does it build against Leap targets? Maybe Tumbleweed libraries are too new.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Oct 2018
    Location
    Atlantis
    Posts
    191

    Default Re: Need help updating xreader (ninja: build stopped: subcommand failed.)

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Does it build against Leap targets? Maybe Tumbleweed libraries are too new.
    I tried building with Leap, it seems to succeed, but TW failed. So I think you are right, TW package might be too new.
    Do you know how can I find the problematic package and submit a bug report to Mint dev?

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,704
    Blog Entries
    15

    Default Re: Need help updating xreader (ninja: build stopped: subcommand failed.)

    Hi
    Maybe a lto issue, or link order... Tumbleweed adds :-Werror=return-type -flto=auto

    Code:
    Tumbleweed
    [  138s] g-ir-scanner: link: gcc -pthread -o /home/abuild/rpmbuild/BUILD/xreader-2.6.4/build/tmp-introspectzdgt3o86/XreaderDocument-1.5 -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection -Werror=return-type -flto=auto /home/abuild/rpmbuild/BUILD/xreader-2.6.4/build/tmp-introspectzdgt3o86/XreaderDocument-1.5.o -L. -Wl,-rpath,. -Wl,--no-as-needed -L/home/abuild/rpmbuild/BUILD/xreader-2.6.4/build/libdocument -Wl,-rpath,/home/abuild/rpmbuild/BUILD/xreader-2.6.4/build/libdocument -lxreaderdocument -lcairo -lglib-2.0 -lgmodule-2.0 -lgtk-3 -lgdk-3 -lpangocairo-1.0 -lpango-1.0 -lharfbuzz -latk-1.0 -lcairo-gobject -lgdk_pixbuf-2.0 -lgio-2.0 -lgobject-2.0 -lm -lgirepository-1.0 -lgio-2.0 -lgobject-2.0 -Wl,--export-dynamic -lgmodule-2.0 -pthread -lglib-2.0 -lglib-2.0
    
    Leap 15.2
    [  115s] g-ir-scanner: link: gcc -pthread -o /home/abuild/rpmbuild/BUILD/xreader-2.6.4/build/tmp-introspectq4ten_oa/XreaderDocument-1.5 -fmessage-length=0 -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection /home/abuild/rpmbuild/BUILD/xreader-2.6.4/build/tmp-introspectq4ten_oa/XreaderDocument-1.5.o -L. -Wl,-rpath,. -Wl,--no-as-needed -L/home/abuild/rpmbuild/BUILD/xreader-2.6.4/build/libdocument -Wl,-rpath,/home/abuild/rpmbuild/BUILD/xreader-2.6.4/build/libdocument -lxreaderdocument -lcairo -lglib-2.0 -lgmodule-2.0 -lgtk-3 -lgdk-3 -lpangocairo-1.0 -lpango-1.0 -lharfbuzz -latk-1.0 -lcairo-gobject -lgdk_pixbuf-2.0 -lgio-2.0 -lgobject-2.0 -lm -lgio-2.0 -lgobject-2.0 -Wl,--export-dynamic -lgmodule-2.0 -pthread -lglib-2.0
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7
    Join Date
    Oct 2018
    Location
    Atlantis
    Posts
    191

    Default Re: Need help updating xreader (ninja: build stopped: subcommand failed.)

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Maybe a lto issue, or link order... Tumbleweed adds :-Werror=return-type -flto=auto

    Code:
    Tumbleweed
    [  138s] g-ir-scanner: link: gcc -pthread -o /home/abuild/rpmbuild/BUILD/xreader-2.6.4/build/tmp-introspectzdgt3o86/XreaderDocument-1.5 -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection -Werror=return-type -flto=auto /home/abuild/rpmbuild/BUILD/xreader-2.6.4/build/tmp-introspectzdgt3o86/XreaderDocument-1.5.o -L. -Wl,-rpath,. -Wl,--no-as-needed -L/home/abuild/rpmbuild/BUILD/xreader-2.6.4/build/libdocument -Wl,-rpath,/home/abuild/rpmbuild/BUILD/xreader-2.6.4/build/libdocument -lxreaderdocument -lcairo -lglib-2.0 -lgmodule-2.0 -lgtk-3 -lgdk-3 -lpangocairo-1.0 -lpango-1.0 -lharfbuzz -latk-1.0 -lcairo-gobject -lgdk_pixbuf-2.0 -lgio-2.0 -lgobject-2.0 -lm -lgirepository-1.0 -lgio-2.0 -lgobject-2.0 -Wl,--export-dynamic -lgmodule-2.0 -pthread -lglib-2.0 -lglib-2.0
    
    Leap 15.2
    [  115s] g-ir-scanner: link: gcc -pthread -o /home/abuild/rpmbuild/BUILD/xreader-2.6.4/build/tmp-introspectq4ten_oa/XreaderDocument-1.5 -fmessage-length=0 -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection /home/abuild/rpmbuild/BUILD/xreader-2.6.4/build/tmp-introspectq4ten_oa/XreaderDocument-1.5.o -L. -Wl,-rpath,. -Wl,--no-as-needed -L/home/abuild/rpmbuild/BUILD/xreader-2.6.4/build/libdocument -Wl,-rpath,/home/abuild/rpmbuild/BUILD/xreader-2.6.4/build/libdocument -lxreaderdocument -lcairo -lglib-2.0 -lgmodule-2.0 -lgtk-3 -lgdk-3 -lpangocairo-1.0 -lpango-1.0 -lharfbuzz -latk-1.0 -lcairo-gobject -lgdk_pixbuf-2.0 -lgio-2.0 -lgobject-2.0 -lm -lgio-2.0 -lgobject-2.0 -Wl,--export-dynamic -lgmodule-2.0 -pthread -lglib-2.0
    Hello,

    Defolos take a look at it, and it is a bug in the code https://github.com/linuxmint/xreader/issues/418

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,704
    Blog Entries
    15

    Default Re: Need help updating xreader (ninja: build stopped: subcommand failed.)

    Quote Originally Posted by andythe_great View Post
    Hello,

    Defolos take a look at it, and it is a bug in the code https://github.com/linuxmint/xreader/issues/418
    Hi
    And this is default in Tumbleweed (-Werror=return-type), hence the failure....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9
    Join Date
    Oct 2018
    Location
    Atlantis
    Posts
    191

    Default Re: Need help updating xreader (ninja: build stopped: subcommand failed.)

    Quote Originally Posted by malcolmlewis View Post
    Hi
    And this is default in Tumbleweed (-Werror=return-type), hence the failure....
    The issue is solved now. Thank for the help anyway, the fix is upstreamed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •