Results 1 to 2 of 2

Thread: Installation über PXE-Server schlägt fehl

  1. #1

    Default Installation über PXE-Server schlägt fehl

    Moinmoin

    ich habe hier einen openSUSE 15.2 server der als PXE-Server dienen soll.

    dnsmasq und nfs ist installiert und konfiguriert.
    Installation von CentOS vom gleichen Server funktioniert.

    Nur openSUSE nicht.

    Die erste Frage: welche Ausprägung ist die richtige? DVD oder NET?
    (Ich habs mit beiden versucht, aber es geht nicht)

    Von der vorgehensweise her:
    NET-ISO in ein freigegebenes nfs-share gemountet und folgendes in die default eingegeben:

    label openSUSE-Leap-15.2
    KERNEL suse/linux
    APPEND initrd=suse/initrd vga=normal install=nfs://192.168.2.1:/srv/tftpboot/images/suse_net
    Für die DVD-ISO hab ichs damit versucht

    label openSUSE-Leap-15.2
    KERNEL suse/linux
    APPEND initrd=suse/initrd vga=normal instsys=tftp://srv/tftpboot/images/suse/boot/x86_64/root install=nfs://192.168.2.1:/srv/tftpboot/images/suse
    Das booten des Clients bricht ab. Die letzte Zeile lautet

    no openSUSE Leap 15.2 repository found



    https://ibb.co/N7zZGNR

    Was mach ich denn falsch?

  2. #2

    Default Re: Installation über PXE-Server schlägt fehl

    install= muss auf das repo zeigen - also z.B. so:
    Code:
    KERNEL suse/linux install=http://download.opensuse.org/distribution/leap/15.2/repo/oss
    und da du kernel und ramdisk ja hast - sowie dass grub wohl irgendwie erfolgreich via pxe startet - brauchst du weder das net image noch das volle dvd image (du könntest das dvd image halt noch mit loopback als nfs mounten wenn du lokal statt aus dem netz installieren willst)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •