Results 1 to 4 of 4

Thread: Configuring Language and Country Settings

  1. #1
    Join Date
    Jun 2008
    Location
    South-West France
    Posts
    1,169

    Default Configuring Language and Country Settings

    Hello.

    After a fresh install ( lang = english , keyb = fr ), I would like to have every things in English, but at least :
    Numbers : fr_FR
    Time : fr_FR
    Currency : fr_FR
    Measurement Units : fr_FR
    Collation and sorting : en_US

    Presently in terminal I got half message in French or English
    Yast menus options are in French and in English.

    Current config is :
    Yast :
    • Primary language : English (US)
    • Detailed Local Settings : en_US
    • Adapt options are off
    • No secondary language


    KDE Regional Settings :
    Language : 1 : American English (Default) ; 2 : Français

    Formats :

    • Region : United States - American English (en_US)
    • Numbers : fr_FR
    • Time : fr_FR
    • Currency : fr_FR
    • Measurement Units : fr_FR
    • Collation and sorting : en_US


    Time Zone : Paris Europe/France


    Any help is welcome
    Thanks for helping. JCD
    __________
    server leap 15.0 -- ASUS g75vw KDE leap 15.0 -- ASUS G731GV KDE leap 15.1 -- acer aspire s13 win 10 home -- HP Omen win 10 home - scan EPSON V500 - Brother HL2250DN - Samsung CLP-325W

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,543

    Default Re: Configuring Language and Country Settings

    How you do this depends on your desktop; you need to tell YaST the language layout of your keyboard. Then in KDE you can go to System settings>Regional settings to configure how the desktop displays. I assume there is something similar in Gnome.

  3. #3
    Join Date
    Feb 2019
    Location
    Amoy
    Posts
    12

    Default Re: Configuring Language and Country Settings

    Quote Originally Posted by jcdole View Post
    KDE Regional Settings :
    Language : 1 : American English (Default) ; 2 : Français
    The language settings of KDE Regional Settings looks suspicious. Is removing the secondary language (Français) solve the problem?

    It should have worked as expected since American English is the default language. But I did have an experience similar to yours with more than one items in language settings of KDE Regional Settings.

  4. #4
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,903
    Blog Entries
    1

    Default Re: Configuring Language and Country Settings

    Quote Originally Posted by jcdole View Post
    Hello.

    After a fresh install ( lang = english , keyb = fr ), I would like to have every things in English, but at least :
    Numbers : fr_FR
    Time : fr_FR
    Currency : fr_FR
    Measurement Units : fr_FR
    Collation and sorting : en_US

    Presently in terminal I got half message in French or English
    Yast menus options are in French and in English.

    Current config is :
    Yast :
    • Primary language : English (US)
    • Detailed Local Settings : en_US
    • Adapt options are off
    • No secondary language


    KDE Regional Settings :
    Language : 1 : American English (Default) ; 2 : Français

    Formats :

    • Region : United States - American English (en_US)
    • Numbers : fr_FR
    • Time : fr_FR
    • Currency : fr_FR
    • Measurement Units : fr_FR
    • Collation and sorting : en_US


    Time Zone : Paris Europe/France


    Any help is welcome
    localedef creates new locales. You can create e.g. en_DE.UTF-8: https://forums.opensuse.org/showthre...86#post2836886 You may start with file /usr/share/i18n/locales/fr_FR
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •