Results 1 to 3 of 3

Thread: Cannot get through install

  1. #1

    Default Cannot get through install

    Hi all,
    So I'm having some trouble with the installation process. I'm trying convert an ubuntu system to a tumbleweed system. The only real issue is that there's a big btrfs array on it, but the installation seems to find that and have no problems with it. Basically, I pulled out the old boot disk, put in a new one (leaving the existing btrfs array intact), and boot from an install dvd. I already used the install dvd to install tumbleweed onto a different machine, that one seems to be working fine, I had no problems with the install on that one at all. But for this one, it get to the "Perfroming Installation" screen, it starts installing each package, but at some point it stops and gives me an error that looks like this:

    error: 2: Failed to provide package mariadb-error......(whole name of package)

    Then it gives me the Ignore, Abort, Retry options. Tried to retry, didn't work. Tried ignore, it moves on, but it fails on the next package. Same kind of error for the next package. Here's what show details looks like (I'm copying from a picture on my phone, might not be letter for letter):

    Error: 2:Failed to provide Package openSUSE-release-appliance-custom-20200910-690.1.x86....

    [openSUSE-20200910-0|cd:/?devices=/dev/disk/vy/id/usb-HL-DT-ST_DVDRAM_GE24NU30_P....
    History:
    - Can't hardlin/copy /var/adm/mount/AP_0xn[UZu2/x86_64/openSUSE-release-appliance-.....
    - Can't provide ./x86_64/openSUSE-release-appliance-custom-20200910-690.1.x86_64.rpm

    With Ignore, Abort, Rerty at the bottom. I'm guessing that at some point my external dvd drive is giving it problems, although with 10% of the packages done, it's not going to finish the installation. Any ideas? I suppose I could:

    Add an internal dvd drive and use that for the install?
    Try a different media (like a thumb drive) for the install?
    Somehow have it bootstrap from the currently running installation on a different machine in the network?

    I'm open to suggestions, oddly the 3rd option would be easiest (assuming there isn't a metric ton of setup). Thanks for any help!

  2. #2
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,396

    Default Re: Cannot get through install

    Quote Originally Posted by cordis View Post
    Try a different media (like a thumb drive) for the install?
    Try the NET installation media instead of the DVD. If you encounter the same or similar problem, switch to the shell vtty (Ctrl-Alt-F2) and run df to see if there is a space shortage, and parted -l or fdisk -l to get a sense of what partitioning the installer has employed.

    What exactly do you mean by "convert"? Did you really mean replace? Did the Ubuntu installation use a separate filesystem for /home than for /? Was/is Ubuntu /home on BTRFS or LVM rather than a separate partition?

    From vtty2 it should be possible to capture installation logs using the save_y2logs command to a USB stick or by mounting an available HD or NFS filesystem, which can enable evaluation of the encountered problem by others when uploaded to susepaste.org or pastebin.com or equivalent.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.1, TW, 15.2 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&15.1 on i965P/Radeon
    Tertiary: TW,15.2,15.1,Fedora,Debian,more on Kaby Lake,iQ45,iQ43,iG41,iG3X,i965G,AMD,NVidia&&&

  3. #3

    Default Re: Cannot get through install

    Thanks for the help mrmazda. I did try it from a thumb drive instead, still didn't work. To be clear, I was trying to replace the boot disk on the ubuntu system with a larger one and put tumbleweed on it, but leave another btrfs array on some other drives alone. I wound up having to disconnect all those (18) drives, then it went pretty smoothly. So somewhat annoying, but got through it, so it's all good now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •