Results 1 to 5 of 5

Thread: Policy Kit decides to use a partition

  1. #1

    Unhappy Policy Kit decides to use a partition

    I have upgraded to 15.2 from previous version.

    Right after the boot, while Plasma is starting, the policy kit (PolKit1) wants to mount a partition, and asks root's password for that.

    I don't want that partition to be mounted. There is nothing said about the partition in fstab.

    In System Settings -> Removable Storage -> Removable Devices -> Device Overrides, the partition is neither listed to be automounted at login nor to be automounted on attach (all boxes are unchecked in the table).

    There are other partitions in the computer, which policy kit does not want to mount.

    How can I disable that undesirable behavior of the policy kit? I haven't configured it in any way.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,400
    Blog Entries
    3

    Default Re: Policy Kit decides to use a partition

    Your desktop is probably configured to restore the previous setting on startup. And in that previous session, you may have had something open that required access to this file system.

    My suggestion:

    Configure Desktop --> Startup & Shutdown --> Desktop Session

    and then check the box "Start with an empty session".

    Logout or reboot, and check whether that has solved the problem.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,644
    Blog Entries
    15

    Default Re: Policy Kit decides to use a partition

    Hi
    Set a udev rule to ignore it... For example;

    Code:
    cat /etc/udev/rules.d/99-hide-partition.rules
    
    KERNEL=="sde3", ENV{UDISKS_IGNORE}="1"
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4

    Default Was not this setting

    Quote Originally Posted by nrickert View Post
    Your desktop is probably configured to restore the previous setting on startup. And in that previous session, you may have had something open that required access to this file system.

    Configure Desktop --> Startup & Shutdown --> Desktop Session
    and then check the box "Start with an empty session".
    Was already set up like this.

  5. #5

    Smile Policy Kit's KDE Agent was quite persistent

    Quote Originally Posted by malcolmlewis View Post
    Set a udev rule to ignore it...

    Code:
    cat /etc/udev/rules.d/99-hide-partition.rules
    
    KERNEL=="sde3", ENV{UDISKS_IGNORE}="1"
    Thanks. After I did this, the policy kit's agent decided to mount the next partition.
    So I blocked a few partitions from being mounted with rules.
    Now runs correctly.

    (This KDE agent is very persistent; must be on 33.33% commission?)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •