Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Update Error Leap 15.2

  1. #1
    Join Date
    May 2020
    Posts
    8

    Default Update Error Leap 15.2

    Hi,
    I am getting an update error
    patch:openSUSE-2020-1421-1.noarch conflicts with
    kio-core-debuginfo.x86_64
    It happens every time it tries to update.
    What should I do about this?
    Thanks,

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,889

    Default AW: Update Error Leap 15.2

    Update with:
    Code:
    zypper up
    as root.

    Did that solve your problem?

  3. #3
    Join Date
    May 2020
    Posts
    8

    Default Re: Update Error Leap 15.2

    No, this did not solve my problem.

    zupper up as root says "Nothing to do"

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,889

    Default AW: Update Error Leap 15.2

    Post:
    Code:
    zypper lr -d
    Code:
    zypper se -s kio-core

  5. #5
    Join Date
    May 2020
    Posts
    8

    Default Re: Update Error Leap 15.2

    I tried this and still get the error

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    27,161

    Default Re: Update Error Leap 15.2

    Quote Originally Posted by pde View Post
    I tried this and still get the error
    I assume you missed something. The question was to post that command and its output here. So that we can see things.
    Henk van Velden

  7. #7
    Join Date
    May 2020
    Posts
    8

    Default Re: Update Error Leap 15.2

    Sorry about that.


    linux-140i:/home/paul # zypper lr -d
    # | Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service
    ---+---------------------------+------------------------------------+---------+-----------+---------+----------+--------+------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+--------
    1 | openSUSE-Leap-15.2-1 | openSUSE-Leap-15.2-1 | No | ---- | ---- | 99 | rpm-md | hd:/?device=/dev/disk/by-id/usb-SanDisk_Ultra_USB_3.0_0401483e17d352676340af973ad94b672fbd4cdc4c8ea6aef8ade573f21c46f201cb0000000000000000000060aff01900140f18915581079aa659f2-0:0-part2 |
    2 | packman.inode.at-suse | Packman Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_15.2/ |
    3 | repo-debug | Debug Repository | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/d...15.2/repo/oss/ |
    4 | repo-debug-non-oss | Debug Repository (Non-OSS) | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/d.../repo/non-oss/ |
    5 | repo-debug-update | Update Repository (Debug) | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/u...leap/15.2/oss/ |
    6 | repo-debug-update-non-oss | Update Repository (Debug, Non-OSS) | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/u.../15.2/non-oss/ |
    7 | repo-non-oss | Non-OSS Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/distrib.../repo/non-oss/ |
    8 | repo-oss | Main Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/distrib...15.2/repo/oss/ |
    9 | repo-source | Source Repository | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/...15.2/repo/oss/ |
    10 | repo-source-non-oss | Source Repository (Non-OSS) | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/.../repo/non-oss/ |
    11 | repo-update | Main Update Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/15.2/oss/ |
    12 | repo-update-non-oss | Update Repository (Non-Oss) | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/15.2/non-oss/ |
    13 | vscode | vscode | Yes | (r ) Yes | No | 99 | NONE | https://packages.microsoft.com/yumrepos/vscode |
    linux-140i:/home/paul # zypper se -s kio-core
    Loading repository data...
    Reading installed packages...

    S | Name | Type | Version | Arch | Repository
    ---+--------------------+---------+--------------------+--------+-----------------------
    i+ | kio-core | package | 5.71.0-lp152.2.9.1 | x86_64 | Main Update Repository
    v | kio-core | package | 5.71.0-lp152.2.6.1 | x86_64 | Main Update Repository
    v | kio-core | package | 5.71.0-lp152.2.3.1 | x86_64 | Main Update Repository
    v | kio-core | package | 5.71.0-lp152.1.1 | x86_64 | Main Repository
    v | kio-core | package | 5.71.0-lp152.2.9.1 | i586 | Main Update Repository
    v | kio-core | package | 5.71.0-lp152.2.6.1 | i586 | Main Update Repository
    v | kio-core | package | 5.71.0-lp152.2.3.1 | i586 | Main Update Repository
    | kio-core-32bit | package | 5.71.0-lp152.2.9.1 | x86_64 | Main Update Repository
    | kio-core-32bit | package | 5.71.0-lp152.2.6.1 | x86_64 | Main Update Repository
    | kio-core-32bit | package | 5.71.0-lp152.2.3.1 | x86_64 | Main Update Repository
    | kio-core-32bit | package | 5.71.0-lp152.1.1 | x86_64 | Main Repository
    i+ | kio-core-debuginfo | package | 5.71.0-lp152.2.6.1 | x86_64 | (System Packages)

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    27,161

    Default Re: Update Error Leap 15.2

    Please, please, next time use CODE tags as I explained in my PM to you.
    Henk van Velden

  9. #9
    Join Date
    May 2020
    Posts
    8

    Default Re: Update Error Leap 15.2

    Code:
    Nothing to do.
    linux-140i:/home/paul # zypper lr -d
    #  | Alias                     | Name                               | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                                                                                                                      | Service
    ---+---------------------------+------------------------------------+---------+-----------+---------+----------+--------+------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+--------
     1 | openSUSE-Leap-15.2-1      | openSUSE-Leap-15.2-1               | No      | ----      | ----    |   99     | rpm-md | hd:/?device=/dev/disk/by-id/usb-SanDisk_Ultra_USB_3.0_0401483e17d352676340af973ad94b672fbd4cdc4c8ea6aef8ade573f21c46f201cb0000000000000000000060aff01900140f18915581079aa659f2-0:0-part2 | 
     2 | packman.inode.at-suse     | Packman Repository                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_15.2/                                                                                                                                         | 
     3 | repo-debug                | Debug Repository                   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.2/repo/oss/                                                                                                                      | 
     4 | repo-debug-non-oss        | Debug Repository (Non-OSS)         | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.2/repo/non-oss/                                                                                                                  | 
     5 | repo-debug-update         | Update Repository (Debug)          | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.2/oss/                                                                                                                                 | 
     6 | repo-debug-update-non-oss | Update Repository (Debug, Non-OSS) | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.2/non-oss/                                                                                                                             | 
     7 | repo-non-oss              | Non-OSS Repository                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/non-oss/                                                                                                                        | 
     8 | repo-oss                  | Main Repository                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/oss/                                                                                                                            | 
     9 | repo-source               | Source Repository                  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.2/repo/oss/                                                                                                                     | 
    10 | repo-source-non-oss       | Source Repository (Non-OSS)        | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.2/repo/non-oss/                                                                                                                 | 
    11 | repo-update               | Main Update Repository             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.2/oss/                                                                                                                                       | 
    12 | repo-update-non-oss       | Update Repository (Non-Oss)        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.2/non-oss/                                                                                                                                   | 
    13 | vscode                    | vscode                             | Yes     | (r ) Yes  | No      |   99     | NONE   | https://packages.microsoft.com/yumrepos/vscode                                                                                                                                           | 
    linux-140i:/home/paul # zypper se -s kio-core
    Loading repository data...
    Reading installed packages...
    
    S  | Name               | Type    | Version            | Arch   | Repository
    ---+--------------------+---------+--------------------+--------+-----------------------
    i+ | kio-core           | package | 5.71.0-lp152.2.9.1 | x86_64 | Main Update Repository
    v  | kio-core           | package | 5.71.0-lp152.2.6.1 | x86_64 | Main Update Repository
    v  | kio-core           | package | 5.71.0-lp152.2.3.1 | x86_64 | Main Update Repository
    v  | kio-core           | package | 5.71.0-lp152.1.1   | x86_64 | Main Repository
    v  | kio-core           | package | 5.71.0-lp152.2.9.1 | i586   | Main Update Repository
    v  | kio-core           | package | 5.71.0-lp152.2.6.1 | i586   | Main Update Repository
    v  | kio-core           | package | 5.71.0-lp152.2.3.1 | i586   | Main Update Repository
       | kio-core-32bit     | package | 5.71.0-lp152.2.9.1 | x86_64 | Main Update Repository
       | kio-core-32bit     | package | 5.71.0-lp152.2.6.1 | x86_64 | Main Update Repository
       | kio-core-32bit     | package | 5.71.0-lp152.2.3.1 | x86_64 | Main Update Repository
       | kio-core-32bit     | package | 5.71.0-lp152.1.1   | x86_64 | Main Repository
    i+ | kio-core-debuginfo | package | 5.71.0-lp152.2.6.1 | x86_64 | (System Packages)

  10. #10
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,430
    Blog Entries
    3

    Default Re: Update Error Leap 15.2

    Quote Originally Posted by pde View Post
    Hi,
    I am getting an update error
    patchpenSUSE-2020-1421-1.noarch conflicts with
    kio-core-debuginfo.x86_64
    I'm replying to the first post, but I have read the others.

    You have not provided enough enough information. But I can guess what is going on. My guess might be wrong, of course.

    Your installed "kio-core-debuginfo" package is probably out of date. But the debug repo is disabled, so it cannot be updated.

    The simplest step, at present, would be to remove "kio-core-debuginfo". You should be able to do that with:
    Code:
    zypper remove kio-core-debuginfo
    Do that as root. If you actually need that package, then enable "repo-debug-update" and install the latest version.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •