Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: HP LaserJet Pro MFP M28-M31- multifunction scanner error using xsane

  1. #11
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,869

    Default AW: HP LaserJet Pro MFP M28-M31- multifunction scanner error using xsane

    Do you installed the missing libs shown by hp-check?

  2. #12
    Join Date
    Apr 2018
    Location
    U.S Midwest just West of the Mississippi River
    Posts
    693

    Default Re: AW: HP LaserJet Pro MFP M28-M31- multifunction scanner error using xsane

    Quote Originally Posted by Sauerland View Post
    Do you installed the missing libs shown by hp-check?
    I tried to find them in GUI YaST, but I got 'no matching results' in the searches.
    HP Compaq desktop Leap15.2, Win10, Win7
    Toshiba laptops Leap15.2 & Win10, HP AiO Win10.
    I can now print with openSuSe Leap! Can Scan now, could be better!!
    I can backup my iPod and iPad with Windows, can't with Linux.(Will get there someday!)

  3. #13
    Join Date
    Apr 2018
    Location
    U.S Midwest just West of the Mississippi River
    Posts
    693

    Default Re: HP LaserJet Pro MFP M28-M31- multifunction scanner error using xsane

    YaST show some DBus's are installed, but apparently not the one(s) needed.
    Also YaST indicates hplip version 3.19.12 is installed, but my unit is not among the 'supported' units for that version per the following:
    https://developers.hp.com/hp-linux-i..._devices/index
    Mine is MFP M28 and it is way down in the 3-18.4 version of hplip.
    MORE CONFUSION!

    There are some warnings at the beginning of hp-check that I should have found yesterday, Sorry, that lot of text was confusing.
    Code:
    HP Linux Imaging and Printing System (ver. 3.19.12)
    Dependency/Version Check Utility ver. 15.1
    
    Copyright (c) 2001-18 HP Development Company, LP
    This software comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to distribute it
    under certain conditions. See COPYING file for more details.
    
    Note: hp-check can be run in three modes:
    1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies    
    are installed to successfully compile HPLIP.                                                                                                                         
    2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball has the   
    proper dependencies installed to successfully run.                                                                                                                   
    3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and run-time dependencies).           
    
    Check types:                                                                                                                                                         
    a. EXTERNALDEP - External Dependencies                                                                                                                               
    b. GENERALDEP - General Dependencies (required both at compile and run time)                                                                                         
    c. COMPILEDEP - Compile time Dependencies                                                                                                                            
    d. [All are run-time checks]                                                                                                                                         
    PYEXT SCANCONF QUEUES PERMISSION                                                                                                                                     
    
    Status Types:
        OK
        MISSING       - Missing Dependency or Permission or Plug-in
        INCOMPAT      - Incompatible dependency-version or Plugin-version
    
    warning: 3-15.2 version is not supported. Using 3-15.1 versions dependencies to verify and install...
    
    ---------------
    | SYSTEM INFO |
    ---------------
    
     Kernel: 5.3.18-lp152.41-default #1 SMP Thu Sep 3 23:02:59 UTC 2020 (a4d139b) GNU/Linux
     Host: linux-ipxi
     Proc: 5.3.18-lp152.41-default #1 SMP Thu Sep 3 23:02:59 UTC 2020 (a4d139b) GNU/Linux
     Distribution: 3 15.2
     Bitness: 64 bit
    
    
    -----------------------
    | HPLIP CONFIGURATION |
    -----------------------
    
    HPLIP-Version: HPLIP 3.19.12
    HPLIP-Home: /usr/share/hplip
    warning: HPLIP-Installation: Auto installation is not supported for 3 distro  15.2 version 
    
    I am at a loss as to what hplip version I should have, why V3.19.12 is installed, and what I should do to correct if any!
    HP Compaq desktop Leap15.2, Win10, Win7
    Toshiba laptops Leap15.2 & Win10, HP AiO Win10.
    I can now print with openSuSe Leap! Can Scan now, could be better!!
    I can backup my iPod and iPad with Windows, can't with Linux.(Will get there someday!)

  4. #14
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    483

    Default Re: HP LaserJet Pro MFP M28-M31- multifunction scanner error using xsane

    Quote Originally Posted by Bill_L View Post
    YaST show some DBus's are installed, but apparently not the one(s) needed.
    Also YaST indicates hplip version 3.19.12 is installed, but my unit is not among the 'supported' units for that version per the following:
    https://developers.hp.com/hp-linux-i..._devices/index
    Mine is MFP M28 and it is way down in the 3-18.4 version of hplip.

    I am at a loss as to what hplip version I should have, why V3.19.12 is installed, and what I should do to correct if any!
    The supported devices link you posted has as a column header
    Min. HPLIP Version
    meaning minimum. Any newer version, like 3.19.2, will work
    Howard
    ThinkPads 310ED, 600E, T23, X41, X60, T61, X201, E550, X390

  5. #15
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,869

    Default AW: Re: AW: HP LaserJet Pro MFP M28-M31- multifunction scanner error using xsane

    Quote Originally Posted by Bill_L View Post
    I tried to find them in GUI YaST, but I got 'no matching results' in the searches.
    These:
    Code:
    LANG=C zypper se -si cups-devel libjpeg avahi-utils sane-backends-devel net-snmp-devel python3-notify2
    Loading repository data...
    Reading installed packages...
    
    S  | Name                | Type    | Version                      | Arch   | Repository
    ---+---------------------+---------+------------------------------+--------+-----------
    i+ | avahi-utils         | package | 0.7-lp152.3.3.1              | x86_64 | OSS-Update
    i+ | cups-devel          | package | 2.2.7-lp152.8.2              | x86_64 | OSS
    i+ | libjpeg-turbo       | package | 2.0.5-lp152.173.7            | x86_64 | Sauerland
    i+ | libjpeg62           | package | 62.3.0-lp152.173.6           | x86_64 | Sauerland
    i+ | libjpeg62-32bit     | package | 62.2.0-lp152.8.3.1           | x86_64 | OSS-Update
    i+ | libjpeg62-devel     | package | 62.3.0-lp152.173.6           | x86_64 | Sauerland
    i+ | libjpeg8            | package | 8.2.2-lp152.173.7            | x86_64 | Sauerland
    i+ | libjpeg8-32bit      | package | 8.1.2-lp152.8.3.1            | x86_64 | OSS-Update
    i+ | libjpegxr0          | package | 1.1-lp152.5.3                | x86_64 | Sauerland
    i+ | net-snmp-devel      | package | 5.7.3-lp152.8.9              | x86_64 | OSS
    i+ | python3-notify2     | package | 0.3.1-lp152.4.1              | noarch | OSS
    i+ | sane-backends-devel | package | 1.0.31.git20200918-lp152.1.1 | x86_64 | Sauerland
    Last edited by Sauerland; 22-Sep-2020 at 23:24.

  6. #16
    Join Date
    Apr 2018
    Location
    U.S Midwest just West of the Mississippi River
    Posts
    693

    Default Re: AW: Re: AW: HP LaserJet Pro MFP M28-M31- multifunction scanner error using xsane

    Quote Originally Posted by Sauerland View Post
    These:
    Code:
    LANG=C zypper se -si cups-devel libjpeg avahi-utils sane-backends-devel net-snmp-devel python3-notify2
    Loading repository data...
    Reading installed packages...
    
    S  | Name                | Type    | Version                      | Arch   | Repository
    ---+---------------------+---------+------------------------------+--------+-----------
    i+ | avahi-utils         | package | 0.7-lp152.3.3.1              | x86_64 | OSS-Update
    i+ | cups-devel          | package | 2.2.7-lp152.8.2              | x86_64 | OSS
    i+ | libjpeg-turbo       | package | 2.0.5-lp152.173.7            | x86_64 | Sauerland
    i+ | libjpeg62           | package | 62.3.0-lp152.173.6           | x86_64 | Sauerland
    i+ | libjpeg62-32bit     | package | 62.2.0-lp152.8.3.1           | x86_64 | OSS-Update
    i+ | libjpeg62-devel     | package | 62.3.0-lp152.173.6           | x86_64 | Sauerland
    i+ | libjpeg8            | package | 8.2.2-lp152.173.7            | x86_64 | Sauerland
    i+ | libjpeg8-32bit      | package | 8.1.2-lp152.8.3.1            | x86_64 | OSS-Update
    i+ | libjpegxr0          | package | 1.1-lp152.5.3                | x86_64 | Sauerland
    i+ | net-snmp-devel      | package | 5.7.3-lp152.8.9              | x86_64 | OSS
    i+ | python3-notify2     | package | 0.3.1-lp152.4.1              | noarch | OSS
    i+ | sane-backends-devel | package | 1.0.31.git20200918-lp152.1.1 | x86_64 | Sauerland
    THANKS for all that. But what about the missing DBus? Isn’t it also necessary?
    What are the packages that show your name after the description?

    Besides, on the desktop connected via USB cable it scans, albeit slowly. I can’t think of anything I want to scan from the network with either of the WiFi laptops because the printer is way far away from them.
    HP Compaq desktop Leap15.2, Win10, Win7
    Toshiba laptops Leap15.2 & Win10, HP AiO Win10.
    I can now print with openSuSe Leap! Can Scan now, could be better!!
    I can backup my iPod and iPad with Windows, can't with Linux.(Will get there someday!)

  7. #17
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,869

    Default AW: HP LaserJet Pro MFP M28-M31- multifunction scanner error using xsane

    But what about the missing DBus? Isn’t it also necessary?
    I think its dbus-1-devel.

    So please run hp-check once more as User, one time with the Printer connected via USB, one time with printer connected via Wifi.
    You get a log in your /home/USERNAME called hp-check.log, which you have to save before you run hp-check with Wifi.

    Save both files to a File-server or paste them on paste.opensuse.org and post the URL you get here.

  8. #18
    Join Date
    Apr 2018
    Location
    U.S Midwest just West of the Mississippi River
    Posts
    693

    Default Re: AW: HP LaserJet Pro MFP M28-M31- multifunction scanner error using xsane

    Quote Originally Posted by Sauerland View Post
    I think its dbus-1-devel.

    So please run hp-check once more as User, one time with the Printer connected via USB, one time with printer connected via Wifi.
    You get a log in your /home/USERNAME called hp-check.log, which you have to save before you run hp-check with Wifi.

    Save both files to a File-server or paste them on paste.opensuse.org and post the URL you get here.
    I hope this is what you were asking for. (I had to install hplip on my laptop to do the check on WiFi machine.)
    Desktop USB https://susepaste.org/36947430
    Laptop WiFi https://susepaste.org/91716968

    NOTE: I both cases the printer unit was still connected to the desktop with a USB cable, but when I did the laptop check the desktop was shut down. I could 'print' from the laptop without hplip sine the printer is WiFi enabled.
    HP Compaq desktop Leap15.2, Win10, Win7
    Toshiba laptops Leap15.2 & Win10, HP AiO Win10.
    I can now print with openSuSe Leap! Can Scan now, could be better!!
    I can backup my iPod and iPad with Windows, can't with Linux.(Will get there someday!)

  9. #19
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,869

    Default AW: HP LaserJet Pro MFP M28-M31- multifunction scanner error using xsane

    1. You have not installed the missing packages.
    2. I get a longer log:
    https://susepaste.org/58745693

    Do you install the driver with hp-setup running as root?

    I installed my HP-Envy without any problems by:
    1.connect the HP-Envy via USB and running as root:
    Code:
    hp-setup
    2. After this, connecting the HP-Envy only via Wifi and running as root:
    Code:
    hp-setup
    Thats all, printing and scanning is working.
    But I forget, the HP-Envy has a static IP, no dhcp.....

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •