Results 1 to 5 of 5

Thread: wireshark won't run on LEAP 15.2

  1. #1

    Default wireshark won't run on LEAP 15.2

    Installed wireshark from the 15.2 repo but it will not run as follows:


    Code:
    foo@bar:~> sudo wireshark 
    [sudo] password for root:  
    qt.qpa.xcb: could not connect to display  
    qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found. 
    error: XDG_RUNTIME_DIR not set in the environment. 
    Failed to create wl_display (No such file or directory) 
    qt.qpa.plugin: Could not load the Qt platform plugin "wayland" in "" even though it was found. 
    This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem. 
     
    Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb. 
     
    Aborted
    Is there a fix?

    TIA!

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,183

    Default AW: wireshark won't run on LEAP 15.2

    Do you install wireshark-ui-qt

  3. #3

    Default Re: AW: wireshark won't run on LEAP 15.2

    Quote Originally Posted by Sauerland View Post
    Do you install wireshark-ui-qt
    yes it is installed

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,183

    Default AW: wireshark won't run on LEAP 15.2

    sudo wireshark
    [sudo] Passwort für root:
    qt.qpa.xcb: could not connect to display
    qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
    error: XDG_RUNTIME_DIR not set in the environment.
    Failed to create wl_display (No such file or directory)
    qt.qpa.plugin: Could not load the Qt platform plugin "wayland" in "" even though it was found.
    This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

    Available platform plugins are: wayland-org.kde.kwin.qpa, eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

    Abgebrochen
    Same here with sudo, but with su it works......

  5. #5

    Default Re: AW: wireshark won't run on LEAP 15.2

    Quote Originally Posted by Sauerland View Post
    Same here with sudo, but with su it works......
    Thank you much, that works!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •