Results 1 to 7 of 7

Thread: Games not working

  1. #1

    Default Games not working

    Hello,
    I love Tumbleweed but not all my steam games work like the did in Manjaro.
    Am I missing something that needs installing? should I be using Leap?
    I have followed a couple of guides on you tube but still no luck,
    any help would be appreciated because I would like to keep using openSUSE

    Thanks

  2. #2

    Default Re: Games not working

    Same. Several Windows games that used to work with Steam Play are broken now. Usually they just bomb but some throw errors complaining about DirectX which suggests that something is recently broken in the DXVK DirectX-to-Vulkan translation.

  3. #3

    Default Re: Games not working

    Quote Originally Posted by 8876523450 View Post
    Same. Several Windows games that used to work with Steam Play are broken now. Usually they just bomb but some throw errors complaining about DirectX which suggests that something is recently broken in the DXVK DirectX-to-Vulkan translation.
    I'm experiencing the same error. Worked fine until two weeks ago and suddenly Steam Play titles would require "PROTON_USE_WINED3D %command%"; otherwise they would just start loading and then crash silently. But playing without Vulkan isn't really an option with most titles.

    @Sebenza: Could you try to start Windows-only games with "PROTON_USE_WINED3D %command%"? Just so I know whether I should rather start a new thread for 8876523450's and my issue.

  4. #4

    Default Re: Games not working

    I don't know if this helps but I've just moved to opensuse krypton from Neon Unstable (Ubuntu 20.04) where I played Skyrim Special edition successfully.

    SSE won't launch on opensuse (tried both proton 4.11 & 5.0), it opens a launching dialogue box for a few seconds and then closes.

    But Skyrim vanilla works same as on Neon, with proton 4.11 and
    WINEDLLOVERRIDES="xaudio2_7=n,b" PULSE_LATENCY_MSEC=90 %command%

    Adding:
    PROTON_USE_WINED3D %command%
    doesn't change anything.

  5. #5

  6. #6

    Default Re: Games not working

    Millesimus, Sorry I stopped using openSUSE and switched to another distro because of this issue
    i liked tumbleweed just not enough help with issues like this

  7. #7

    Thumbs up Re: Games not working

    Thank you so so much! I don't know how long I searched for a solution but I didn't come across this issue. Adding the Wayland OBS repo and upgrading libvulkans resolved it for me.

    @Sebenza31: I'm very sorry to hear this. For me this was the first time I had to ask for help and it turned out very well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •