Results 1 to 4 of 4

Thread: after upgrading to tumbleed 20201022 I had packman conflicts

  1. #1

    Question after upgrading to tumbleed 20201022 I had packman conflicts

    Hi there,
    I had packman installed but after trying to upgrade tumbleweed to 20201022 a lot of conflicting files/packed are flagged.
    Easy solution was to remove the affected packages and removing the packman repository that solve the conflicting issues and the system upgrade fine to 20201022.
    Now with the system in 20201022 I've tried to add packman repository again and re-installing the affected packages. No go....
    Code:
    kimera:/home/miguel # tumbleweed status
    latest   : 20201026
    target   : 20201022
    installed: 20201022
    kimera:/home/miguel #
    kimera:/home/miguel # zypper ref
    Repository 'Google-Chrome' is up to date.
    Repository 'NVIDIA' is up to date.
    Repository 'Tumbleweed OSS' is up to date.
    Repository 'Tumbleweed non-OSS' is up to date.
    Repository 'Tumbleweed update' is up to date.
    Repository 'google-chrome-beta' is up to date.
    Repository 'Java-related packages (openSUSE_Tumbleweed)' is up to date.
    Repository 'libdvdcss repository' is up to date.
    Repository 'nvidia-tumbleweed' is up to date.
    Repository 'snappy' is up to date.
    Repository 'vscode' is up to date.
    All repositories have been refreshed.
    kimera:/home/miguel # zypper dup
    Loading repository data...
    Reading installed packages...
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Computing distribution upgrade...
    
    The following item is locked and will not be changed by any action:
     Available:
      Mesa-dri-nouveau
    
    Nothing to do.
    kimera:/home/miguel #
    
    Then adding the packman and trying to re-install the affected packages result in a lot of conflicts and removal of important packages for me, like digikam and showphoto.
    How to fix this ?

    Code:
    kimera:/home/miguel # zypper addrepo -cfp 90 https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/ packman      
    Adding repository 'packman' ................................................................................................................................................................................................................[done]
    Repository 'packman' successfully added
    
    URI         : https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/
    Enabled     : Yes
    GPG Check   : Yes
    Autorefresh : Yes
    Priority    : 90 (raised priority)
    
    Repository priorities in effect:                                                                                                                                                                                  (See 'zypper lr -P' for details)
          90 (raised priority)  :  1 repository
          99 (default priority) : 11 repositories
    kimera:/home/miguel # zypper in  vlc vlc-codecs k3b-codecs ffmpeg lame gstreamer-plugins-libav gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer-plugins-good gstreamer-fluendo-mp3 libdvdcss2   
    Retrieving repository 'packman' metadata ...................................................................................................................................................................................................[done]
    Building repository 'packman' cache ........................................................................................................................................................................................................[done]
    Loading repository data...
    Reading installed packages...
    Package 'gstreamer-fluendo-mp3' not found.
    Package 'k3b-codecs' not found.
    'ffmpeg' not found in package names. Trying capabilities.
    Resolving package dependencies...
    3 Problems:
    Problem: vlc-codecs-3.0.11.1-5.5.x86_64 requires libavcodec58_91(unrestricted), but this requirement cannot be provided
    Problem: vlc-3.0.11.1-5.5.x86_64 requires vlc-noX = 3.0.11.1-5.5, but this requirement cannot be provided
    Problem: nothing provides libvmaf.so.0()(64bit) needed by libavfilter7_85-4.3.1-8.1.x86_64
    
    Problem: vlc-codecs-3.0.11.1-5.5.x86_64 requires libavcodec58_91(unrestricted), but this requirement cannot be provided
      not installable providers: libavcodec58_91-4.3.1-8.1.i586[packman]
                       libavcodec58_91-4.3.1-8.1.x86_64[packman]
     Solution 1: Following actions will be done:
      install libavcodec58_91-4.3.1-8.1.x86_64 (with vendor change)
        openSUSE  -->  http://packman.links2linux.de
      install libavformat58_45-4.3.1-8.1.x86_64 (with vendor change)
        openSUSE  -->  http://packman.links2linux.de
      deinstallation of libavfilter7_85-4.3.1-4.1.x86_64
      deinstallation of libavdevice58_10-4.3.1-4.1.x86_64
      architecture change of ffmpegthumbs-20.08.2-1.1.x86_64 to ffmpegthumbs-20.08.2-1.1.i586
      architecture change of libQtAV1-1.13.0-3.5.x86_64 to libQtAV1-1.13.0-3.5.i586
      deinstallation of libdigikamcore7-7.1.0-1.4.x86_64
      deinstallation of digikam-plugins-7.1.0-1.4.x86_64
      deinstallation of digikam-7.1.0-1.4.x86_64
      deinstallation of showfoto-7.1.0-1.4.x86_64
      architecture change of libQtAVWidgets1-1.13.0-3.5.x86_64 to libQtAVWidgets1-1.13.0-3.5.i586
      install libswscale5_7-4.3.1-8.1.x86_64 (with vendor change)
        openSUSE  -->  http://packman.links2linux.de
     Solution 2: do not install vlc-codecs-3.0.11.1-5.5.x86_64
     Solution 3: break vlc-codecs-3.0.11.1-5.5.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c/d/?] (c): c
    kimera:/home/miguel #
    
    Am i doing something wrong ?
    There is another way to get the restricted multimedia codecs other than that way ?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    27,325

    Default Re: after upgrading to tumbleed 20201022 I had packman conflicts

    The only thing you have to do after adding the Packman repo is "do the vendor switch to it"
    Code:
    zypper dup --from packman
    Henk van Velden

  3. #3

    Default Re: after upgrading to tumbleed 20201022 I had packman conflicts

    Quote Originally Posted by hcvv View Post
    The only thing you have to do after adding the Packman repo is "do the vendor switch to it"
    Code:
    zypper dup --from packman
    Doing that, causes the removal of showphoto, digikam,
    Code:
    kimera:/home/miguel # zypper addrepo -cfp 90 https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/ packman                                                                           
    Adding repository 'packman' ................................................................................................................................................................................................................[done]
    Repository 'packman' successfully added
    
    URI         : https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/
    Enabled     : Yes
    GPG Check   : Yes
    Autorefresh : Yes
    Priority    : 90 (raised priority)
    
    Repository priorities in effect:                                                                                                                                                                                  (See 'zypper lr -P' for details)
          90 (raised priority)  :  1 repository
          99 (default priority) : 11 repositories
    kimera:/home/miguel # zypper dup --from packman
    Retrieving repository 'packman' metadata ...................................................................................................................................................................................................[done]
    Building repository 'packman' cache ........................................................................................................................................................................................................[done]
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    27 Problems:
    Problem: problem with installed package libavcodec58_91-4.3.1-4.1.x86_64
    Problem: problem with installed package libavdevice58_10-4.3.1-4.1.x86_64
    Problem: problem with installed package libavfilter7_85-4.3.1-4.1.x86_64
    Problem: problem with installed package libavformat58_45-4.3.1-4.1.x86_64
    Problem: problem with installed package libavresample4_0-4.3.1-4.1.x86_64
    Problem: problem with installed package libavutil56_51-4.3.1-4.1.x86_64
    Problem: problem with installed package libgstadaptivedemux-1_0-0-1.16.2-9.3.x86_64
    Problem: problem with installed package libgstbadaudio-1_0-0-1.16.2-9.3.x86_64
    Problem: problem with installed package libgstbasecamerabinsrc-1_0-0-1.16.2-9.3.x86_64
    Problem: problem with installed package libgstcodecparsers-1_0-0-1.16.2-9.3.x86_64
    Problem: problem with installed package libgstisoff-1_0-0-1.16.2-9.3.x86_64
    Problem: problem with installed package libgstmpegts-1_0-0-1.16.2-9.3.x86_64
    Problem: problem with installed package libgstphotography-1_0-0-1.16.2-9.3.x86_64
    Problem: problem with installed package libgstsctp-1_0-0-1.16.2-9.3.x86_64
    Problem: problem with installed package libgsturidownloader-1_0-0-1.16.2-9.3.x86_64
    Problem: problem with installed package libgstwayland-1_0-0-1.16.2-9.3.x86_64
    Problem: problem with installed package libgstwebrtc-1_0-0-1.16.2-9.3.x86_64
    Problem: problem with installed package libpostproc55_7-4.3.1-4.1.x86_64
    Problem: problem with installed package libquicktime0-1.2.4+git20180804.fff99cd-2.4.x86_64
    Problem: problem with installed package libswresample3_7-4.3.1-4.1.x86_64
    Problem: problem with installed package libswscale5_7-4.3.1-4.1.x86_64
    Problem: problem with installed package libvlc5-3.0.11.1-2.2.x86_64
    Problem: problem with installed package libvlccore9-3.0.11.1-2.2.x86_64
    Problem: problem with installed package vlc-codec-gstreamer-3.0.11.1-2.2.x86_64
    Problem: problem with installed package vlc-noX-3.0.11.1-2.2.x86_64
    Problem: problem with installed package vlc-qt-3.0.11.1-2.2.x86_64
    Problem: problem with installed package vlc-lang-3.0.11.1-2.2.noarch
    
    Problem: problem with installed package libavcodec58_91-4.3.1-4.1.x86_64
     Solution 1: Following actions will be done:
      install libavcodec58_91-4.3.1-8.1.x86_64 (with vendor change)
        openSUSE  -->  http://packman.links2linux.de
      deinstallation of libdigikamcore7-7.1.0-1.4.x86_64
      architecture change of libQtAV1-1.13.0-3.5.x86_64 to libQtAV1-1.13.0-3.5.i586
      architecture change of ffmpegthumbs-20.08.2-1.1.x86_64 to ffmpegthumbs-20.08.2-1.1.i586
      deinstallation of digikam-plugins-7.1.0-1.4.x86_64
      architecture change of libQtAVWidgets1-1.13.0-3.5.x86_64 to libQtAVWidgets1-1.13.0-3.5.i586
      deinstallation of digikam-7.1.0-1.4.x86_64
      deinstallation of showfoto-7.1.0-1.4.x86_64
     Solution 2: keep obsolete libavcodec58_91-4.3.1-4.1.x86_64
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c/d/?] (c): 1
    
    Problem: problem with installed package libavdevice58_10-4.3.1-4.1.x86_64
     Solution 1: Following actions will be done:
      deinstallation of libavdevice58_10-4.3.1-4.1.x86_64
      deinstallation of libQtAV1-1.13.0-3.5.x86_64
      deinstallation of digikam-plugins-7.1.0-1.4.x86_64
      deinstallation of libQtAVWidgets1-1.13.0-3.5.x86_64
      deinstallation of libdigikamcore7-7.1.0-1.4.x86_64
      deinstallation of showfoto-7.1.0-1.4.x86_64
     Solution 2: keep obsolete libavdevice58_10-4.3.1-4.1.x86_64
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c/d/?] (c): 1
    
    Problem: problem with installed package libavfilter7_85-4.3.1-4.1.x86_64
     Solution 1: Following actions will be done:
      deinstallation of libavfilter7_85-4.3.1-4.1.x86_64
      architecture change of ffmpegthumbs-20.08.2-1.1.x86_64 to ffmpegthumbs-20.08.2-1.1.i586
      architecture change of libQtAV1-1.13.0-3.5.x86_64 to libQtAV1-1.13.0-3.5.i586
      deinstallation of libdigikamcore7-7.1.0-1.4.x86_64
      deinstallation of digikam-plugins-7.1.0-1.4.x86_64
      deinstallation of digikam-7.1.0-1.4.x86_64
      architecture change of libQtAVWidgets1-1.13.0-3.5.x86_64 to libQtAVWidgets1-1.13.0-3.5.i586
      deinstallation of showfoto-7.1.0-1.4.x86_64
     Solution 2: keep obsolete libavfilter7_85-4.3.1-4.1.x86_64
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c/d/?] (c): 1
    
    Problem: problem with installed package libavformat58_45-4.3.1-4.1.x86_64
     Solution 1: Following actions will be done:
      install libavformat58_45-4.3.1-8.1.x86_64 (with vendor change)
        openSUSE  -->  http://packman.links2linux.de
      architecture change of libQtAV1-1.13.0-3.5.x86_64 to libQtAV1-1.13.0-3.5.i586
      architecture change of ffmpegthumbs-20.08.2-1.1.x86_64 to ffmpegthumbs-20.08.2-1.1.i586
      deinstallation of digikam-plugins-7.1.0-1.4.x86_64
      architecture change of libQtAVWidgets1-1.13.0-3.5.x86_64 to libQtAVWidgets1-1.13.0-3.5.i586
      deinstallation of digikam-7.1.0-1.4.x86_64
      deinstallation of showfoto-7.1.0-1.4.x86_64
     Solution 2: keep obsolete libavformat58_45-4.3.1-4.1.x86_64
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c/d/?] (c): 1
    ...
    ... # the list continues, always choosing option 1: install with vendor change
    ...
    The following 11 packages are going to be REMOVED:
      digikam digikam-lang digikam-plugins ffmpegthumbs ffmpegthumbs-lang libQtAV1 libQtAVWidgets1 libavdevice58_10 libavfilter7_85 libdigikamcore7 showfoto
    ...
    
    
    It is a compromise solution, I guesss ? packman or digikam/showphoto ?

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    27,325

    Default Re: after upgrading to tumbleed 20201022 I had packman conflicts

    As far as I am aware, Tumbleweed uses --allow-vendor-change by default.
    Code:
    zypper dup --from packman  --allow-vendor-change
    Sorry if that is not the case and that you had to acknowledge all those one by one.

    I assume you are OK now?
    Henk van Velden

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •