Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: Overheating in leap only on boot

  1. #1

    Question Overheating in leap only on boot

    Hello everyone.
    My first post here, so apologies for any errors and deviations from the etiquette.
    I run win 10 and dual booted that with bunch of Linux distros. Recently I decided that leap 15.2 will be my distro of choice and just got a notification about 70 or so updates.after restart all I got was what's on the screenshot https://ibb.co/dpTN6Bq . No idea what happened. Windows works fine and according to windows and soft on windows, all temperatures are fine and there are no hardware issues.
    Not sure if this is relevant, but before installing those updates, I was fighting with Nvidia drivers that I managed to install, eventually, however only my second screen got detected not the primary screen. After unplugging secondary screen, primary screen stayed black with only dash in top left corner. After reboot it was back to normal on a primary screen and at that time I decided to do those updates i.mentioned above.
    Any ideas?

  2. #2
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    746

    Default Re: Overheating in leap only on boot

    Quote Originally Posted by Wazaxib View Post
    Hello everyone.
    My first post here, so apologies for any errors and deviations from the etiquette.
    I run win 10 and dual booted that with bunch of Linux distros. Recently I decided that leap 15.2 will be my distro of choice and just got a notification about 70 or so updates.after restart all I got was what's on the screenshot https://ibb.co/dpTN6Bq . No idea what happened. Windows works fine and according to windows and soft on windows, all temperatures are fine and there are no hardware issues.
    Not sure if this is relevant, but before installing those updates, I was fighting with Nvidia drivers that I managed to install, eventually, however only my second screen got detected not the primary screen. After unplugging secondary screen, primary screen stayed black with only dash in top left corner. After reboot it was back to normal on a primary screen and at that time I decided to do those updates i.mentioned above.
    Any ideas?
    This is normal, You'll get this error message on more or less all machines with all kernel. The fact that it is asking for login may suggest that it failed to boot with XServer. You can log in with your username and try to start X server using the command

    Code:
    startx
    and tell us what the error code is.

  3. #3

    Default Re: Overheating in leap only on boot

    I'll be home in about 2hrs. I'll let you know then. Thank you!

  4. #4

    Default Re: Overheating in leap only on boot

    Quote Originally Posted by Wazaxib View Post
    I'll be home in about 2hrs. I'll let you know then. Thank you!
    I did that and got this: https://ibb.co/jHxKS6K
    I have started my journey with Linus only 2 months ago, and I really hate the fact that I still don't know so much. Please don't mind me

  5. #5
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    746

    Default Re: Overheating in leap only on boot

    Quote Originally Posted by Wazaxib View Post
    I did that and got this: https://ibb.co/jHxKS6K
    I have started my journey with Linus only 2 months ago, and I really hate the fact that I still don't know so much. Please don't mind me
    My guess is that you created an xorg file using nvidia-settings and your computer doesn't like that very much. You can move it to somewhere else temporally to see if that was the issue by typing in the following:
    Code:
    su - #become a super user, type in your password
    mv /etc/X11/xorg.conf.d/$(ls /etc/X11/xorg.conf.d/ |grep -i nvidia) ./
    then reboot.

    If you still cannot start X server please let us know.

  6. #6
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    746

    Default Re: Overheating in leap only on boot

    Just FYI, this is Nvidia driver issue and not overheating issue. Once you can boot up properly with Xserver working, let's try to walk through how you have Nvidia installed. I personally recommend the "easy" way I wrote (you will have to adjust for LEAP 15.2 and if your computer is a Desktop, bumblebee is not needed).

  7. #7

    Default Re: Overheating in leap only on boot

    Quote Originally Posted by SJLPHI View Post
    My guess is that you created an xorg file using nvidia-settings and your computer doesn't like that very much. You can move it to somewhere else temporally to see if that was the issue by typing in the following:
    Code:
    su - #become a super user, type in your password
    mv /etc/X11/xorg.conf.d/$(ls /etc/X11/xorg.conf.d/ |grep -i nvidia) ./
    then reboot.

    If you still cannot start X server please let us know.
    Hi I did as you said and this still got me to the same screen as in the first picture in this thread. No changes.

    I installed it by downloading the file from Nvidia website and then following a guide.kn how to install it from the opensuse website.

    What do I do now?

  8. #8
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    746

    Default Re: Overheating in leap only on boot

    Quote Originally Posted by Wazaxib View Post
    Hi I did as you said and this still got me to the same screen as in the first picture in this thread. No changes.

    I installed it by downloading the file from Nvidia website and then following a guide.kn how to install it from the opensuse website.

    What do I do now?
    Okay, let's step back for a minute. What machine are you using? Desktop/Laptop? CPU, GPU?

    Can you also paste the results of
    Code:
    dmesg |grep -i nvidia

  9. #9

    Default Re: Overheating in leap only on boot

    Thank you for replying back, however I must have messed up with something, as now, linux doesn't show up in the boot menu. I will go with clean isntall then.

    Can I however ask you or your opinion and advice please, as you seem to know your stuff, and when it comes to linux I am still very much a noob.

    I decided to keep small, 150GB partition on primary SSD for Windows for Uni ( I want to eventually move to using windows in a VM inside a linux distro, but I am not going to do so with unstable OS), use remaining space on this 500GP SSD for another distro - ubuntu for now.
    On the second SSD that i have, also 500GB, I want to install opensuse and make it workable - get used it it, get benefits of brtfs file system, and make this distro usable for my final project this year - for this I need installed and working nvidia drivers, as I will need to utilize cuda cores for my machine learning project.

    I know I am asking for a lot, but I would be grateful for any pointers, if detailed response is not practical. On a side note, when I installed ubuntu first, I always had a choice on boot to get into either windows or ubuntu, but since i changed ubuntu for opensuse, I had to use boot settings in bios every time i wanted to access linux, as windows loader didn't recognize it at all.

    Many thanks and thank you for your time
    Greg

  10. #10

    Default Re: Overheating in leap only on boot

    forgot to add the spec as requested: https://ibb.co/d24JMfL and it is a laptop.

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •