Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 29

Thread: Overheating in leap only on boot

  1. #11
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    746

    Default Re: Overheating in leap only on boot

    Quote Originally Posted by Wazaxib View Post
    Thank you for replying back, however I must have messed up with something, as now, linux doesn't show up in the boot menu. I will go with clean isntall then.

    Can I however ask you or your opinion and advice please, as you seem to know your stuff, and when it comes to linux I am still very much a noob.

    I decided to keep small, 150GB partition on primary SSD for Windows for Uni ( I want to eventually move to using windows in a VM inside a linux distro, but I am not going to do so with unstable OS), use remaining space on this 500GP SSD for another distro - ubuntu for now.
    On the second SSD that i have, also 500GB, I want to install opensuse and make it workable - get used it it, get benefits of brtfs file system, and make this distro usable for my final project this year - for this I need installed and working nvidia drivers, as I will need to utilize cuda cores for my machine learning project.

    I know I am asking for a lot, but I would be grateful for any pointers, if detailed response is not practical. On a side note, when I installed ubuntu first, I always had a choice on boot to get into either windows or ubuntu, but since i changed ubuntu for opensuse, I had to use boot settings in bios every time i wanted to access linux, as windows loader didn't recognize it at all.

    Many thanks and thank you for your time
    Greg
    Hi Greg, sure you can ask, but a moderator may ask you start a new thread.

    So some things that I can tell you right now. If you want an easy way to get Cuda+OpenSUSE working properly, you should do the following:
    1. Check if your Windows 10 is EFI or MBR boot.
    2. Download the ISO for OpenSUSE then install it in your flash drive using UNetbootin (https://unetbootin.github.io/).
    3. Load your drive with proper mode (if your W10 is EFI, make sure UNetbootin is set for UEFI only, otherwise MBR/compatible)
    4. Install your OpenSUSE.
    5. Make sure your GPU can handle OpenSUSE's repository Nvidia driver package G05 and install OpenSUSE LEAP 15.2 and follow the instructions that I wrote in (https://forums.opensuse.org/showthre...75#post2957575).

      Just be sure to switch all of the LEAP 15.1s into LEAP 15.2 and skip the "bumblebee" steps from 11. and upwards.

      When Nvidia driver is installed with CUDA, it should have installed G04 Nvidia drivers, you should re-install the Nvidia drivers by invoking forced installation of G05 packages.
    6. Be aware, right now, on LEAP 15.2 and Tumbleweed Nvidia package has been a bit finnicky and may not work after any update.

  2. #12
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    746

    Default Re: Overheating in leap only on boot

    Quote Originally Posted by Wazaxib View Post
    forgot to add the spec as requested: https://ibb.co/d24JMfL and it is a laptop.
    Okay, I cannot confirm but you may be able to/may need to install bumblebee and/or suse-prime. I have no experience in suse-prime yet.

  3. #13

    Default Re: Overheating in leap only on boot

    Quote Originally Posted by SJLPHI View Post
    Hi Greg, sure you can ask, but a moderator may ask you start a new thread.

    So some things that I can tell you right now. If you want an easy way to get Cuda+OpenSUSE working properly, you should do the following:
    1. Check if your Windows 10 is EFI or MBR boot.
    2. Download the ISO for OpenSUSE then install it in your flash drive using UNetbootin (https://unetbootin.github.io/).
    3. Load your drive with proper mode (if your W10 is EFI, make sure UNetbootin is set for UEFI only, otherwise MBR/compatible)
    4. Install your OpenSUSE.
    5. Make sure your GPU can handle OpenSUSE's repository Nvidia driver package G05 and install OpenSUSE LEAP 15.2 and follow the instructions that I wrote in (https://forums.opensuse.org/showthre...75#post2957575).

      Just be sure to switch all of the LEAP 15.1s into LEAP 15.2 and skip the "bumblebee" steps from 11. and upwards.

      When Nvidia driver is installed with CUDA, it should have installed G04 Nvidia drivers, you should re-install the Nvidia drivers by invoking forced installation of G05 packages.
    6. Be aware, right now, on LEAP 15.2 and Tumbleweed Nvidia package has been a bit finnicky and may not work after any update.
    Its EFI and I have initially installed opensuse the way you advised.
    Would it be better then perhaps to stick to 15.1 instead of 15.2? would that be easier to set up for a beginner like myself?

    I will look into bumblebee and that other software you mentioned.

    Does it matter what order I install those distros? or just windows has to be installed first?

    And how should i properly partition drives in the linux way? I am just using what I kind of am used to from windows and perhaps that's why I am missing unified boot option for windows and linux?

    thank you!

  4. #14
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    746

    Default Re: Overheating in leap only on boot

    Quote Originally Posted by Wazaxib View Post
    Its EFI and I have initially installed opensuse the way you advised.
    Would it be better then perhaps to stick to 15.1 instead of 15.2? would that be easier to set up for a beginner like myself?

    I will look into bumblebee and that other software you mentioned.

    Does it matter what order I install those distros? or just windows has to be installed first?

    And how should i properly partition drives in the linux way? I am just using what I kind of am used to from windows and perhaps that's why I am missing unified boot option for windows and linux?

    thank you!
    Honestly, think of LEAP 15.1 as a well oiled machine that no one makes parts for anymore. When it goes out of support, if anything goes wrong, you're on your own. LEAP 15.2 right now is lacking the stability of LEAP 15.1 but it is supported and will be supported for a while longer, so you'll get more help from the community. I'd say go for 15.2 if you want to get help.

    If you are new on linux, it's easier to install Windows first.

    For me, I only have 3 partitions for my linux.
    1. /boot/efi
    2. /
    3. /home

    Many people do it differently but I always create linux's own /boot/efi (ESP) partition. Some people use the same /boot/efi partition that Windows 10 creates.

  5. #15

    Default Re: Overheating in leap only on boot

    Quote Originally Posted by SJLPHI View Post
    Honestly, think of LEAP 15.1 as a well oiled machine that no one makes parts for anymore. When it goes out of support, if anything goes wrong, you're on your own. LEAP 15.2 right now is lacking the stability of LEAP 15.1 but it is supported and will be supported for a while longer, so you'll get more help from the community. I'd say go for 15.2 if you want to get help.

    If you are new on linux, it's easier to install Windows first.

    For me, I only have 3 partitions for my linux.
    1. /boot/efi
    2. /
    3. /home

    Many people do it differently but I always create linux's own /boot/efi (ESP) partition. Some people use the same /boot/efi partition that Windows 10 creates.
    15.2 it is then.

    care to explain why you have /home separate to / and how and where to set up boot/efi?

  6. #16
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,003

    Default Re: Overheating in leap only on boot

    IN advanced option in the installer you can set things the way you wish.

    Home contains all your personal data/files. Having home on a separate partition allows more flexibility if you decide to change destros or if all is on the same partition when you foramt that partition for a new OS it wipes home directory. If on a different partition you can preserve home and install a new OS with out disturbing your data.

    I don't care for the new trend to default home to the root partition

  7. #17

    Default Re: Overheating in leap only on boot

    Didn't think of it this way. Good one!
    What about boot? How to set it up so that when I boot I can actually choose between windows and different distros on the machine?

  8. #18
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,003

    Default Re: Overheating in leap only on boot

    Will if Windows fast boot is off it should just show up. Fast boot leaves the Windows partition in a unusable (by other OS) state thus Linux can't boot it. But as long as Linux can see the Windows partition then it should just work with an option in grub to boot Windows.

    Note if Windows does not show up it can be fixed after the install

  9. #19

    Default Re: Overheating in leap only on boot

    No way! So it's all about fast boot option in bios? ****, you do learn every day. Thank you so much for all your wisdome. Tomorrow evening I will try to reinstall windows on a small partition and two other distros and see how it goes.

    Thank you again!

  10. #20
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,003

    Default Re: Overheating in leap only on boot

    No that should be off also it is the fast boot option in Windows. It defaults on and essentially does some form of hibernation instead of a clean shut down in any case it messes up mounting the Windows partition's in other OS

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •