Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Wireless scan OK/unable to connect

  1. #1
    Join Date
    Oct 2008
    Location
    Texas
    Posts
    89

    Default Wireless scan OK/unable to connect

    HP Pavilion laptop dual boot setup with Windows 10 (Win fast startup and UEFI secure boot disabled).
    Internal Realtek B/G/N wireless which is currently configured and working okay.
    It is limited to 802.11n@2.4 Ghz at best. The laptop is connected to an AVR/TV path so I need to have the laptop lid closed normally. For these two reasons I am trying to get an external USB TP-Link AC 600/Archer T2 Nano wireless connection working.

    I am using the Wicked network manager and currently have both wireless configured until I can get the TP-Link fully functional. After doing some reading on this forum and other locations I did the following:
    Removed and marked the original RTL8812au driver packages taboo.
    Installed recommended drivers from https://download.opensuse.org/reposi...p_15.2_Update/ repository. I installed rtl8812AU_8821AU-kmp-default and rtl8812AU_8821AU-kmp-preempt only.
    Set wpa_supplicant in YaST Services interface to start at boot.

    When I access YaST Network Services/wlan1 (TP-Link) I am able to scan for networks without issue, but it continues to show "Not Connected". I have compared configuration with wlan0 (Realtek internal wireless) and they are similar.

    lsusb output shows no description for the TP-Link:
    Code:
    fuscop@Media:~> lsusb
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 007: ID 0bda:b008 Realtek Semiconductor Corp. 
    Bus 001 Device 005: ID 2357:011e  
    Bus 001 Device 003: ID 04f2:b56d Chicony Electronics Co., Ltd 
    Bus 001 Device 006: ID 046d:c52b Logitech, Inc. Unifying Receiver
    Bus 001 Device 004: ID 22b8:2e62 Motorola PCS 
    Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    YaST Systemd Journal shows a normal connection sequence for wlan0. but only four lines for wlan1. I tried to insert a small screenshot here but apparently that doesn't work or I didn't find the proper method.

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,902

    Default AW: Wireless scan OK/unable to connect

    Post:
    Code:
    zypper lr -d
    Code:
    zypper se -si kernel rtl8812
    Code:
    uname -a

  3. #3
    Join Date
    Oct 2008
    Location
    Texas
    Posts
    89

    Default Re: AW: Wireless scan OK/unable to connect

    Quote Originally Posted by Sauerland View Post
    Post:
    Code:
    zypper lr -d
    Code:
    zypper se -si kernel rtl8812
    Code:
    uname -a
    Sorry, but I can't currently even complete the process to load a desktop session.

    This is my second attempt at getting this particular configuration to work and it has imploded both times after hibernation. I have no issues with completing the dual-boot setup/partitioning/other steps to run Leap 15.2 alongside Win 10 Home. It is once I'm working in the KDE Plasma environment that I seem to experience problems. To make this explanation as short as possible: I've had some issues with busy/race conditions during operation (best guess, I hear increased fan speed and highly delayed keyboard/mouse response), as well as attempt to enter Sleep mode dumping me back to login screen. While I can hibernate the system, it has resulted in a system that fails to successfully resume completely from any grub menu choice (normal, recovery, snapshot) other than the Windows entry. Any other choice eventually leaves me at a command prompt for username, then password, after which it informs me it timed out.

    This configuration (laptop with HDMI to AVR to TV, Logitech USB unifying keyboard and mouse, external USB wireless) works flawlessly with Win 10 home. So I know the hardware itself is not the issue.

    I'm willing to work a bit more to get this to work, but I'm also considering trying something Debian based to see if it is more compatible with this configuration. If not, Win 10 is still there and completely usable. I just like KDE more.

  4. #4
    Join Date
    Oct 2008
    Location
    Texas
    Posts
    89

    Default Re: AW: Wireless scan OK/unable to connect

    Quote Originally Posted by Sauerland View Post
    Post:
    Code:
    zypper lr -d
    Code:
    zypper se -si kernel rtl8812
    Code:
    uname -a
    I'm running a live USB using Gecko Linux with KDE desktop. Since it runs persistently I have been able to approximate the same conditions, and this is on the same hardware and configuration as before. When I loaded your repository this time I installed all the automatically selected items. I'm still experiencing issues with the TP-Link USB wireless and the output of lsusb still shows no description for the TP-Link. I can see it in Network Manager and in the YaST Network Settings but it still doesn't want to connect.

    Code:
    linux@MediaWin:~> zypper lr -d
    # | Alias                     | Name                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                   | Service
    --+---------------------------+-----------------------------+---------+-----------+---------+----------+--------+---------------------------------------------------------------------------------------+--------
    1 | Google-chrome             | Google-chrome               | Yes     | (r ) Yes  | Yes     |    7     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                                   | 
    2 | openSUSE_Leap_15.2        | Firefox                     | Yes     | (r ) Yes  | Yes     |    6     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.2/                 | 
    3 | openSUSE_Leap_15.2_Update | TP-Link                     | Yes     | (r ) Yes  | Yes     |    8     | rpm-md | https://download.opensuse.org/repositories/home:/Sauerland/openSUSE_Leap_15.2_Update/ | 
    4 | packman.inode.at-suse     | Packman Repository          | Yes     | (r ) Yes  | Yes     |    1     | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_15.2/                                      | 
    5 | repo-non-oss              | Non-OSS Repository          | Yes     | (r ) Yes  | No      |    5     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/non-oss/                     | 
    6 | repo-oss                  | Main Repository             | Yes     | (r ) Yes  | No      |    4     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/oss/                         | 
    7 | repo-update               | Main Update Repository      | Yes     | (r ) Yes  | Yes     |    2     | rpm-md | http://download.opensuse.org/update/leap/15.2/oss                                     | 
    8 | repo-update-non-oss       | Update Repository (Non-Oss) | Yes     | (r ) Yes  | Yes     |    3     | rpm-md | http://download.opensuse.org/update/leap/15.2/non-oss/                                |
    Code:
    linux@MediaWin:~> zypper se -si kernel rtl8812
    Loading repository data...
    Reading installed packages...
    
    S  | Name                         | Type    | Version                             | Arch   | Repository
    ---+------------------------------+---------+-------------------------------------+--------+-----------------------
    i+ | kernel-default               | package | 5.3.18-lp152.33.1                   | x86_64 | Main Update Repository
    i+ | kernel-firmware              | package | 20200107-lp152.1.1                  | noarch | Main Repository
    i  | kernel-preempt               | package | 5.3.18-lp152.36.1                   | x86_64 | Main Update Repository
    i  | purge-kernels-service        | package | 0-lp152.4.1                         | noarch | Main Repository
    i+ | rtl8812AU_8821AU-kmp-default | package | 20200719_k5.3.18_lp152.36-lp152.5.1 | x86_64 | TP-Link
    i+ | rtl8812AU_8821AU-kmp-preempt | package | 20200719_k5.3.18_lp152.36-lp152.5.1 | x86_64 | TP-Link
    Code:
    linux@MediaWin:~> uname -a
    Linux MediaWin.attlocal.net 5.3.18-lp152.33-default #1 SMP Wed Jul 22 06:32:33 UTC 2020 (e5a8383) x86_64 x86_64 x86_64 GNU/Linux
    linux@MediaWin:~>

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,902

    Default AW: Wireless scan OK/unable to connect

    Update your kernel, the installed driver is build against the last kernel from update Repo.

  6. #6
    Join Date
    Oct 2008
    Location
    Texas
    Posts
    89

    Default Re: AW: Wireless scan OK/unable to connect

    Quote Originally Posted by Sauerland View Post
    Update your kernel, the installed driver is build against the last kernel from update Repo.
    After working with the Gecko Linux live for some time unsuccessfully. I was ready to compose this answer. Before I did that, I decided to take another look at the Leap 15.2 dual boot on the laptop for which I originally opened the issue. I logged in at run level three and figured out that "/" was out of space. After grimacing that I hadn't considered that I took a look at /var/log and found two extremely large old logs. One was mesg(date) and the other was warn(date). I deleted them and rebooted.

    Once I got back to a normal session I rearranged my repositories to make your repository top priority. I then correctly installed the two rtl8812 packages needed. Afterward I ran mkinitrd as root and it seemed to complete okay. I then rebooted.

    I initially had some issues with the internal wireless not connecting so I plugged in a 100 Mbps Ethernet cable. I had left the system using Wicked so I messed with that first but had no luck. I went back to Network Manager, configured a wlan0 entry to the 2.4 Ghz BSSID for the B/G/N internal, and a wlan1 entry for the AC external to the 5.0 Ghz BSSID, also setting the device restriction on both appropriately. Both have their password set to "Store password for all users (not encrypted).

    Current status:
    wlan0 connects successfully.
    wlan1 hangs at configuring interface, prompts twice for authentication and then fails with the "No secrets were provided" message, after which it deactivates. Apparently this is a common issue but not really a definitive solution I could find. I didn't want to guess so I'll see what you think and what information you need. Thanks for your help.

  7. #7
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,902

    Default AW: Wireless scan OK/unable to connect

    What is wlan0 and wlan1?

    Post:
    Code:
    /usr/sbin/hwinfo --wlan
    Code:
    ip a

  8. #8
    Join Date
    Oct 2008
    Location
    Texas
    Posts
    89

    Default Re: AW: Wireless scan OK/unable to connect

    Quote Originally Posted by Sauerland View Post
    What is wlan0 and wlan1?

    Post:
    Code:
    /usr/sbin/hwinfo --wlan
    Code:
    ip a
    Requested output:
    I'm continuing to experience issues with very large "mesg" and "warn" log filling up drive. Tail on both show something related to kernel and PCI, I need to look at further. It does indicate to me that the hibernate/sleep issues were probably caused by full disk condition. Can also confirm that this issue was occurring prior to installing the two packages from your repository, running mkinitrd and rebooting.

  9. #9
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,777
    Blog Entries
    2

    Default Re: AW: Wireless scan OK/unable to connect

    Quote Originally Posted by fuscop View Post
    After working with the Gecko Linux live for some time unsuccessfully. I was ready to compose this answer. Before I did that, I decided to take another look at the Leap 15.2 dual boot on the laptop for which I originally opened the issue. I logged in at run level three and figured out that "/" was out of space. After grimacing that I hadn't considered that I took a look at /var/log and found two extremely large old logs. One was mesg(date) and the other was warn(date). I deleted them and rebooted.

    Once I got back to a normal session I rearranged my repositories to make your repository top priority. I then correctly installed the two rtl8812 packages needed. Afterward I ran mkinitrd as root and it seemed to complete okay. I then rebooted.

    I initially had some issues with the internal wireless not connecting so I plugged in a 100 Mbps Ethernet cable. I had left the system using Wicked so I messed with that first but had no luck. I went back to Network Manager, configured a wlan0 entry to the 2.4 Ghz BSSID for the B/G/N internal, and a wlan1 entry for the AC external to the 5.0 Ghz BSSID, also setting the device restriction on both appropriately. Both have their password set to "Store password for all users (not encrypted).

    Current status:
    wlan0 connects successfully.
    wlan1 hangs at configuring interface, prompts twice for authentication and then fails with the "No secrets were provided" message, after which it deactivates. Apparently this is a common issue but not really a definitive solution I could find. I didn't want to guess so I'll see what you think and what information you need. Thanks for your help.
    You wouldn't want both wlan0 and wlan1 actively connected anyway.
    This is a common networking mistake to configure two active network interfaces, both with Default Gateways... You should have only one Default Gateway and any other number of ordinary router gateways that point to other networkd but none that can be found through the Default Gateway. The reason for this TCP/IP is a 2-way protocol, and the response must return through the same router path and with two gateways that isn't assured resulting in numerous packet failures.
    You can have multiple network interfaces configured, each with its own default gateway but in this case interface must be inactive except for one.

    There is an exception to the above if you configure Advanced TCP/IP to do things like bonding, but that's another topic that doesn't apply here.

    Bottom line seems to be that Wicked is protecting you from yourself.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  10. #10
    Join Date
    Oct 2008
    Location
    Texas
    Posts
    89

    Default Re: AW: Wireless scan OK/unable to connect

    Quote Originally Posted by tsu2 View Post
    You wouldn't want both wlan0 and wlan1 actively connected anyway.
    This is a common networking mistake to configure two active network interfaces, both with Default Gateways... You should have only one Default Gateway and any other number of ordinary router gateways that point to other networkd but none that can be found through the Default Gateway. The reason for this TCP/IP is a 2-way protocol, and the response must return through the same router path and with two gateways that isn't assured resulting in numerous packet failures.
    You can have multiple network interfaces configured, each with its own default gateway but in this case interface must be inactive except for one.

    There is an exception to the above if you configure Advanced TCP/IP to do things like bonding, but that's another topic that doesn't apply here.

    Bottom line seems to be that Wicked is protecting you from yourself.

    TSU
    The current configuration I described is configured through Network Manager and is two separate entries that both originally were named to the default SSID. I changed their naming to wlan0 and wlan1 for clarity. Both use DHCP and both are set not to auto-start. So they will never be running, or attempting to run together. The ethernet connection is currently active always, and I have connected wlan0 concurrently without apparent issue.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •