Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: Wireless scan OK/unable to connect

  1. #11
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,999

    Default AW: Wireless scan OK/unable to connect

    Code:
    The ethernet connection is currently active always
    deactivate it by plug off the cable......

    And also deactivate the other Wlan by :
    Code:
    sudo modprobe -r rtl8723be
    Restart network:
    Code:
    sudo systemctl restart network.service
    Does the other works now?

    Is the firmware for rtl8723be installed:
    Code:
    ls -al /lib/firmware/rtlwifi/ | grep 8723be

  2. #12
    Join Date
    Oct 2008
    Location
    Texas
    Posts
    89

    Default Re: AW: Wireless scan OK/unable to connect

    Quote Originally Posted by Sauerland View Post
    Code:
    The ethernet connection is currently active always
    deactivate it by plug off the cable......

    And also deactivate the other Wlan by :
    Code:
    sudo modprobe -r rtl8723be
    Restart network:
    Code:
    sudo systemctl restart network.service
    Does the other works now?

    Is the firmware for rtl8723be installed:
    Code:
    ls -al /lib/firmware/rtlwifi/ | grep 8723be
    Ethernet cable disconnected.
    Deactivated wlan0 internal.
    Restarted network.
    No change for wlan1 USB on either 2.4 Ghz or 5.0 Ghz attempt to connect, same prompts and "No secrets" result.


    Firmware for rtl8723be installed?
    Code:
    fuscop@Media:/var/log> sudo ls -al /lib/firmware/rtlwifi|grep 8723be
    [sudo] password for root: 
    -rw-r--r-- 1 root root  31762 Mar  1 01:55 rtl8723befw_36.bin
    -rw-r--r-- 1 root root  30746 Mar  1 01:55 rtl8723befw.bin
    Also looked at messages and warn logs that had already grown to 8 GB and 6.1 GB, believe I found the culprit for repeated entries. This is related to internal wireless:
    Code:
    2020-08-29T08:27:42.331796-05:00 Media kernel: [   38.351810] pcieport 0000:00:1d.0: AER: Corrected error received: 0000:00:1d.0
    2020-08-29T08:27:42.331797-05:00 Media kernel: [   38.351813] pcieport 0000:00:1d.0: AER: PCIe Bus Error: severity=Corrected, type=Physical Layer, (Receiver ID)
    2020-08-29T08:27:42.331797-05:00 Media kernel: [   38.351814] pcieport 0000:00:1d.0: AER:   device [8086:9d1b] error status/mask=00000001/00002000
    2020-08-29T08:27:42.331798-05:00 Media kernel: [   38.351815] pcieport 0000:00:1d.0: AER:    [ 0] RxErr
    I left those logs for now. Since wlan0 internal is deactivated I don't expect them to grow. As mentioned, wlan0 does connect okay but something is obviously wrong. I don't believe I've used it today and those entries are from today.

  3. #13
    Join Date
    Oct 2008
    Location
    Texas
    Posts
    89

    Default Re: Wireless scan OK/unable to connect

    Also looked at messages and warn logs that had already grown to 8 GB and 6.1 GB, believe I found the culprit for repeated entries. This is related to internal wireless:

    Code:
    2020-08-29T08:27:42.331796-05:00 Media kernel: [   38.351810] pcieport 0000:00:1d.0: AER: Corrected error received: 0000:00:1d.0
    2020-08-29T08:27:42.331797-05:00 Media kernel: [   38.351813] pcieport 0000:00:1d.0: AER: PCIe Bus Error: severity=Corrected, type=Physical Layer, (Receiver ID)
    2020-08-29T08:27:42.331797-05:00 Media kernel: [   38.351814] pcieport 0000:00:1d.0: AER:   device [8086:9d1b] error status/mask=00000001/00002000
    2020-08-29T08:27:42.331798-05:00 Media kernel: [   38.351815] pcieport 0000:00:1d.0: AER:    [ 0] RxErr
    It appears that if I do want the internal wireless available in the future I may need to add "pcie_aspm=off" to my bootloader options. That seems preferable to pci=nomsi or pci=noaer.
    Also raises a question in my mind about any similar suspend/sleep conditions for USB since I plan on having a shared drive connected to USB 3.0 port at some point. That's a future concern though.

  4. #14
    Join Date
    Oct 2008
    Location
    Texas
    Posts
    89

    Default Re: Wireless scan OK/unable to connect

    Tried connecting via nmcli command but no difference, other than not receiving any prompts before failure. Seems to confirm those Network Manager GUI prompts are bogus.
    Code:
    Media:/etc/NetworkManager # nmcli dev wifi connect "My SSID" password "My SSID password"
    Error: Connection activation failed: (7) Secrets were required, but not provided.
    Tried adding the following but it didn't change anything.
    Code:
    $ tail -2 /etc/NetworkManager/NetworkManager.conf
    [device] 
    wifi.scan-rand-mac-address=no
    Went ahead and removed it.

    Continuing to research online as time permits.

  5. #15
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,856
    Blog Entries
    2

    Default Re: AW: Wireless scan OK/unable to connect

    Quote Originally Posted by fuscop View Post
    The current configuration I described is configured through Network Manager and is two separate entries that both originally were named to the default SSID. I changed their naming to wlan0 and wlan1 for clarity. Both use DHCP and both are set not to auto-start. So they will never be running, or attempting to run together. The ethernet connection is currently active always, and I have connected wlan0 concurrently without apparent issue.
    I always configure each radio with a different SSID... eg WIFI1 for 2.4ghz and WIFI2 for 5.6mhz.
    Same reason as before although slightly different situation... It's important to uniquely identify different networks.
    Of course that also means that you will configure a different network connection to each SSID.

    If that is what you are already doing, my apologies but I think you're describing something different.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  6. #16
    Join Date
    Oct 2008
    Location
    Texas
    Posts
    89

    Default Re: AW: Wireless scan OK/unable to connect

    Quote Originally Posted by tsu2 View Post
    I always configure each radio with a different SSID... eg WIFI1 for 2.4ghz and WIFI2 for 5.6mhz.
    Same reason as before although slightly different situation... It's important to uniquely identify different networks.
    Of course that also means that you will configure a different network connection to each SSID.

    If that is what you are already doing, my apologies but I think you're describing something different.

    TSU
    Not sure if you're referring to the router/gateway host or the laptop/wireless so I'll address both.

    Regarding the laptop, I removed the existing wireless entries from Network Manager interface, leaving the default one from scan that is named for the SSID. I then configured it explicitly in regard to BSSID to connect to the 5.0 network on my router/gateway, as well as setting the restriction to limit this connection to wlan1 (even though wlan0 module was removed on an earlier step recommended by Sauerland). Meaning that wlan1 was the only choice for the latter step.

    I rebooted the router/gateway earlier. And while it does use the same SSID for both 2.4 and 5.0 networks, I have other devices (tablets, computers, A/C system) which use one or the other of the networks and connect fine. And, in fact, the laptop in question is dual boot and the Windows 10 OS connects via the external USB without issue. Which leaves me with some issue within this Linux OS as the cause.

  7. #17
    Join Date
    Oct 2008
    Location
    Texas
    Posts
    89

    Default Re: Wireless scan OK/unable to connect

    I tested wireless connectivity on a 2011 Mac Mini I previously setup with Leap 15.2 as single OS. It has a Broadcom chip and once I switched from Wicked to Network Manager and configured the connection it connected successfully.

    I gave more thought to the last suggestion from tsu2 to label each of the connections and realized that it would not only be a good troubleshooting step, but also would simplify verifying my current and future connections. I also noticed yesterday while looking at the Network Manager log that besides the connection failures there were instances of trying to assign a new MAC address and failing. I'm going to follow the suggestion and give each of my router/gateway wireless SSID distinct names.

  8. #18
    Join Date
    Oct 2008
    Location
    Texas
    Posts
    89

    Default Re: Wireless scan OK/unable to connect

    Router/Gateway now has wireless renamed with "_2.4" and "_5.x" suffixes. All previous devices were able to connect appropriately dependent on their capability/signal strength.

    The Mac Mini running Leap 15.2 with Broadcom A/B/G/N capability was able to connect to either band without issue.

    The laptop being troubleshooted was able to see both bands but connect to neither, with the same two prompts for passwords, followed by "No secrets were provided" disconnection. Starting to wonder if it is even communicating with the router/gateway.

  9. #19
    Join Date
    Oct 2008
    Location
    Texas
    Posts
    89

    Default Re: Wireless scan OK/unable to connect

    Quote Originally Posted by fuscop View Post
    Router/Gateway now has wireless renamed with "_2.4" and "_5.x" suffixes. All previous devices were able to connect appropriately dependent on their capability/signal strength.

    The Mac Mini running Leap 15.2 with Broadcom A/B/G/N capability was able to connect to either band without issue.

    The laptop being troubleshooted was able to see both bands but connect to neither, with the same two prompts for passwords, followed by "No secrets were provided" disconnection. Starting to wonder if it is even communicating with the router/gateway.
    Final step was removing drivers completely, verifying and then rebooting. I then reinstalled the drivers, "sudo modprobe rtl8812au" and verified. Rebooted.
    Still not seeing device identified in lsusb and it still fails to complete configuration and connect to router/gateway. If I am missing something I don't know what it is.
    Code:
    fuscop@Media:~> lsmod | grep rtl8812au
    rtl8812au            1490944  0
    cfg80211              835584  3 rtl8812au,rtlwifi,mac80211
    usbcore               311296  6 rtl8812au,xhci_hcd,usbhid,uvcvideo,btusb,xhci_pci
    fuscop@Media:~> lsusb
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 005: ID 0bda:b008 Realtek Semiconductor Corp. 
    Bus 001 Device 004: ID 2357:011e  
    Bus 001 Device 003: ID 04f2:b56d Chicony Electronics Co., Ltd 
    Bus 001 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    fuscop@Media:~>
    So I'll get along with the 100 Mbps Powerline Ethernet on the Linux side, and if I need to download files I'll do it in Windows and then move them while in Linux.

  10. #20
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,999

    Default AW: Wireless scan OK/unable to connect

    Post as root:
    Code:
    journalctl -b | grep -Ei 'net|rtl|wlan|firmware'

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •