Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Nach umount Gerät im System nicht mehr auffindbar?

  1. #1

    Default Nach umount Gerät im System nicht mehr auffindbar?

    Hallo,

    ich verstehe vielleicht noch nicht ganz wie die Befehle mount und umount funktionieren.

    Nach mount eines Wechseldatenträgers /dev/sdi unter /mnt und anschließendem umount ist der Wechseldatenträger gar nicht mehr im System zu finden. Ich könnte also den Wechseldatenträger nicht noch einmal vielleicht an anderer Stelle mounten?
    Umount hängt doch nur das Gerät aus den Mountpoint aus, aber müsste doch noch im System unter :
    Code:
    blkid -o list  
    zu sehen sein?
    -
    Gruß, su_lin_user1

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,870

    Default AW: Nach umount Gerät im System nicht mehr auffindbar?

    Du mountest auch eine Partition sda1 und nicht die Festplatte sda........

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    27,116

    Default Re: Nach umount Gerät im System nicht mehr auffindbar?

    Eigentlich ist den Ausdruck "Gerät mounten" ganz falsch.

    Ein Dateisystem wird "gemounted", das heiẞt das den Verzeichnis/Datei Baum an einer bestimmte Stelle inerhalb der schon anwesende Baum verfügbar ist.

    Weil man beim mounten angeben muẞ wo sich das Dateisystem befindet, benutzt man dazu das Volume (englisch) worauf es gespeichert ist. Oft ein Partition. Kann aber auch ein ganze Festplatte sein. Oder noch andere Sachen wie LVM Volumen, usw.

    In jedem Fall ist es merkwürdig wenn das System nach umount das nicht mehr finden kann. Andeeseits hat @su_lin_user1 eigentlich nicts gezeigt.

    Also, erst mal
    Code:
    lsblk
    Dan den komplette Zyclus:
    Code:
    mount ..........
    umount ....
    lsblk
    so das wir auch wirklich sehen können was passiert.
    Henk van Velden

  4. #4

    Default Re: Nach umount Gerät im System nicht mehr auffindbar?

    Hallo,

    @hcvv:
    In jedem Fall ist es merkwürdig wenn das System nach umount das nicht mehr finden kann. Andeeseits hat @su_lin_user1 eigentlich nicts gezeigt.
    Ja, entschuldigt, dass ich nicht gleich was gezeigt habe. Ich hole das jetzt gleich nach, um verständlich zu machen was genau ich angesprochen habe.

    Ich habe den MP3 Player "Sansa Clip" per USB am PC angesteckt. Der Sansa Clip hat eine eingebaute 8GiB SD Karte und einen Slot für eine microSD, in welchem eine 64GiB microSD steckt.
    Ich habe den Sansa Clip angesteckt und danach eine Konsole geöffnet und mich als root angemeldet. Die microSD mit 64GiB wird als sdi angezeigt. Die microSD ist noch nicht gemountet, aber schon als /dev/sdi am PC zu finden.

    Code:
    # blkid -o list -w /dev/null
    device                                                       fs_type         label            mount point                                                      UUID
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    /dev/sda1                                                            vfat              BOOT               (not mounted)                                                            4402-9DE3
    /dev/sda3                                                            ntfs                                 (not mounted)                                                            065A48FE5A48EC4D
    /dev/sda4                                                            ntfs              Speicher_Reserve   (not mounted)                                                            72D28812D287D92D
    /dev/sda5                                                            vfat              BOOT_EFI           /boot/efi                                                                6324-DD15
    /dev/sda6                                                            swap              Swap               [SWAP]                                                                   6207ec2a-0775-48f5-a316-2d57c5145d29
    /dev/sda7                                                            ext4              Suse_Leap          /                                                                        55732048-b266-495d-8ea6-ea67eb6a1d19
    /dev/sdb1                                                            ntfs              Win10_Daten        (not mounted)                                                            54A556646FCA122B
    /dev/sdb2                                                            ext4              Suse_Daten         /home                                                                    af750ff7-9ced-4dee-b5c8-41a45769f1a0
    /dev/sdh                                                             vfat              SANSA CLIPP        (not mounted)                                                            78DE-786F
    /dev/sda2                                                                                                 (not mounted)                                                            
    /dev/sdi                                                             vfat                                 (not mounted)                                                            D020-FB7E
    Jetzt mounte ich /dev/sdi an /mnt.
    Code:
    # mount /dev/sdi /mnt
    Das Ergebnis:
    Code:
    # blkid -o list -w /dev/null
    device                                                       fs_type         label            mount point                                                      UUID
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    /dev/sda1                                                            vfat              BOOT               (not mounted)                                                            4402-9DE3
    /dev/sda3                                                            ntfs                                 (not mounted)                                                            065A48FE5A48EC4D
    /dev/sda4                                                            ntfs              Speicher_Reserve   (not mounted)                                                            72D28812D287D92D
    /dev/sda5                                                            vfat              BOOT_EFI           /boot/efi                                                                6324-DD15
    /dev/sda6                                                            swap              Swap               [SWAP]                                                                   6207ec2a-0775-48f5-a316-2d57c5145d29
    /dev/sda7                                                            ext4              Suse_Leap          /                                                                        55732048-b266-495d-8ea6-ea67eb6a1d19
    /dev/sdb1                                                            ntfs              Win10_Daten        (not mounted)                                                            54A556646FCA122B
    /dev/sdb2                                                            ext4              Suse_Daten         /home                                                                    af750ff7-9ced-4dee-b5c8-41a45769f1a0
    /dev/sdh                                                             vfat              SANSA CLIPP        (not mounted)                                                            78DE-786F
    /dev/sdi                                                             vfat                                 /mnt                                                                     D020-FB7E
    /dev/sda2                                                                                                 (not mounted)
    Die microSD wird jetzt als gemounted unter /mnt angezeigt.

    Jetzt hänge ich die microSD wieder aus.
    Code:
    # umount /dev/sdi /mnt
    umount: /mnt: nicht eingehängt.
    Code:
    # blkid -o list -w /dev/null
    device                                                       fs_type         label            mount point                                                      UUID
    ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    /dev/sda1                                                            vfat              BOOT               (not mounted)                                                            4402-9DE3
    /dev/sda3                                                            ntfs                                 (not mounted)                                                            065A48FE5A48EC4D
    /dev/sda4                                                            ntfs              Speicher_Reserve   (not mounted)                                                            72D28812D287D92D
    /dev/sda5                                                            vfat              BOOT_EFI           /boot/efi                                                                6324-DD15
    /dev/sda6                                                            swap              Swap               [SWAP]                                                                   6207ec2a-0775-48f5-a316-2d57c5145d29
    /dev/sda7                                                            ext4              Suse_Leap          /                                                                        55732048-b266-495d-8ea6-ea67eb6a1d19
    /dev/sdb1                                                            ntfs              Win10_Daten        (not mounted)                                                            54A556646FCA122B
    /dev/sdb2                                                            ext4              Suse_Daten         /home                                                                    af750ff7-9ced-4dee-b5c8-41a45769f1a0
    /dev/sdh                                                             vfat              SANSA CLIPP        (not mounted)                                                            78DE-786F
    /dev/sdi                                                             vfat                                 (not mounted)                                                            D020-FB7E
    /dev/sda2                                                                                                 (not mounted)
    Ergebnis ist, dass /dev/sdi jetzt wieder "not mounted" angezeigt wird. Genau so würde ich es mir auch erwarten.
    Es ist schon öfters vorgekommen, dass nach dem umount /dev/sdi hier nicht mehr zu sehen war. Ich musste deshalb den Sansa Clip abziehen und wieder neu anstecken und manchmal sogar 2-3 Mal nach einander und dazu Dolphin und Konsole schließen , bis ich /dev/sdi wieder angezeigt bekam.

    Es kann sein, dass sich das nicht verträgt, wenn Konsole und Dolphin zusammen geöffnet sind. Jetzt hat mein Beispiel ohne Probleme funktioniert, da ich nur die Konsole geöffnet hatte.(?!)

    Edit:
    Zur Ergänzung (Der Befehl ist neu für mich. Gefällt mir sehr gut)
    Code:
    # lsblk 
    NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
    sda      8:0    0 232,9G  0 disk 
    ├─sda1   8:1    0   1,5G  0 part 
    ├─sda2   8:2    0     2G  0 part 
    ├─sda3   8:3    0  48,3G  0 part 
    ├─sda4   8:4    0     2G  0 part 
    ├─sda5   8:5    0   560M  0 part /boot/efi
    ├─sda6   8:6    0     8G  0 part [SWAP]
    └─sda7   8:7    0    50G  0 part /
    sdb      8:16   0   1,8T  0 disk 
    ├─sdb1   8:17   0 886,5G  0 part 
    └─sdb2   8:18   0 976,6G  0 part /home
    sdh      8:112  1   7,4G  0 disk 
    sdi      8:128  1  59,5G  0 disk 
    sr0     11:0    1 535,1M  0 rom
    -
    Gruß, su_lin_user1

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    27,116

    Default Re: Nach umount Gerät im System nicht mehr auffindbar?

    Code:
    umount /dev/sdi /mnt
    ist Falsch. Wenn es Fehlermeldungen gibt sollte man die nicht ignorieren.

    Lese mal
    Code:
    man umount
    Besser wäre
    Code:
    umount /mnt
    Übrigens kannst du die Zwischenbemerkungen herauslassen. Einfach das Ganze copy/paste. Wir verstehen schon das es von oben nach unten in der Zeit geht.

    Ich habe auch nicht nach blkid gefragt.

    Also das gezeigte zeigt was es zeigen soll. Damit können wir weiter nicht viel anfangen. Alles in Ordnung!

    Und mit Dolphin. Es könnte sein das der Benutzer mit Dolphin noch immer da "drin" ist. Dann kann das umount natürlich nicht stattfinden. Dann gibt es auch ein Fehlermeldung. Die du dann mölicherweise ignorierst wie schon oben.
    Du mußt als root dir natürlich mit der Benutzer verständigen ober das was jeder tun geht. Und das sollte, wenn beide zufälligerweise die gleiche Person sind, nicht all zu schwiereig sein.
    Henk van Velden

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,870

    Default AW: Nach umount Gerät im System nicht mehr auffindbar?

    Noch einmal zur Erklärung:
    Du mountest keine Festplatte sondern die darauf angelegten Partitionen.

    /dev/sdi ist die Festplatte
    /dev/sdi1 ist die erste Partition auf Festplatte /dev/sdi

    Poste mal als root bei eingesteckten USB-Geräten und Karte:
    Code:
    fdisk -l
    Last edited by Sauerland; 26-Aug-2020 at 22:43.

  7. #7

    Default Re: Nach umount Gerät im System nicht mehr auffindbar?

    Hallo,

    @hcvv:
    Code:

    umount /dev/sdi /mnt

    ist Falsch. Wenn es Fehlermeldungen gibt sollte man die nicht ignorieren.
    Besser wäre
    Code:
    umount /mnt
    Danke für die Korrektur. Ich war mir bisher nicht ganz sicher, aber es hat trotzdem funktioniert - analog Befehl mount.


    @Sauerland
    Poste mal als root bei eingesteckten USB-Geräten und Karte:
    Code:
    fdisk -l
    Code:
    # fdisk -l
    Festplatte /dev/sda: 232,9 GiB, 250059350016 Bytes, 488397168 Sektoren
    Disk model: Samsung SSD 860 
    Einheiten: Sektoren von 1 * 512 = 512 Bytes
    Sektorgröße (logisch/physikalisch): 512 Bytes / 512 Bytes
    E/A-Größe (minimal/optimal): 512 Bytes / 512 Bytes
    Festplattenbezeichnungstyp: gpt
    Festplattenbezeichner: 4B8682CE-A06A-4CED-B778-AF50D38744CB
    
    Gerät         Anfang      Ende  Sektoren Größe Typ
    /dev/sda1    2048000   5119999   3072000  1,5G EFI-System
    /dev/sda2    5120000   9215999   4096000    2G Microsoft reserviert
    /dev/sda3    9216000 110524918 101308919 48,3G Microsoft Basisdaten
    /dev/sda4  110526464 114620415   4093952    2G Windows-Wiederherstellungsumgebung
    /dev/sda5  114620416 115767295   1146880  560M Microsoft Basisdaten
    /dev/sda6  115767296 132544511  16777216    8G Linux Swap
    /dev/sda7  132544512 237402111 104857600   50G Linux-Dateisystem
    
    
    Festplatte /dev/sdb: 1,8 TiB, 2000398934016 Bytes, 3907029168 Sektoren
    Disk model: ST2000DM008-2FR1
    Einheiten: Sektoren von 1 * 512 = 512 Bytes
    Sektorgröße (logisch/physikalisch): 512 Bytes / 4096 Bytes
    E/A-Größe (minimal/optimal): 4096 Bytes / 4096 Bytes
    Festplattenbezeichnungstyp: gpt
    Festplattenbezeichner: 6FB70E26-C9D6-4BE7-B0B7-9B05D7F5F544
    
    Gerät          Anfang       Ende   Sektoren  Größe Typ
    /dev/sdb1        2048 1859028991 1859026944 886,5G Microsoft Basisdaten
    /dev/sdb2  1859028992 3907028991 2048000000 976,6G Linux-Dateisystem
    
    
    Festplatte /dev/sdh: 7,4 GiB, 7916748800 Bytes, 15462400 Sektoren
    Disk model: Internal Storage
    Einheiten: Sektoren von 1 * 512 = 512 Bytes
    Sektorgröße (logisch/physikalisch): 512 Bytes / 512 Bytes
    E/A-Größe (minimal/optimal): 512 Bytes / 512 Bytes
    Festplattenbezeichnungstyp: dos
    Festplattenbezeichner: 0x6f20736b
    
    Gerät      Boot     Anfang       Ende   Sektoren  Größe Kn Typ
    /dev/sdh1        778135908 1919645538 1141509631 544,3G 72 unbekannt
    /dev/sdh2        168689522 2104717761 1936028240 923,2G 65 Novell Netware 386
    /dev/sdh3       1869881465 3805909656 1936028192 923,2G 79 unbekannt
    /dev/sdh4       2885681152 2885736650      55499  27,1M  d unbekannt
    
    Partitionstabelleneinträge sind nicht in Festplatten-Reihenfolge.
    
    
    Festplatte /dev/sdi: 59,5 GiB, 63864569856 Bytes, 124735488 Sektoren
    Disk model: SD Card Slot    
    Einheiten: Sektoren von 1 * 512 = 512 Bytes
    Sektorgröße (logisch/physikalisch): 512 Bytes / 512 Bytes
    E/A-Größe (minimal/optimal): 512 Bytes / 512 Bytes
    Festplattenbezeichnungstyp: dos
    Festplattenbezeichner: 0x00000000
    -
    Gruß, su_lin_user1

  8. #8
    Join Date
    Sep 2014
    Location
    Germany
    Posts
    549

    Default Re: AW: Nach umount Gerät im System nicht mehr auffindbar?

    Quote Originally Posted by Sauerland View Post
    Noch einmal zur Erklärung:
    Du mountest keine Festplatte sondern die darauf angelegten Partitionen.

    /dev/sdi ist die Festplatte
    /dev/sdi1 ist die erste Partition auf Festplatte /dev/sdi
    Eingehängt (aka "gemountet") wird das Dateisystem und das kann auch direkt auf das Gerät (d.h. /dev/sdi, ohne Partition) aufgebracht werden.

    Viele Grüße

    susejunky

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    27,116

    Default Re: AW: Nach umount Gerät im System nicht mehr auffindbar?

    Quote Originally Posted by susejunky View Post
    Eingehängt (aka "gemountet") wird das Dateisystem und das kann auch direkt auf das Gerät (d.h. /dev/sdi, ohne Partition) aufgebracht werden.

    Viele Grüße

    susejunky
    Wie ich shon in Post #3 versucht habe zu erklären. Mein Deutsch reight anscheinend nicht aus.

    Wie es in dieser Fall ist, ist aber in Post #4 schon klar geworden. Und da hat sich auch gezeigt das der OP das Ganze nicht wiederholen kann.

    Also, bis auf weiteres (das heiẞt klares Beweis) kónnen wir wenig machen.
    Last edited by hcvv; 27-Aug-2020 at 03:01.
    Henk van Velden

  10. #10

    Default Re: Nach umount Gerät im System nicht mehr auffindbar?

    Hallo,

    also danke für alle Erklärungen, die bestimmt nicht umsonst waren.

    Ich habe verstanden, dass man nicht eine Festplatte mountet, sondern nur bestehende Partitionen. Im Titel hätte ich vielleicht besser anstatt Gerät, Partition schreiben müssen. Ich treffe vielleicht die richtigen Begriffe als Anfänger noch nicht so präzise.
    Vielleicht habt ihr aber auch überlesen, dass mein Problem wiederholt war, dass eine gerade ausgehängte Partition im System nicht mehr aufgelistet wurde und es deshalb oft auch nicht mehr möglich war die gleiche Partition bei Bedarf wieder einzuhängen. Erst später kam ich auf den Verdacht, dass sich Dolphin und Konsole vielleicht gegenseitig blockieren, da ich zuletzt nur noch mit Konsole gearbeitet habe und diese Probleme nicht mehr hatte.
    -
    Gruß, su_lin_user1

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •