Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: Nach umount Gerät im System nicht mehr auffindbar?

  1. #11

    Default Re: Nach umount Gerät im System nicht mehr auffindbar?

    Hallo,

    noch eine unverständliche Sache.
    Ich habe momentan keine Partition am PC eingesteckt die den Namen /dev/sdi hat. Trotzdem erhalte ich mit "mount" die Anzeige /dev/sdi on /mnt.
    Ich habe keine Erklärung dafür. Könnte mir hier im Forum jemand erklären wieso das so ist?
    Code:
    localhost:/ # lsblk      
    NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
    sda      8:0    0 232,9G  0 disk 
    ├─sda1   8:1    0   1,5G  0 part 
    ├─sda2   8:2    0     2G  0 part 
    ├─sda3   8:3    0  48,3G  0 part 
    ├─sda4   8:4    0     2G  0 part 
    ├─sda5   8:5    0   560M  0 part /boot/efi
    ├─sda6   8:6    0     8G  0 part [SWAP]
    └─sda7   8:7    0    50G  0 part /
    sdb      8:16   0   1,8T  0 disk 
    ├─sdb1   8:17   0 886,5G  0 part 
    └─sdb2   8:18   0 976,6G  0 part /home
    sde      8:64   1  59,5G  0 disk 
    sdj      8:144  0   2,7T  0 disk 
    └─sdj1   8:145  0   2,7T  0 part 
    sr0     11:0    1 535,2M  0 rom  
    localhost:/ # mount
    sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
    proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
    devtmpfs on /dev type devtmpfs (rw,nosuid,size=8155952k,nr_inodes=2038988,mode=755)
    securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
    tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
    devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
    tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
    tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
    cgroup on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime)
    cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,name=systemd)
    pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
    efivarfs on /sys/firmware/efi/efivars type efivarfs (rw,nosuid,nodev,noexec,relatime)
    cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
    cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
    cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
    cgroup on /sys/fs/cgroup/rdma type cgroup (rw,nosuid,nodev,noexec,relatime,rdma)
    cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
    cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
    cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
    cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
    cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
    cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
    cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
    /dev/sda7 on / type ext4 (rw,relatime)
    systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=33,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=23612)
    debugfs on /sys/kernel/debug type debugfs (rw,relatime)
    hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime,pagesize=2M)
    mqueue on /dev/mqueue type mqueue (rw,relatime)
    /dev/sda5 on /boot/efi type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
    /dev/sdb2 on /home type ext4 (rw,relatime,data=ordered)
    tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=1633160k,mode=700,uid=1000,gid=100)
    gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)
    fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
    /dev/sdi on /mnt type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
    tracefs on /sys/kernel/debug/tracing type tracefs (rw,relatime)
    Und noch eine unverständliche Sache. Wieso kann ich unter /mnt kein Verzeichnis anlegen? Ich würde gern verschiedene Verzeichnisse für Speichermedien anlegen.
    Code:
    localhost:/mnt # mkdir SD_card
    mkdir: das Verzeichnis „SD_card“ kann nicht angelegt werden: Eingabe-/Ausgabefehler
    -
    Gruß, su_lin_user1

  2. #12
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,015

    Default AW: Nach umount Gerät im System nicht mehr auffindbar?

    Ich habe momentan keine Partition am PC eingesteckt die den Namen /dev/sdi hat. Trotzdem erhalte ich mit "mount" die Anzeige /dev/sdi on /mnt.
    Ich habe keine Erklärung dafür. Könnte mir hier im Forum jemand erklären wieso das so ist?
    Code:
    /dev/sdi on /mnt type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
    Poste einmal:
    Code:
    cat /etc/fstab

  3. #13

    Default Re: Nach umount Gerät im System nicht mehr auffindbar?

    Hallo,

    @Sauerland:
    Poste einmal:
    Code:

    cat /etc/fstab
    Code:
    localhost:/mnt # cat /etc/fstab
    UUID=6207ec2a-0775-48f5-a316-2d57c5145d29  swap       swap  defaults      0  0
    UUID=55732048-b266-495d-8ea6-ea67eb6a1d19  /          ext4  defaults      0  1
    UUID=af750ff7-9ced-4dee-b5c8-41a45769f1a0  /home      ext4  data=ordered  0  2
    UUID=6324-DD15                             /boot/efi  vfat  defaults      0  2
    -
    Gruß, su_lin_user1

  4. #14
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,015

    Default AW: Nach umount Gerät im System nicht mehr auffindbar?

    Dann mal als root:
    Code:
    umount /dev/sdi
    Und dann mal nachschauen, ob die immer noch da ist.

    Übrigens benutze ich unter Plasma/KDE immer das automount-Aplett zum mounten und auch wieder sicher entfernen.

  5. #15

    Default Re: Nach umount Gerät im System nicht mehr auffindbar?

    Hallo,

    @Sauerland:
    Dann mal als root:
    Code:
    umount /dev/sdi
    Code:
    localhost:/mnt # umount /dev/sdi
    umount: /mnt: das Ziel wird gerade benutzt.
    -
    Gruß, su_lin_user1

  6. #16
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,015

    Default AW: Nach umount Gerät im System nicht mehr auffindbar?

    /dev/sdi on /mnt type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
    mounte niemals in ein schon vorhandenes Verzeichnis, in diesem Fall /mnt.
    Erstelle immer ein neues Verzeichnis unterhalb des vorhandenen Verzeichnisses z.B. Disk1.....

    Bei mir in der /etc/fstab:
    Code:
    /dev/sdb3 on /mnt/1TB type ext4 (rw,relatime,stripe=32750)
    /dev/sda1 on /mnt/2TB type ext4 (rw,relatime)
    Und hier:
    Code:
    ls -al /mnt/
    insgesamt 12
    drwxr-xr-x 1 root    root    30  6. Aug 08:54 .
    drwxr-xr-x 1 root    root   178 15. Aug 09:44 ..
    drwxrwxr-x 6 stephan users 4096 30. Dez 2016  1TB
    lrwxrwxrwx 1 root    root     8 19. Sep 2019  2GB -> /mnt/2TB
    drwxrwxr-x 6 stephan users 4096 12. Jan 2019  2TB
    drwxr-xr-x 1 root    root     0  6. Aug 08:54 laptop
    Wie du siehst, alles in separaten Verzeichnissen.
    Und diese müssen beim mount schon angelegt worden sein.

  7. #17
    Join Date
    Sep 2014
    Location
    Germany
    Posts
    554

    Default Re: Nach umount Gerät im System nicht mehr auffindbar?

    Quote Originally Posted by su_lin_user1 View Post
    ...
    Code:
    localhost:/mnt # umount /dev/sdi
    umount: /mnt: das Ziel wird gerade benutzt.
    An der Eingabeaufforderung "localhost:/mnt #" ist zu sehen, dass das Verzeichnis /mnt das Verzeichnis ist, in dem Deine Konsole gerade arbeitet.

    Solange das der Fall ist, kann das Verzeichnis bzw. das Dateisystem, welches auf diesem Verzeichnis eingehängt ist, nicht ausgehängt werden. Das trifft auch zu, wenn das Verzeichnis /mnt oder ein Unterverzeichnis oder eine Datei aus dem Verzeichnis oder einem Unterverzeichniss gerade anderweitig genutzt wird (z.B. mit Dolphin, mit einem Editor, mit VLC, ...)

    Probiere folgendes (als "root" in einer Konsole):
    Code:
    # cd /
    # umount -f /mnt
    Viele Grüße

    susejunky

  8. #18

    Default Re: Nach umount Gerät im System nicht mehr auffindbar?

    Hallo,

    @Sauerland:
    mounte niemals in ein schon vorhandenes Verzeichnis, in diesem Fall /mnt.
    Erstelle immer ein neues Verzeichnis unterhalb des vorhandenen Verzeichnisses z.B. Disk1.....
    Ok, dass ist keine Kür sondern Pflicht.


    Wie du siehst, alles in separaten Verzeichnissen.
    Und diese müssen beim mount schon angelegt worden sein.
    Also das heißt für jede gemountete Patition ein eigenes Verzeichnis. Ja, das hatte ich jetzt zuletzt vor, da ich bemerkt habe, dass sonst nicht klappt.

    Ich hoffe, dass ich nach einem reboot wieder Verzeichnisse unter /mnt erstellen kann.
    Danke für die Hilfe.
    -
    Gruß, su_lin_user1

  9. #19
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    27,359

    Default Re: Nach umount Gerät im System nicht mehr auffindbar?

    Entschuldige. Es wird mich zuviel. Zu viele Unwahrkeiten, Halbunwahrkeiten, nur halb definiierte Probleme.

    Ich kann nur empfehlen das man wirklich eindringlich versucht zu verstehen wie das ist mit:
    • der enzige Verzeichnisbaum (single directory tree) in Unix/Linux und wie man die aufbaut;
    • was sich eigentlich hinter dem begriff Anhängen (mount) verbirgt (welche Parameter man braucht um es zu tun, was die Folgen sind für den Baum, usw.);
    • der Unterschied zwischen Behälter (volumes) und was da drin ist wie Dateisysteme (file systems).


    Wenn man das versteht wird man auch verstehen das ein mkdir innerhalb /mnt verschiedene Resultate hat wenn in /mnt nichts gemounted ist oder wenn da etwas gemounted ist.

    Man wird dann auch verstehen was passiert wenn man etwas mounted auf ein Verzeichnis wo schon Dateien drin sind.

    Ich habe dafür schon auf Niederländisch geschrieben, fülle mich aber nicht im Stande das auch auf Deutsch zu tun. Es gibt aber bestimmt gute Bücher, Papier oder On-line.
    Henk van Velden

  10. #20

    Default Re: Nach umount Gerät im System nicht mehr auffindbar?

    Hallo,

    @susejunky:
    An der Eingabeaufforderung "localhost:/mnt #" ist zu sehen, dass das Verzeichnis /mnt das Verzeichnis ist, in dem Deine Konsole gerade arbeitet.

    Solange das der Fall ist, kann das Verzeichnis bzw. das Dateisystem, welches auf diesem Verzeichnis eingehängt ist, nicht ausgehängt werden. Das trifft auch zu, wenn das Verzeichnis /mnt oder ein Unterverzeichnis oder eine Datei aus dem Verzeichnis oder einem Unterverzeichniss gerade anderweitig genutzt wird (z.B. mit Dolphin, mit einem Editor, mit VLC, ...)
    Danke für den Tip. Habe verstanden.

    @Sauerland:
    Ich habe jetzt die Verzeichnisse angelegt, die dann für die verschiedenen volumes (Wechseldatenträger, ext. Laufwerk usw.) als mount point dienen sollen, damit in Zukunft jede gemountete Partition sein eigenes Verzeichnis hat.
    Code:
    linux:/mnt # dir
    insgesamt 16
    drwxr-xr-x 2 root root 4096 27. Aug 21:12 mybook
    drwxr-xr-x 2 root root 4096 27. Aug 21:13 sansa_clip
    drwxr-xr-x 2 root root 4096 27. Aug 21:12 sd_card
    drwxr-xr-x 2 root root 4096 27. Aug 21:11 usb_stick
    -
    Gruß, su_lin_user1

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •