Results 1 to 6 of 6

Thread: My package produce files under /usr/src/debug/, with BuildArch: noarch

  1. #1
    Join Date
    Oct 2018
    Location
    Atlantis
    Posts
    191

    Default My package produce files under /usr/src/debug/, with BuildArch: noarch

    I received RPMLINT warning "W: no-binary for my package. The package should be of the noarch architecture because it doesn't contain any binaries."

    So I add BuildArch: noarch to the spec file. But I received unpackage files under /usr/src/debug/, however, from what I understand, files under debug can only exist if I enable debug info flag in OBS but I did not enable it.
    Is this normal?
    Also, does having files under usr/lib/cmake/qdldl normal? or do I have to force it to lib64?

    https://build.opensuse.org/package/s...he_great/qdldl

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,704
    Blog Entries
    15

    Default Re: My package produce files under /usr/src/debug/, with BuildArch: noarch

    Hi
    Change to "Release" rather than Install configuration: "RelWithDebInfo" with -DCMAKE_BUILD_TYPE=Release
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Oct 2018
    Location
    Atlantis
    Posts
    191

    Default Re: My package produce files under /usr/src/debug/, with BuildArch: noarch

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Change to "Release" rather than Install configuration: "RelWithDebInfo" with -DCMAKE_BUILD_TYPE=Release
    Hello,

    I tried adding the flag like you suggest, however, the same debug directory still appear.
    Looking at the log, I also found -DCMAKE_BUILD_TYPE=RelWithDebInfo being invoke together with the -DCMAKE_BUILD_TYPE=Release, How to override the flag?
    Thanks.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,704
    Blog Entries
    15

    Default Re: My package produce files under /usr/src/debug/, with BuildArch: noarch

    Quote Originally Posted by andythe_great View Post
    Hello,

    I tried adding the flag like you suggest, however, the same debug directory still appear.
    Looking at the log, I also found -DCMAKE_BUILD_TYPE=RelWithDebInfo being invoke together with the -DCMAKE_BUILD_TYPE=Release, How to override the flag?
    Thanks.
    Hi
    Patch the CmakeLists.txt file(s).
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Oct 2018
    Location
    Atlantis
    Posts
    191

    Default Re: My package produce files under /usr/src/debug/, with BuildArch: noarch

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Patch the CmakeLists.txt file(s).
    Hello,

    I look through all the cmakelists.txt files and search for RelWithDebInfo, and I don't found any.
    Then I add set(CMAKE_BUILD_TYPE Release) to all cmakelists.txt files. However, the build log still show -DCMAKE_BUILD_TYPE=RelWithDebInfo being invoke.

    So is there other places that -DCMAKE_BUILD_TYPE=RelWithDebInfo was called other than cmakelists.txt?
    Thanks.

  6. #6
    Join Date
    Oct 2018
    Location
    Atlantis
    Posts
    191

    Default Re: My package produce files under /usr/src/debug/, with BuildArch: noarch

    SOLVED

    I have debug info tick in OBS.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •