Results 1 to 10 of 10

Thread: Usb devices don't work after kernel 5.3.18-lp152.36-default update

  1. #1

    Default Usb devices don't work after kernel 5.3.18-lp152.36-default update

    Hi guys, first time here!
    I've upgraded the kernel at the 5.3.18-lp152.36-default version on my openSUSE 15.2 and since then all my usb mouse/keyboard don't work anymore but usb pendrives or external mass storage are fine. I've watch at the dmesg output with
    Code:
    dmesg -w
    And I saw that all my devices are detected but nevertheless work.
    Here the output when I test to connect/disconnect my wireless mouse and I used the previous command:
    Code:
    [55976.777790] usb 1-1: new full-speed USB device number 32 using xhci_hcd
    [55976.927963] usb 1-1: New USB device found, idVendor=25a7, idProduct=fa23, bcdDevice= 2.40
    [55976.927968] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    [55976.927971] usb 1-1: Product: 2.4G Receiver
    [55976.927974] usb 1-1: Manufacturer: Compx
    [55976.930731] input: Compx 2.4G Receiver as /devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.0/0003:25A7:FA23.0029/input/input108
    [55976.990252] hid-generic 0003:25A7:FA23.0029: input,hidraw0: USB HID v1.10 Keyboard [Compx 2.4G Receiver] on usb-0000:00:14.0-1/input0
    [55976.994073] input: Compx 2.4G Receiver Mouse as /devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.1/0003:25A7:FA23.002A/input/input109
    [55976.994382] input: Compx 2.4G Receiver as /devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.1/0003:25A7:FA23.002A/input/input110
    [55976.994647] input: Compx 2.4G Receiver Consumer Control as /devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.1/0003:25A7:FA23.002A/input/input111
    [55977.054019] input: Compx 2.4G Receiver System Control as /devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.1/0003:25A7:FA23.002A/input/input112
    [55977.054348] hid-generic 0003:25A7:FA23.002A: input,hiddev96,hidraw1: USB HID v1.10 Mouse [Compx 2.4G Receiver] on usb-0000:00:14.0-1/input1
    [56095.125714] usb 1-1: USB disconnect, device number 32
    I googled for a while for an explanation and a way to fix this very annoying problem but I didn't reach it.
    Did you have this problem as well, guys?

    Thanks for now

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,417
    Blog Entries
    3

    Default Re: Usb devices don't work after kernel 5.3.18-lp152.36-default update

    I am not noticing a problem here. As far as I can tell, USB devices are all working: keyboard, mouse, flash drive, external drive, apcups.

    I suggest that you boot the previous kernel to see if that fixes the problem. This is intended just as a cross check to help decide whether this is a kernel issue or some other issue.

    Note that if you use UEFI booting, then you may need to disable secure-boot before you can boot the previous kernel. Use the "Advanced options" boot menu line to select which kernel to boot.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

  3. #3

    Default Re: Usb devices don't work after kernel 5.3.18-lp152.36-default update

    Firstly, thank you for the very quick reply.
    I just tried to boot with the older kernel (5.3.18-lp152.33-default) and the problem persist so I assume that is not a problem of the kernel, I taught so maybe because I didn't connect usb devices for a while.
    Is there anything else that I can check?

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    27,142

    Default Re: Usb devices don't work after kernel 5.3.18-lp152.36-default update

    Quote Originally Posted by billporta View Post
    Is there anything else that I can check?
    Well,
    Code:
    lsusb
    Henk van Velden

  5. #5

    Default Re: Usb devices don't work after kernel 5.3.18-lp152.36-default update

    Quote Originally Posted by hcvv View Post
    Well,
    Code:
    lsusb
    Here the output of lsusb when the device isn't connected:
    Code:
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 003: ID 04f2:b52d Chicony Electronics Co., Ltd 
    Bus 001 Device 002: ID 8087:0a2a Intel Corp. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    When is connected:
    Code:
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 003: ID 04f2:b52d Chicony Electronics Co., Ltd 
    Bus 001 Device 002: ID 8087:0a2a Intel Corp. 
    Bus 001 Device 012: ID 25a7:fa23  
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    27,142

    Default Re: Usb devices don't work after kernel 5.3.18-lp152.36-default update

    At least the device 25a7:fa23 is detected. It apperentlky can not be found in the lists that will report readable manufacturer and product names, but that may nly of minor importtance.
    OTOH the dmesg in your first post sees to have found it as Compx 2.4G Receiver, Does that sound a bell?
    And then I assume you disconnect it.

    BTW when you post code, then please iclude one more line at the top so it includes the prompt and the command (and inclusing one more line at the bottom which has the new prompt to show it is complete). Easy to do and it spares you the typing of texts like "when I do command xxx, I get". It gives others the complete picture of who you were, where you were and what you did. The best replacement for looking over your shoulder we have.
    Henk van Velden

  7. #7

    Default Re: Usb devices don't work after kernel 5.3.18-lp152.36-default update

    Yeah, it's right I've connected a generic wireless mouse dongle to usb and then disconnect it, but with all kind of usb devices (EXCEPT FOR MASS STORAGE DEVICES such as pen drive) I have the same problem: they are recognized but don't work.

    Sorry the next time I'll post the code in the right way ahahah.

  8. #8

    Default Re: Usb devices don't work after kernel 5.3.18-lp152.36-default update

    I SOLVED simply reinstall openSUSE 15.2 from scratch and restoring my personal data
    Thank you to all for the support I'll close the thread.

    EDIT: How can I close the thread? (I'm new sorry)

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    27,142

    Default Re: Usb devices don't work after kernel 5.3.18-lp152.36-default update

    Quote Originally Posted by billporta View Post
    I SOLVED simply reinstall openSUSE 15.2 from scratch and restoring my personal data
    Thank you to all for the support I'll close the thread.

    EDIT: How can I close the thread? (I'm new sorry)
    Well, I am glad that it is solved for you. However the way it is done is a bit disappointing because we will probably never know what was wrong. But in the end we can live with that .

    You do not close a thread, saying that it is solved for you in a post (like you did above) is enough.

    Enjoy openSUSE.
    Henk van Velden

  10. #10

    Default Re: Usb devices don't work after kernel 5.3.18-lp152.36-default update

    Quote Originally Posted by hcvv View Post
    Well, I am glad that it is solved for you. However the way it is done is a bit disappointing because we will probably never know what was wrong. But in the end we can live with that .
    Yeah I know that it's not correct but I was in a hurry because I need this machine always ready for working reasons, so thank you for the support
    You do not close a thread, saying that it is solved for you in a post (like you did above) is enough.
    Perfect!
    Bye and thank you for all!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •