Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: nvidia-*04 in https://download.nvidia.com/ repo not working with Kernel 5.3.18-lp152.36-default

  1. #1
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    746

    Default nvidia-*04 in https://download.nvidia.com/ repo not working with Kernel 5.3.18-lp152.36-default

    Hello,

    I am currently testing out LEAP 15.2 on my Lenovo T480 with Optimus iGPU+Nvidia Mx150. I noticed that the nvidia-*04 drivers from (https://download.nvidia.com/opensuse/leap/15.2) is not compiled with Kernel 5.3.18-lp152.36-default.

    For the time being I am using nvidia-*05 drivers which seem to work, but is this something that will be expected to be patched either from Nvidia or the next LEAP kernel?

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,698
    Blog Entries
    15

    Default Re: nvidia-*04 in https://download.nvidia.com/ repo not working with Kernel 5.3.18-lp152.36-default

    Quote Originally Posted by SJLPHI View Post
    Hello,

    I am currently testing out LEAP 15.2 on my Lenovo T480 with Optimus iGPU+Nvidia Mx150. I noticed that the nvidia-*04 drivers from (https://download.nvidia.com/opensuse/leap/15.2) is not compiled with Kernel 5.3.18-lp152.36-default.

    For the time being I am using nvidia-*05 drivers which seem to work, but is this something that will be expected to be patched either from Nvidia or the next LEAP kernel?

    Thanks.
    Hi
    If your card can use the latest G05 kmp, then best to carry on with that. It could very well be that the G04 needs patching for the later kernels, it just takes time to filter through.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    746

    Default Re: nvidia-*04 in https://download.nvidia.com/ repo not working with Kernel 5.3.18-lp152.36-default

    Quote Originally Posted by malcolmlewis View Post
    Hi
    If your card can use the latest G05 kmp, then best to carry on with that. It could very well be that the G04 needs patching for the later kernels, it just takes time to filter through.
    I am using the G05 kmp for now but it is not cuda friendly. I am just waiting for the patch to switch back to G04 for now.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,698
    Blog Entries
    15

    Default Re: nvidia-*04 in https://download.nvidia.com/ repo not working with Kernel 5.3.18-lp152.36-default

    Quote Originally Posted by SJLPHI View Post
    I am using the G05 kmp for now but it is not cuda friendly. I am just waiting for the patch to switch back to G04 for now.
    Hi
    I use manual install here of both the driver and cuda, all good for me?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    746

    Default Re: nvidia-*04 in https://download.nvidia.com/ repo not working with Kernel 5.3.18-lp152.36-default

    Quote Originally Posted by malcolmlewis View Post
    Hi
    I use manual install here of both the driver and cuda, all good for me?
    I am hoping for the "standard" release because I do not want to regularly maintain it.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,698
    Blog Entries
    15

    Default Re: nvidia-*04 in https://download.nvidia.com/ repo not working with Kernel 5.3.18-lp152.36-default

    Quote Originally Posted by SJLPHI View Post
    I am hoping for the "standard" release because I do not want to regularly maintain it.
    Hi
    It's all a compromise, but I have found the short time it takes to install the driver from the command line far out ways the waiting for a repository to update
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    746

    Default Re: nvidia-*04 in https://download.nvidia.com/ repo not working with Kernel 5.3.18-lp152.36-default

    Quote Originally Posted by malcolmlewis View Post
    Hi
    It's all a compromise, but I have found the short time it takes to install the driver from the command line far out ways the waiting for a repository to update
    Honestly, LEAP 15.1 and prior were more or less up to date most of the time. I'm surprised that Kernel 5.8.0 for TW and latest LEAP 15.2 kernels haven't been built with Nvidia yet.

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,698
    Blog Entries
    15

    Default Re: nvidia-*04 in https://download.nvidia.com/ repo not working with Kernel 5.3.18-lp152.36-default

    Quote Originally Posted by SJLPHI View Post
    Honestly, LEAP 15.1 and prior were more or less up to date most of the time. I'm surprised that Kernel 5.8.0 for TW and latest LEAP 15.2 kernels haven't been built with Nvidia yet.
    Hi
    Not sure, likely patching issues the G04 has not been touched in a month the G05 was updated a couple of days ago....
    https://build.opensuse.org/project/s...:Drivers:Video

    From there it gets pushed to Nvidia for publishing...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9
    Join Date
    Oct 2014
    Location
    Switzerland
    Posts
    746

    Default Re: nvidia-*04 in https://download.nvidia.com/ repo not working with Kernel 5.3.18-lp152.36-default

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Not sure, likely patching issues the G04 has not been touched in a month the G05 was updated a couple of days ago....
    https://build.opensuse.org/project/s...:Drivers:Video

    From there it gets pushed to Nvidia for publishing...
    Well..
    soon enough I'll have to write a general macro to do the manual installation and updates...

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,698
    Blog Entries
    15

    Default Re: nvidia-*04 in https://download.nvidia.com/ repo not working with Kernel 5.3.18-lp152.36-default

    Quote Originally Posted by SJLPHI View Post
    Well..
    soon enough I'll have to write a general macro to do the manual installation and updates...
    Hi
    Have a read here: https://forums.opensuse.org/showthre...s-to-initramfs
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •