Results 1 to 3 of 3

Thread: Build for Fedora: have choice for (glibc-langpack-en or glibc-all-langpacks) needed by obs-service-o

Hybrid View

  1. #1

    Default Build for Fedora: have choice for (glibc-langpack-en or glibc-all-langpacks) needed by obs-service-o

    Here's my project https://build.opensuse.org/package/s...g_antonyan/mpz build works fine for opensuse, but when I enable Fedora or CentOS I get "unresolvable" error with this message:
    Code:
    have choice for (glibc-langpack-en or glibc-all-langpacks) needed by obs-service-obs_scm-common: glibc-all-langpacks glibc-langpack-en
    This is my "project config", to change dependencies names, but it does nothing it seems

    Code:
    %if 0%{?fedora} || 0%{?rhel_version} || 0%{?centos_version}
      Substitute: libqt5-qtbase-devel qt5-qtbase-devel
      Substitute: libqt5-qtmultimedia-devel qt5-qtmultimedia-devel
      Substitute: libqt5-qtx11extras-devel qt5-qtx11extras-devel
      BuildRequires: glibc-all-langpacks glibc-langpack-en
    %endif
    How to fix this?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,819
    Blog Entries
    15

    Default Re: Build for Fedora: have choice for (glibc-langpack-en or glibc-all-langpacks) needed by obs-servi

    Quote Originally Posted by oleg_antonyan1 View Post
    Here's my project https://build.opensuse.org/package/s...g_antonyan/mpz build works fine for opensuse, but when I enable Fedora or CentOS I get "unresolvable" error with this message:
    Code:
    have choice for (glibc-langpack-en or glibc-all-langpacks) needed by obs-service-obs_scm-common: glibc-all-langpacks glibc-langpack-en
    This is my "project config", to change dependencies names, but it does nothing it seems

    Code:
    %if 0%{?fedora} || 0%{?rhel_version} || 0%{?centos_version}
      Substitute: libqt5-qtbase-devel qt5-qtbase-devel
      Substitute: libqt5-qtmultimedia-devel qt5-qtmultimedia-devel
      Substitute: libqt5-qtx11extras-devel qt5-qtx11extras-devel
      BuildRequires: glibc-all-langpacks glibc-langpack-en
    %endif
    How to fix this?
    Hi and welcome to the Forum
    AFAIK, you need to add a Prefer: for which ever one your want to use.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Build for Fedora: have choice for (glibc-langpack-en or glibc-all-langpacks) needed by obs-servi

    It worked!
    Code:
    %if 0%{?fedora} || 0%{?rhel_version} || 0%{?centos_version}
      Substitute: libqt5-qtbase-devel qt5-qtbase-devel
      Substitute: libqt5-qtmultimedia-devel qt5-qtmultimedia-devel
      Substitute: libqt5-qtx11extras-devel qt5-qtx11extras-devel
      Presef: glibc-all-langpacks
    %endif
    Thank you, malcolmlewis!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •