Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Nach Installation Leap 15.2 kein Windows im Boot-Menue

  1. #11
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,704

    Default AW: Nach Installation Leap 15.2 kein Windows im Boot-Menue

    Die Installation erfolgt in dem Modus, der bei dir lt. Bios/UEFI eingestellt ist.
    Zeichen für den Leagcy Modus ist, das du im 1. Installationsbildschirm mit den F-Tasten etwas auswählen und verändern kannst.
    Das gibt es im UEFI Modus nicht.

  2. #12

    Default AW: Nach Installation Leap 15.2 kein Windows im Boot-Menue

    Hallo,

    @Sauerland:
    Ich habe bei der Installation nach dem Partitionieren eine Warnungsmeldung erhalten, wusste aber nicht was das bedeuten kann. Somit habe ich es ignoriert.
    Der Partitionstyp BIOS-Boot-Partition ist erforderlich,um den Bootloader zu installieren.
    Ein solches Setup wird nicht unterstützt und kann jetzt und in der Zukunft zu Problemen mit dem Bootloader führen.
    Möchten Sie fortfahren?
    Ich habe keinen Partitionstyp BIOS-Boot-Partition zur Auswahl gehabt.

    Die Installation erfolgt in dem Modus, der bei dir lt. Bios/UEFI eingestellt ist.
    In meinem Bios ist CSM aktiv. Das heißt EFI und auch MBR können booten (Aussage von Tuxedo Computers).
    -
    Gruß, su_lin_user1

  3. #13
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,704

    Default AW: Nach Installation Leap 15.2 kein Windows im Boot-Menue

    In meinem Bios ist CSM aktiv. Das heißt EFI und auch MBR können booten (Aussage von Tuxedo Computers).
    Dann stell es um.....

  4. #14

    Default Re: Nach Installation Leap 15.2 kein Windows im Boot-Menue

    Hallo,

    @Sauerland:
    Hier gibt es dazu auch einen Beitrag:
    https://forums.opensuse.org/showthre...ith-Windows-10
    Ich bin nach bestem Verständnis der Anweisung gefolgt.
    Das Ergebnis ist, der Windows Bootloader Eintrag auf /dev/sda1 ist wieder im Bootmenue zu sehen. Jedoch bootet Windows nicht.
    Meldung im Terminalfenster beim Windows boot:
    Code:
    error invalid signiture.
    press any key to continue
    Dann stell es um.....
    Soll ich bei der Situation jetzt, auch noch CSM auf disable stellen?
    -
    Gruß, su_lin_user1

  5. #15
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,704

    Default AW: Nach Installation Leap 15.2 kein Windows im Boot-Menue

    Mal ne Frage:
    kannst du nicht einfach openSUSE neu installieren?
    Vorher aber das Bios/UEFI umstellen auf UEFI only?

  6. #16

    Default Re: Nach Installation Leap 15.2 kein Windows im Boot-Menue

    Hallo Sauerland,

    Mal ne Frage:
    kannst du nicht einfach openSUSE neu installieren?
    Vorher aber das Bios/UEFI umstellen auf UEFI only?
    Ja, natürlich ist das möglich, Das Hauptproblem war momentan, dass Windows nicht mehr booten konnte.

    Wenn ich openSUSE neu installiere mit UEFI, ist dann auch zu erwarten, dass Windows wieder booten kann? Nur so nebenbei gefragt. Notfalls müsste man auch Windows noch mal installieren.
    Falls die Chancen gering sind, dass Windows nach einer Neuinstallation von openSUSE wieder starten kann, wäre es fast besser ich installiere gleich beide neu, angefangen mit Windows, dann openSUSE, damit es keine Schwierigkeiten beim Überschreiben des Bootloaders gibt.
    Windows habe ich auch noch nicht unter UEFI installiert. Müsste mich auch erst mal schlau machen.

    Danke für Deine Tips.
    -
    Gruß, su_lin_user1

  7. #17

    Default Re: Nach Installation Leap 15.2 kein Windows im Boot-Menue

    Hallo,

    ich habe nun den kompletten PC neu formatiert und mit Windows 10 und openSUSE 15.2 neu installiert. Dabei muss berücksichtigt werden, dass Windows als erstes installiert wird, da im umgekehten Fall Windows den Linux Bootloader überschreiben würde und das system nicht mehr booten würde.
    Ich habe dazu den user vom alten PC auf diesen neuen PC verlegt. kMail und Benutzerdaten sind jetzt wie auf dem alten PC verwendbar. Damit kann ich den alten PC endlich als zweitrangig verwenden.

    Schwierigkeiten gab es mit dem Installations USB für Windows. Obwohl das Verzeichnis auf dem Stick sichtbar einen Ordner für EFI enthält und damit vermuten lässt, dass man eine UEFI Installation durchführen kann, war jedoch nur eine Installation BIOS auf MBR möglich, also die alte Methode. Ich habe gelesen, dass das Bootmedium mit FAT32, nicht mit NTFS formatiert sein muss, sonst kann die Installation nicht auf UEFI erfogen. Dass heißt, man bekommt im Fall einer FAT32 Formatierung erst keine Auswahl wie " UEFI USB Installationmedium" beim Bootmenue zu sehen. Erst, wenn der USB auf FAT32 formatiert ist und natürlich der Inhalt davon wieder 1:1 drauf kopiert ist, bekommt man plötzlich die Auswahl " UEFI USB Installationmedium" und kann die Installation anlegen. Das Umkopieren habe ich mit tar erledigt. Das hat selbst bei anfänglicher Ungewissheit gut geklappt.

    Eine weitere Schwierigkeit ergab sich mit den Partitionen, die Windows von sich aus anlegt. Microsoft nimmt natürlich keine Rücksicht darauf, dass vielleicht neben Windows noch LInux installiert werden könnte. Deshalb sind die Partitionen knapp mit bemessen. Nach der Installation ist es mit normalen Hilfmitteln nicht möglich die ersten Partitionen zu vergrößern. Deshalb habe ich verucht, die Partitionen "EFI system partition", "Microsoft reserved partition" und die "Recovery Partition" vom Speicherplatz etwas großzügiger zu bemessen. Die System Partition für das Betriebssystem bekam eine 50 GiB Partition. Damit Windows die Partitionen bei der Installation von sich aus akzeptiert, ist es notwendig sie genau so anzulegen, mit Fomat, Benennung und Markierungen, wie Windows sie selbst anlegen würde. Dabei half mir "Gparted Live CD". Wenn die Installation geklappt hat und die Partitionen sich nicht danach verändert haben bzw. Windows nicht selbstständig neue Partitionen angelegt hat und diese anstatt verwendet hat, dann kann man beruhigt daran denken openSUSE zu installieren.

    Code:
    # parted -l
    Modell: ATA Samsung SSD 860 (scsi)
    Festplatte  /dev/sda:  250GB
    Sektorgröße (logisch/physisch): 512B/512B
    Partitionstabelle: gpt
    Disk-Flags: 
    
    Nummer  Anfang  Ende    Größe   Dateisystem     Name                          Flags
     1      1049MB  2621MB  1573MB  fat32           EFI system partition          boot, esp
     2      2621MB  4719MB  2097MB                  Microsoft reserved partition  msftres
     3      4719MB  56,6GB  51,9GB  ntfs            Basic data partition          msftdata
     4      56,6GB  58,7GB  2096MB  ntfs            Basic data partition          versteckt, diag
     5      58,7GB  59,3GB  587MB   fat32           primary                       msftdata
     6      59,3GB  67,9GB  8590MB  linux-swap(v1)                                swap
     7      67,9GB  122GB   53,7GB  ext4
    
    
    Modell: ATA ST2000DM008-2FR1 (scsi)
    Festplatte  /dev/sdb:  2000GB
    Sektorgröße (logisch/physisch): 512B/4096B
    Partitionstabelle: gpt
    Disk-Flags: 
    
    Nummer  Anfang  Ende    Größe   Dateisystem  Name           Flags
     1      1049kB  952GB   952GB   ntfs         Windows_Daten  msftdata
     2      952GB   2000GB  1049GB  ext4         Linux_Daten
    PS: Was ich noch vergessen habe, Windows sollte man nach der Installation komplett Updaten. Bekanntlich gibt es Versionssprünge innerhalb Windows 10 von Version 1803, auf Version 1903 und Version 1909. Wenn man Windows nicht ganz updatet und zwischen durch Linux installiert und später dann ein weiteres Windows Versions Update durch führt, kann es sein, dass Windows den Linux Bootloader überschreibt und Linux sich nicht mehr booten lässt. Deshalb am besten Windows vollständig updaten bevor man LInux installiert.
    -
    Gruß, su_lin_user1

  8. #18
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,704

    Default AW: Nach Installation Leap 15.2 kein Windows im Boot-Menue

    Schön, das es jetzt funktioniert.
    Sieht auch gut aus.

    Und du hast etwas dazugelernt, ist nie schlecht.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •