After installing a 64 bit system, I downloaded and installed the following 32 bit file of a cloud storage application called mega from the "mega.nz" site and was able to run it:


"Opensuse_tumbleweed.i586.rpm"


then I downloaded the following 32 bit rpm file from the vivaldi web browser site, but it didn't work:


"Vivaldi-stable-3.2.1967.41-1.i386.rpm"


I don't know where I went wrong. Is it because the second program I mentioned has the phrase "i386" in its name? if so, there is no version of vivaldi bearing the phrase i586. Or is there some other incompatibility?