Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Plasma desktop black screen with cursor only after update to kernel 5.7

  1. #1

    Default Plasma desktop black screen with cursor only after update to kernel 5.7

    After an update to kernel 5.7 I can no longer establish a functional plasma session. On boot the login screen appears but has strange behavior where objects flicker do not refresh properly. I can select user and enter passwrd but upon login (Plasma wayland) only a black screen with mouse cursor is visible. Ctl+Alt+Bksp kills session and returns to login screen. I can select Icewm and login successfully, see the expected backgrond and can launch applications etc. However display has intermittent flickering.

    I was able to boot from previous snapshot with kernel 5.6 and everything worked fine. Unfortunately I did a second update hoping it would fix the problem and now I've lost that working snapshot.

    Also tried installing kernel 5.8 but this does not fix the issue. Not sure if this is plasma, kernel or other dependency issue. Can ssh in if needed for debugging.
    Anything I can do to debug?
    Current system:

    linux-ka5p 5.8.0-2.g9bc0044-default #1 SMP Tue Aug 4 07:30:59 UTC 2020 (9bc0044) x86_64 x86_64 x86_64 GNU/Linux

    kded5 5.72.0
    plasma-framework 5.72.0-1.1
    plasma5-desktop 5.19.4-1.1

    NAME="openSUSE Tumbleweed"
    # VERSION="20200807"
    ID="opensuse-tumbleweed"
    ID_LIKE="opensuse suse"
    VERSION_ID="20200807"
    PRETTY_NAME="openSUSE Tumbleweed"
    ANSI_COLOR="0;32"
    CPE_NAME="cpe:/opensuse:tumbleweed:20200807"
    BUG_REPORT_URL="https://bugs.opensuse.org"
    HOME_URL="https://www.opensuse.org/"
    LOGO="distributor-logo"

    Heres graphics info:

    Code:
    # hwinfo --gfxcard19: PCI 02.0: 0300 VGA compatible controller (VGA)              
      [Created at pci.386]
      Unique ID: _Znp.Wziy7T1Yy33
      SysFS ID: /devices/pci0000:00/0000:00:02.0
      SysFS BusID: 0000:00:02.0
      Hardware Class: graphics card
      Model: "Intel Haswell-ULT Integrated Graphics Controller"
      Vendor: pci 0x8086 "Intel Corporation"
      Device: pci 0x0a06 "Haswell-ULT Integrated Graphics Controller"
      SubVendor: pci 0x1ae0 "Google, Inc."
      SubDevice: pci 0xc000 
      Revision: 0x09
      Driver: "i915"
      Driver Modules: "i915"
      Memory Range: 0xe0000000-0xe03fffff (rw,non-prefetchable)
      Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
      I/O Ports: 0x3000-0x303f (rw)
      Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
      IRQ: 45 (5965 events)
      Module Alias: "pci:v00008086d00000A06sv00001AE0sd0000C000bc03sc00i00"
      Driver Info #0:
        Driver Status: i915 is active
        Driver Activation Cmd: "modprobe i915"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
    
    
    Primary display adapter: #19
    Heres output from journalctl After reboot and then login to new user (Plasma wayland)


    Code:
    sudo journalctl -b -u display-manager.service
    -- Logs begin at Sat 2020-08-08 17:01:52 PDT, end at Sat 2020-08-08 17:26:23 PDT. --
    Aug 08 17:02:16 linux-ka5p systemd[1]: /usr/lib/systemd/system/display-manager.service:12: PIDFile= references a path below legacy directory /var/run/, updating /var/run/displaymanager.pid → /run/disp>
    Aug 08 17:02:21 linux-ka5p systemd[1]: /usr/lib/systemd/system/display-manager.service:12: PIDFile= references a path below legacy directory /var/run/, updating /var/run/displaymanager.pid → /run/disp>
    Aug 08 17:02:24 linux-ka5p systemd[1]: /usr/lib/systemd/system/display-manager.service:12: PIDFile= references a path below legacy directory /var/run/, updating /var/run/displaymanager.pid → /run/disp>
    Aug 08 17:02:28 linux-ka5p systemd[1]: /usr/lib/systemd/system/display-manager.service:12: PIDFile= references a path below legacy directory /var/run/, updating /var/run/displaymanager.pid → /run/disp>
    Aug 08 17:02:35 linux-ka5p systemd[1]: Starting X Display Manager...
    Aug 08 17:02:35 linux-ka5p display-manager[2190]: /etc/vconsole.conf available
    Aug 08 17:02:35 linux-ka5p display-manager[2190]: KEYMAP: us
    Aug 08 17:02:35 linux-ka5p display-manager[2190]: Command: localectl set-keymap us
    Aug 08 17:02:35 linux-ka5p display-manager[2190]: I: Using systemd /usr/share/systemd/kbd-model-map mapping
    Aug 08 17:02:39 linux-ka5p sddm[2213]: Initializing...
    Aug 08 17:02:39 linux-ka5p sddm[2213]: Starting...
    Aug 08 17:02:39 linux-ka5p sddm[2213]: Logind interface found
    Aug 08 17:02:39 linux-ka5p sddm[2213]: Adding new display on vt 7 ...
    Aug 08 17:02:39 linux-ka5p sddm[2213]: Loading theme configuration from ""
    Aug 08 17:02:39 linux-ka5p sddm[2213]: Display server starting...
    Aug 08 17:02:39 linux-ka5p sddm[2213]: Running: /usr/bin/X -nolisten tcp -auth /run/sddm/{baee475f-e46e-4947-9b4c-cb8a1d69f6c4} -background none -noreset -displayfd 17 -seat seat0 vt7
    Aug 08 17:02:39 linux-ka5p display-manager[2181]: Starting service sddm..done
    Aug 08 17:02:39 linux-ka5p systemd[1]: Started X Display Manager.
    Aug 08 17:02:40 linux-ka5p sddm[2213]: Setting default cursor
    Aug 08 17:02:40 linux-ka5p sddm[2213]: Running display setup script  "/etc/X11/xdm/Xsetup"
    Aug 08 17:02:40 linux-ka5p sddm[2213]: Display server started.
    Aug 08 17:02:40 linux-ka5p sddm[2213]: Socket server starting...
    Aug 08 17:02:40 linux-ka5p sddm[2213]: Socket server started.
    Aug 08 17:02:40 linux-ka5p sddm[2213]: Loading theme configuration from "/usr/share/sddm/themes/breeze-openSUSE/theme.conf"
    Aug 08 17:02:40 linux-ka5p sddm[2213]: Greeter starting...
    Aug 08 17:02:41 linux-ka5p sddm-helper[2233]: [PAM] Starting...
    Aug 08 17:02:41 linux-ka5p sddm-helper[2233]: [PAM] Authenticating...
    Aug 08 17:02:41 linux-ka5p sddm-helper[2233]: [PAM] returning.
    Aug 08 17:02:42 linux-ka5p sddm[2213]: Greeter session started successfully
    Aug 08 17:02:43 linux-ka5p sddm[2213]: Message received from greeter: Connect
    Aug 08 17:15:12 linux-ka5p sddm[2213]: Message received from greeter: Login
    Aug 08 17:15:12 linux-ka5p sddm[2213]: Reading from "/usr/share/wayland-sessions/plasmawayland.desktop"
    Aug 08 17:15:12 linux-ka5p sddm[2213]: Reading from "/usr/share/wayland-sessions/plasmawayland.desktop"
    Aug 08 17:15:12 linux-ka5p sddm[2213]: Session "/usr/share/wayland-sessions/plasmawayland.desktop" selected, command: "dbus-run-session /usr/bin/startplasma-wayland"
    Aug 08 17:15:12 linux-ka5p sddm-helper[2791]: [PAM] Starting...
    Aug 08 17:15:12 linux-ka5p sddm-helper[2791]: [PAM] Authenticating...
    Aug 08 17:15:12 linux-ka5p sddm-helper[2791]: [PAM] Preparing to converse...
    Aug 08 17:15:12 linux-ka5p sddm-helper[2791]: [PAM] Conversation with 1 messages
    Aug 08 17:15:12 linux-ka5p sddm-helper[2791]: [PAM] returning.
    Aug 08 17:15:12 linux-ka5p sddm[2213]: Authenticated successfully
    Aug 08 17:15:12 linux-ka5p sddm[2213]: Auth: sddm-helper exited successfully
    Aug 08 17:15:12 linux-ka5p sddm[2213]: Greeter stopped.
    Aug 08 17:15:13 linux-ka5p sddm-helper[2791]: pam_unix(sddm:session): session opened for user test(uid=1100) by (uid=0)
    Aug 08 17:15:13 linux-ka5p sddm-helper[2791]: Starting: "/usr/share/sddm/scripts/wayland-session dbus-run-session /usr/bin/startplasma-wayland"
    Aug 08 17:15:13 linux-ka5p sddm[2213]: Session started
    Aug 08 17:20:38 linux-ka5p sddm[2213]: Auth: sddm-helper exited successfully
    Aug 08 17:20:38 linux-ka5p sddm[2213]: Socket server stopping...
    Aug 08 17:20:38 linux-ka5p sddm[2213]: Socket server stopped.
    Aug 08 17:20:38 linux-ka5p sddm[2213]: Display server stopping...
    Aug 08 17:20:38 linux-ka5p sddm[2213]: Display server stopped.
    Aug 08 17:20:38 linux-ka5p sddm[2213]: Running display stop script  "/usr/share/sddm/scripts/Xstop"
    Aug 08 17:20:38 linux-ka5p sddm[2213]: Removing display ":0" ...
    Aug 08 17:20:38 linux-ka5p sddm[2213]: Adding new display on vt 7 ...
    Aug 08 17:20:38 linux-ka5p sddm[2213]: Loading theme configuration from ""
    Aug 08 17:20:38 linux-ka5p sddm[2213]: Display server starting...
    Aug 08 17:20:38 linux-ka5p sddm[2213]: Running: /usr/bin/X -nolisten tcp -auth /run/sddm/{85d6d97d-0db4-4511-b508-2f5d4d26f05e} -background none -noreset -displayfd 18 -seat seat0 vt7
    Aug 08 17:20:40 linux-ka5p sddm[2213]: Setting default cursor
    Aug 08 17:20:40 linux-ka5p sddm[2213]: Running display setup script  "/etc/X11/xdm/Xsetup"
    Aug 08 17:20:40 linux-ka5p sddm[2213]: Display server started.
    Aug 08 17:20:40 linux-ka5p sddm[2213]: Socket server starting...
    Aug 08 17:20:40 linux-ka5p sddm[2213]: Socket server started.
    Aug 08 17:20:40 linux-ka5p sddm[2213]: Loading theme configuration from "/usr/share/sddm/themes/breeze-openSUSE/theme.conf"
    Aug 08 17:20:40 linux-ka5p sddm[2213]: Greeter starting...
    Aug 08 17:20:42 linux-ka5p sddm-helper[3336]: [PAM] Starting...
    Aug 08 17:20:42 linux-ka5p sddm-helper[3336]: [PAM] Authenticating...
    Aug 08 17:20:42 linux-ka5p sddm-helper[3336]: [PAM] returning.
    Aug 08 17:20:44 linux-ka5p sddm[2213]: Display server stopped.
    Aug 08 17:20:44 linux-ka5p sddm[2213]: Running display stop script  "/usr/share/sddm/scripts/Xstop"
    Aug 08 17:20:44 linux-ka5p sddm[2213]: Socket server stopping...
    Aug 08 17:20:44 linux-ka5p sddm[2213]: Socket server stopped.
    Aug 08 17:20:44 linux-ka5p sddm[2213]: Removing display ":0" ...
    Aug 08 17:20:44 linux-ka5p sddm[2213]: Adding new display on vt 7 ...
    Aug 08 17:20:44 linux-ka5p sddm[2213]: Loading theme configuration from ""
    Aug 08 17:20:44 linux-ka5p sddm[2213]: Display server starting...
    Aug 08 17:20:44 linux-ka5p sddm[2213]: Running: /usr/bin/X -nolisten tcp -auth /run/sddm/{0bab670c-56d6-45b4-9602-604a7aa596e7} -background none -noreset -displayfd 20 -seat seat0 vt7
    Aug 08 17:20:47 linux-ka5p sddm[2213]: Setting default cursor
    Aug 08 17:20:47 linux-ka5p sddm[2213]: Running display setup script  "/etc/X11/xdm/Xsetup"
    Aug 08 17:20:47 linux-ka5p sddm[2213]: Display server started.
    Aug 08 17:20:47 linux-ka5p sddm[2213]: Socket server starting...
    Aug 08 17:20:47 linux-ka5p sddm[2213]: Socket server started.
    Aug 08 17:20:47 linux-ka5p sddm[2213]: Loading theme configuration from "/usr/share/sddm/themes/breeze-openSUSE/theme.conf"
    Aug 08 17:20:47 linux-ka5p sddm[2213]: Greeter starting...
    Aug 08 17:20:47 linux-ka5p sddm[2213]: QProcess: Destroyed while process ("/usr/lib/sddm/sddm-helper") is still running.
    Aug 08 17:20:48 linux-ka5p sddm-helper[3365]: [PAM] Starting...
    Aug 08 17:20:48 linux-ka5p sddm-helper[3365]: [PAM] Authenticating...
    Aug 08 17:20:48 linux-ka5p sddm-helper[3365]: [PAM] returning.
    Aug 08 17:20:53 linux-ka5p sddm[2213]: Greeter session started successfully
    Aug 08 17:20:58 linux-ka5p sddm[2213]: Message received from greeter: Connect
    Aug 08 17:21:22 linux-ka5p sddm[2213]: Message received from greeter: Login
    
    Kill plams wayland and login to IceMW
    
    
    Aug 08 17:21:44 linux-ka5p sddm[2213]: Reading from "/usr/share/xsessions/icewm.desktop"
    Aug 08 17:21:44 linux-ka5p sddm[2213]: Reading from "/usr/share/xsessions/icewm.desktop"
    Aug 08 17:21:44 linux-ka5p sddm[2213]: Session "/usr/share/xsessions/icewm.desktop" selected, command: "icewm-session"
    Aug 08 17:21:45 linux-ka5p sddm-helper[3435]: [PAM] Starting...
    Aug 08 17:21:45 linux-ka5p sddm-helper[3435]: [PAM] Authenticating...
    Aug 08 17:21:45 linux-ka5p sddm-helper[3435]: [PAM] Preparing to converse...
    Aug 08 17:21:45 linux-ka5p sddm-helper[3435]: [PAM] Conversation with 1 messages
    Aug 08 17:21:45 linux-ka5p sddm-helper[3435]: [PAM] returning.
    Aug 08 17:21:45 linux-ka5p sddm[2213]: Authenticated successfully
    Aug 08 17:21:45 linux-ka5p sddm[2213]: Auth: sddm-helper exited successfully
    Aug 08 17:21:45 linux-ka5p sddm[2213]: Greeter stopped.
    Aug 08 17:21:46 linux-ka5p sddm[2213]: Session started
    Aug 08 17:23:15 linux-ka5p sddm[2213]: Auth: sddm-helper exited successfully
    Aug 08 17:23:15 linux-ka5p sddm[2213]: Socket server stopping...
    Aug 08 17:23:15 linux-ka5p sddm[2213]: Socket server stopped.
    Aug 08 17:23:15 linux-ka5p sddm[2213]: Display server stopping...
    Aug 08 17:23:15 linux-ka5p sddm[2213]: Display server stopped.
    Aug 08 17:23:15 linux-ka5p sddm[2213]: Running display stop script  "/usr/share/sddm/scripts/Xstop"
    Aug 08 17:23:15 linux-ka5p sddm[2213]: Removing display ":0" ...
    Aug 08 17:23:15 linux-ka5p sddm[2213]: Adding new display on vt 7 ...
    Aug 08 17:23:15 linux-ka5p sddm[2213]: Loading theme configuration from ""
    Aug 08 17:23:15 linux-ka5p sddm[2213]: Display server starting...
    Aug 08 17:23:15 linux-ka5p sddm[2213]: Running: /usr/bin/X -nolisten tcp -auth /run/sddm/{8778d93e-5de6-411b-966d-d79d549f09cb} -background none -noreset -displayfd 17 -seat seat0 vt7
    Aug 08 17:23:16 linux-ka5p sddm[2213]: Setting default cursor
    Aug 08 17:23:16 linux-ka5p sddm[2213]: Running display setup script  "/etc/X11/xdm/Xsetup"
    Aug 08 17:23:17 linux-ka5p sddm[2213]: Display server started.
    Aug 08 17:23:17 linux-ka5p sddm[2213]: Socket server starting...
    Aug 08 17:23:17 linux-ka5p sddm[2213]: Socket server started.
    Aug 08 17:23:17 linux-ka5p sddm[2213]: Loading theme configuration from "/usr/share/sddm/themes/breeze-openSUSE/theme.conf"
    Aug 08 17:23:17 linux-ka5p sddm[2213]: Greeter starting...
    Aug 08 17:23:17 linux-ka5p sddm-helper[4743]: [PAM] Starting...
    Aug 08 17:23:17 linux-ka5p sddm-helper[4743]: [PAM] Authenticating...
    Aug 08 17:23:17 linux-ka5p sddm-helper[4743]: [PAM] returning.
    Aug 08 17:23:17 linux-ka5p sddm-helper[4743]: pam_unix(sddm-greeter:session): session opened for user sddm(uid=454) by (uid=0)
    Aug 08 17:23:17 linux-ka5p sddm[2213]: Greeter session started successfully
    Aug 08 17:23:19 linux-ka5p sddm[2213]: Message received from greeter: Connect
    Aug 08 17:23:41 linux-ka5p sddm[2213]: Message received from greeter: Login
    
    
    logout of IceWM and into Plasma (plain, no wayland)
    
    
    Aug 08 17:23:41 linux-ka5p sddm[2213]: Reading from "/usr/share/xsessions/plasma5.desktop"
    Aug 08 17:23:41 linux-ka5p sddm[2213]: Reading from "/usr/share/xsessions/plasma5.desktop"
    Aug 08 17:23:41 linux-ka5p sddm[2213]: Session "/usr/share/xsessions/plasma5.desktop" selected, command: "/usr/bin/startplasma-x11"
    Aug 08 17:23:41 linux-ka5p sddm-helper[4773]: [PAM] Starting...
    Aug 08 17:23:41 linux-ka5p sddm-helper[4773]: [PAM] Authenticating...
    Aug 08 17:23:41 linux-ka5p sddm-helper[4773]: [PAM] Preparing to converse...
    Aug 08 17:23:41 linux-ka5p sddm-helper[4773]: [PAM] Conversation with 1 messages
    Aug 08 17:23:41 linux-ka5p sddm-helper[4773]: [PAM] returning.
    Aug 08 17:23:41 linux-ka5p sddm[2213]: Authenticated successfully
    Aug 08 17:23:41 linux-ka5p sddm[2213]: Auth: sddm-helper exited successfully
    Aug 08 17:23:41 linux-ka5p sddm[2213]: Greeter stopped.
    Aug 08 17:23:42 linux-ka5p sddm-helper[4773]: pam_unix(sddm:session): session opened for user test(uid=1100) by (uid=0)
    Aug 08 17:23:42 linux-ka5p sddm-helper[4773]: Starting: "/etc/X11/xdm/Xsession \"/usr/bin/startplasma-x11\""
    Aug 08 17:23:42 linux-ka5p sddm[2213]: Session started

  2. #2
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,327

    Default Re: Plasma desktop black screen with cursor only after update to kernel 5.7

    No such problem on either of my Haswells, but their TWs are running only KDE3. Fedora 33/Rawhide on Xorg after logging in on SDDM never completes starting a Plasma 5.73 desktop, only succeeding to reopen Konsole, which I normally keep open on session exit, leaving the whole rest of the screen black. Each right click on desktop opens a context menu, but any click in one is ignored, and focusing back into Konsole doesn't clear any of the popups. Alt-F2 works as expected, other than being half hidden by the Konsole window. Double clicking the Konsole titlebar toggles fullscreen without clearing the windowed Konsole.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.1,TW,15.2 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&15.1 on 965P/Radeon
    Tertiary: TW,15.2,15.1,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  3. #3

    Default Re: Plasma desktop black screen with cursor only after update to kernel 5.7

    Quote Originally Posted by mrmazda View Post
    No such problem on either of my Haswells, but their TWs are running only KDE3. Fedora 33/Rawhide on Xorg after logging in on SDDM never completes starting a Plasma 5.73 desktop, only succeeding to reopen Konsole, which I normally keep open on session exit, leaving the whole rest of the screen black. Each right click on desktop opens a context menu, but any click in one is ignored, and focusing back into Konsole doesn't clear any of the popups. Alt-F2 works as expected, other than being half hidden by the Konsole window. Double clicking the Konsole titlebar toggles fullscreen without clearing the windowed Konsole.
    mrmazda - thanks for info on your Haswells running only KDE3. I have now tested KDE3 on my box and KDE desktop is working (mostly). The session starts and looks normal but with use display still seems less than optimal with lines and empty boxes in some cases.

    My experience with Plasma 5.72 (no Wayland) is very similar to what you see on Fedora 33/Rawhide on SDDM - never completes starting a Plasma session. For me the whole screen is black. Right click on desktop opens a context menu, but click inside one is ignored, and focusing elsewhere doesn't clear any of the popups. Alt-F2 DOES NOT work as expected for me.

    In the case of Plasma (Wayland) or Plasma (full Wayland) I just get black screen and mouse cursor. Left/right clicks do nothing, Alt-F2 DOES NOT work. I can switch to Vt3 (cntl+alt+F3) or kill X with cntl+alt+backspace but sometimes need to do it more than 2x.

    Suggestions anyone? Or does anyone possibly have an image prior kernel 5.7? Everything was running fine on 5.6.

    Created bug: Bugzilla – Bug 1175033 Black screen with cursor upon login to plasma

  4. #4
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,327

    Default Re: Plasma desktop black screen with cursor only after update to kernel 5.7

    I just sent a private email to OP's B.O.O. email address containing URL to download kernel-default-5.6.14-1.6.x86_64.rpm. My email provider and his do not play nice together, so that email might not reach its destination. Please report here if it shows up, and with what results if tried.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.1,TW,15.2 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&15.1 on 965P/Radeon
    Tertiary: TW,15.2,15.1,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  5. #5
    Join Date
    May 2018
    Location
    Québec city
    Posts
    13

    Default Re: Plasma desktop black screen with cursor only after update to kernel 5.7

    Same symptoms here. I'm on tumbleweed 20200807 too and unable to establish any plasma session. First it disabled the compositor (kwin) and when I try to bring it back by changing the settings, my plasma session abended and I was sent back to login with SDDM. Since then, I can't login with plasma, plasma with wayland or plasma full wayland. With the last 2 It start the session but never finish, it goes forever nowhere.

    I'm actually using "sway" my backup desktop. Please find what's wrong with that update.

    My hardware is :

    System: Host: linux-0rk5 Kernel: 5.7.11-1-default x86_64 bits: 64 Desktop: sway 1.5 Distro: openSUSE Tumbleweed 20200807Machine: Type: Laptop System: Hewlett-Packard product: HP Pavilion g6 Notebook PC v: 0593110000204610000620100
    Mobo: Hewlett-Packard model: 169B v: KBC Version 18.0D BIOS: Hewlett-Packard
    v: F.34 date: 08/16/2011
    CPU: Topology: Quad Core model: AMD A6-3400M APU with Radeon HD Graphics bits: 64 type: MCP L2 cache: 4096 KiB
    Speed: 802 MHz min/max: 800/1400 MHz Core speeds (MHz): 1: 802 2: 802 3: 1761 4: 803
    Graphics: Device-1: Advanced Micro Devices [AMD/ATI] Sumo [Radeon HD 6520G] driver: radeon v: kernel
    Device-2: Chicony HP Webcam-101 type: USB driver: uvcvideo
    Display: wayland server: X.Org 1.20.8 compositor: sway driver: radeon FAILED: ati unloaded: fbdev,modesetting,vesa
    resolution: 1366x768~60Hz
    OpenGL: renderer: AMD SUMO (DRM 2.50.0 / 5.7.11-1-default LLVM 10.0.0) v: 3.3 Mesa 20.1.4

    Regards,
    BT

  6. #6

    Default Re: Plasma desktop black screen with cursor only after update to kernel 5.7

    Quote Originally Posted by mrmazda View Post
    I just sent a private email to OP's B.O.O. email address containing URL to download kernel-default-5.6.14-1.6.x86_64.rpm. My email provider and his do not play nice together, so that email might not reach its destination. Please report here if it shows up, and with what results if tried.
    Thanks! Your mail went to spam but I was able to recover it and download kernel-default-5.6.14-1.6.x86_64.rpm from the link (before the message mysteriously disappeared completely). After installing and booting with this kernel everything is working as expected. DM greeter login screen behaves normally and I am able to initiate Plasma (Wayland) session. Clearly something got broken in 5.7, 5.8 kernel. Also added this info to the bug report. Maybe this should be classified under kernel rather than application/Plasma. I'm glad to be up and running on 5.6.14-1.6 for the moment! Kinda wish tumbleweed would archive kernel for a few releases rather than just vaporizing everything. Anyways - THANK YOU mrmazda!

  7. #7
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,327

    Default Re: Plasma desktop black screen with cursor only after update to kernel 5.7

    These symptoms don't have anything to do with Haswell, or SDDM, or Intel vs Radeon GPU, or specific vs modesetting DDX. As follows
    Code:
    # inxi -C
    CPU:       Topology: Dual Core model: Intel Core2 6700 bits: 64 type: MCP L2 cache: 4096 KiB
               Speed: 1600 MHz min/max: 1596/2660 MHz Core speeds (MHz): 1: 1600 2: 1600
    # inxi -SGxx
    System:    Host: fi965 Kernel: 5.6.14-1-default x86_64 bits: 64 compiler: gcc v: 10.1.1 Desktop: KDE Plasma 5.19.4
               tk: Qt 5.15.0 wm: kwin_x11 dm: <KDM3> Distro: openSUSE Tumbleweed 20200807
    Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Oland [Radeon HD 8570 / R7 240/340 / Radeon 520 OEM] vendor: Dell
               driver: radeon v: kernel bus ID: 01:00.0 chip ID: 1002:6611
               Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: modesetting resolution: 1: 2560x1440~60Hz
               2: 1920x1200~60Hz s-dpi: 120
               OpenGL: renderer: AMD OLAND (DRM 2.50.0 5.6.14-1-default LLVM 10.0.0) v: 4.5 Mesa 20.1.4 direct render: Yes
    behavior is fully acceptable. When I instead boot 5.7.11, same bad symptoms I describe in comment 2 for Fedora appear, similar to symptoms described here by others. Disabling compositing makes a significant apparent improvement booted to 5.7.11.

    Thread beginning https://lists.opensuse.org/opensuse/.../msg00097.html seems possibly to be similar issue, but on Leap 15.2, which uses "5.3" kernel (with what backports from 5.7 kernel???).
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.1,TW,15.2 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&15.1 on 965P/Radeon
    Tertiary: TW,15.2,15.1,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  8. #8
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,327

    Default Re: Plasma desktop black screen with cursor only after update to kernel 5.7

    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.1,TW,15.2 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&15.1 on 965P/Radeon
    Tertiary: TW,15.2,15.1,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  9. #9

    Default Re: Plasma desktop black screen with cursor only after update to kernel 5.7

    Quote Originally Posted by mrmazda View Post
    These symptoms don't have anything to do with Haswell, or SDDM, or Intel vs Radeon GPU, or specific vs modesetting DDX. As follows
    Code:
    # inxi -C
    CPU:       Topology: Dual Core model: Intel Core2 6700 bits: 64 type: MCP L2 cache: 4096 KiB
               Speed: 1600 MHz min/max: 1596/2660 MHz Core speeds (MHz): 1: 1600 2: 1600
    # inxi -SGxx
    System:    Host: fi965 Kernel: 5.6.14-1-default x86_64 bits: 64 compiler: gcc v: 10.1.1 Desktop: KDE Plasma 5.19.4
               tk: Qt 5.15.0 wm: kwin_x11 dm: <KDM3> Distro: openSUSE Tumbleweed 20200807
    Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Oland [Radeon HD 8570 / R7 240/340 / Radeon 520 OEM] vendor: Dell
               driver: radeon v: kernel bus ID: 01:00.0 chip ID: 1002:6611
               Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: modesetting resolution: 1: 2560x1440~60Hz
               2: 1920x1200~60Hz s-dpi: 120
               OpenGL: renderer: AMD OLAND (DRM 2.50.0 5.6.14-1-default LLVM 10.0.0) v: 4.5 Mesa 20.1.4 direct render: Yes
    behavior is fully acceptable. When I instead boot 5.7.11, same bad symptoms I describe in comment 2 for Fedora appear, similar to symptoms described here by others. Disabling compositing makes a significant apparent improvement booted to 5.7.11.

    Thread beginning https://lists.opensuse.org/opensuse/.../msg00097.html seems possibly to be similar issue, but on Leap 15.2, which uses "5.3" kernel (with what backports from 5.7 kernel???).
    No problems on my worksation with Nvidia quadro using proprietary 400 series driver. Everything works perfectly with compositing enabled or disabled:

    Code:
     #inxi -C              CPU:       Topology: 6-Core model: AMD Phenom II X6 1055T bits: 64 type: MCP L2 cache: 3072 KiB  
    Speed: 1170 MHz min/max: 800/2800 MHz Core speeds (MHz):1: 1170 2: 1280 3: 1033 4: 1320 5: 2669 6: 980  
    valhalla:/home/ej 
    
    # inxi -SGxx
    System:    Host: valhalla Kernel: 5.7.11-1-default x86_64 bits: 64 compiler: gcc v: 10.2.1 Desktop: KDE Plasma 5.19.4  
    tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: openSUSE Tumbleweed 20200807  
    Graphics:  Device-1: NVIDIA GK107GL [Quadro K2000] vendor: Hewlett-Packard driver: nvidia v: 450.57 bus ID: 06:00.0  
    chip ID: 10de:0ffe  
    Display: x11 server: X.org 1.20.8 compositor: kwin_x11 driver: nvidia resolution: <xdpyinfo missing>  
    OpenGL:renderer: Quadro K2000/PCIe/SSE2 v: 4.6.0 NVIDIA 450.57 direct render: Yes

  10. #10
    Join Date
    May 2018
    Location
    Québec city
    Posts
    13

    Default Re: Plasma desktop black screen with cursor only after update to kernel 5.7

    I can now log into regular plasma session since update to kernel 5.8.0-1 with Tumbleweed 20200810.

    but not plasma(Wayland) nor plasma(Full Wayland).

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •