In my dmesg output, I see

Code:
[   11.896435] bluetooth hci0: Direct firmware load for brcm/BCM20702A1-0a5c-21e6.hcd failed with error -2 
[   11.896438] Bluetooth: hci0: BCM: Patch brcm/BCM20702A1-0a5c-21e6.hcd not found
and searching around (e.g. https://forums.opensuse.org/showthre...s-disappearing), I found out that this file (and others) is provided by the bcm20702a1-firmware-1201650-5.1.noarch package. I looked in /lib/firmware/brcm:

Code:
$ ls /lib/firmware/brcm/BCM* 
/lib/firmware/brcm/BCM-0bb4-0306.hcd.xz
and sure enough, the files aren't there.

Figuring that something went wrong when the package was installed, I tried to reinstall it:

Code:
# zypper in -f bcm20702a1-firmware-1201650-5.1.noarch
It looks like it's successful - the output ends with

Code:
Converting BCM_DriverOnly/64/BCM20702A1_001.002.014.1443.1467.hex to BCM20702A1-0b05-17cb.hcd 
Converting BCM_DriverOnly/64/BCM20702A1_001.002.014.1443.1469.hex to BCM20702A1-0b05-17cf.hcd 
Converting BCM_DriverOnly/64/BCM20702A1_001.002.014.1483.1647.hex to BCM20702A1-05ac-21e1.hcd 
Converting BCM_DriverOnly/64/BCM20702A1_001.002.014.1483.1669.hex to BCM20702A1-0a5c-21e6.hcd 
Converting BCM_DriverOnly/64/BCM20702A1_001.002.014.1443.1467.hex to BCM20702A1-050d-065a.hcd
but the files are still not present in /lib/firmware/brcm. Is there something else I need to do to put them there? I'd have thought installing the package would do that.

Thanks!