OpenSUSE have Yast2 and zypper. As far as I remember, Yast2 allows for user intervention. PackageKit have had problems with it. To solve it, I started DaemonUI. DaemonUI uses Bonsole. Bonsole sources are on sourceforge.net . Read this topic: https://github.com/hughsie/PackageKit/issues/415 . Question is: how to do/cause dependency problem?