Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Nvidia proprietary driver doesn't work (GeForce GT 640)

  1. #1

    Default Nvidia proprietary driver doesn't work (GeForce GT 640)

    I did a clean install of opensuse 15.2 today and found the nvidia proprietary drivers from the nvidia repo doesn't work.

    I tried both the G04 and the G05 driver, but the result is the same: my screen resolution seems to be very low (images and fonts are extremely large, both in KDE and in KDM greeter). As soon as I remove the nvidia propietary driver, resolution is ok again.

    Can someone point me in the right direction how to get the proprietary driver working? Until yesterday I was running opensuse 42.3 with proprietary driver and with the same graphics card without any problem.

  2. #2

    Default Re: Nvidia proprietary driver doesn't work (GeForce GT 640)

    https://forums.opensuse.org/showthre...33#post2948833

    For GF116 chip you need G04 driver.

  3. #3

    Default Re: Nvidia proprietary driver doesn't work (GeForce GT 640)

    Quote Originally Posted by Svyatko View Post
    https://forums.opensuse.org/showthre...33#post2948833

    For GF116 chip you need G04 driver.
    Well I tried both G04 and G05, both with same result.

    My desktop looks exactly like this one:

    https://forums.opensuse.org/showthre...indows-toolbar

  4. #4

    Default Re: Nvidia proprietary driver doesn't work (GeForce GT 640)

    Some extra info: output of inxi command

    Code:
    inxi -SGxxz
    System:
      Kernel: 5.3.18-lp152.33-default x86_64 bits: 64 
      compiler: gcc v: 7.5.0 Desktop: KDE Plasma 5.18.5 
      tk: Qt 5.12.7 wm: kwin_x11 dm: SDDM 
      Distro: openSUSE Leap 15.2 
    Graphics:
      Device-1: NVIDIA GK107 [GeForce GT 640] 
      vendor: Micro-Star MSI driver: nvidia v: 390.138 
      bus ID: 01:00.0 chip ID: 10de:0fc1 
      Display: x11 server: X.Org 1.20.3 compositor: kwin_x11 
      driver: nvidia unloaded: fbdev,modesetting,nouveau,nv,vesa 
      resolution: 1680x1050~60Hz s-dpi: 267 
      OpenGL: renderer: GeForce GT 640/PCIe/SSE2 
      v: 4.6.0 NVIDIA 390.138 direct render: Yes

  5. #5
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,328

    Default Re: Nvidia proprietary driver doesn't work (GeForce GT 640)

    Quote Originally Posted by suskewiet2 View Post
    ...
    Code:
    Graphics:
      Device-1: NVIDIA GK107 [GeForce GT 640] 
    ...
      resolution: 1680x1050~60Hz s-dpi: 267
    267 on a 1680x1050 screen would only be appropriate if the screen was extremely tiny. Can you try the possible solution proposed in https://forums.opensuse.org/showthre...38#post2952838 ?
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.1,TW,15.2 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&15.1 on 965P/Radeon
    Tertiary: TW,15.2,15.1,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  6. #6

    Default Re: Nvidia proprietary driver doesn't work (GeForce GT 640)

    I also found this in /var/log/Xorg.0.log:

    Code:
    [    27.422] (==) NVIDIA(0):
    [    27.422] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
    [    27.422] (==) NVIDIA(0):     will be used as the requested mode.
    [    27.423] (==) NVIDIA(0):
    [    27.423] (II) NVIDIA(0): Validated MetaModes:
    [    27.423] (II) NVIDIA(0):     "DFP-1:nvidia-auto-select"
    [    27.423] (II) NVIDIA(0): Virtual screen size determined to be 1680 x 1050
    [    27.430] (--) NVIDIA(0): DPI set to (266, 296); computed from "UseEdidDpi" X config
    [    27.430] (--) NVIDIA(0):     option
    Maybe the DPI is the problem. How can I set it to a lower value? I tried with uncommenting the monitor section in /etc/X11/xorg.conf.d/50-monitor.conf and adding two options:

    Code:
    Section "Monitor"
      Identifier "Default Monitor"
    #
    #  ## If your monitor doesn't support DDC you may override the
    #  ## defaults here
    #  #HorizSync 28-85
    #  #VertRefresh 50-100
    #
    #  ## Add your mode lines here, use e.g the cvt tool
    #
    
    Option "DPI" "96 x 96"
    Option "UseEdidDpi" "False"
    
    EndSection
    But after reboot xorg.0.log still contains:

    Code:
    [    27.645] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
    [    27.645] (==) NVIDIA(0):     will be used as the requested mode.
    [    27.645] (==) NVIDIA(0): 
    [    27.645] (II) NVIDIA(0): Validated MetaModes:
    [    27.645] (II) NVIDIA(0):     "DFP-1:nvidia-auto-select"
    [    27.645] (II) NVIDIA(0): Virtual screen size determined to be 1680 x 1050
    [    27.653] (--) NVIDIA(0): DPI set to (266, 296); computed from "UseEdidDpi" X config
    [    27.653] (--) NVIDIA(0):     option
    PS. I don't have an /etc/X11/xorg.conf file

  7. #7
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,328

    Default Re: Nvidia proprietary driver doesn't work (GeForce GT 640)

    Please do
    Code:
    susepaste -n suskewiet2 /var/log/Xorg.0.log
    and provide the resulting URL here. If it produces a failure message, goto https://paste.opensuse.org/lists and you'll probably see yours listed anyway. We almost certainly need to see the whole log.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.1,TW,15.2 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&15.1 on 965P/Radeon
    Tertiary: TW,15.2,15.1,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  8. #8

    Default Re: Nvidia proprietary driver doesn't work (GeForce GT 640)


  9. #9
    Join Date
    Aug 2020
    Location
    Lyon, France
    Posts
    8

    Default Re: Nvidia proprietary driver doesn't work (GeForce GT 640)

    Hi @suskewiet2

    If you force the DPI font value to 96 in the Fonts menu of the KDE system configuration (last option of the Fonts menu), does it improve or solve your issue ?
    It just worked for me.

    Hope it helps.

  10. #10
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,328

    Default Re: Nvidia proprietary driver doesn't work (GeForce GT 640)

    Quote Originally Posted by suskewiet2 View Post
    This apparently expired before I could open it. I get a not found error trying now.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.1,TW,15.2 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&15.1 on 965P/Radeon
    Tertiary: TW,15.2,15.1,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •