Results 1 to 6 of 6

Thread: Sound recording problems

  1. #1

    Default Sound recording problems

    Greetings All

    I am trying to utilize AUDACITY to capture input from the Line-In connection of the computer.
    Unfortunately, this has been an exercise in futility.

    Problem 1:
    In spite of the fact that the PulseAudio Volume Control shows a 'monitor',
    I have been unable to get the output to include what is coming in to the Line-In plug.

    Problem 2:
    The adjustment of the 'input' level using PulseAudio Volume Control behaves in a weird manner.
    Increasing the volume slightly results in an almost instant indication of the signal going to maximum.
    Returning the signal to 'silence' takes about a minute for the meter to respond: It seems to be doing it in small steps...

    Problem 3:
    When I attempt to record what is coming in on the Line-In plug using AUDACITY,
    the recording is made with some sort of strange compression: 1 minute of sound results in 1 second of recorded media.
    If I disconnect the plug into the line-in, or select the Mic-in (not connected), AUDACITY will record at a normal rate,
    although there is no sound to record...

    If PulseAudio is disabled using setup-pulseaduio --disable, AUDACITY can record normally.
    I can even monitor the input (using ALSAMIXER).
    However, any attempts to play what was recorded (or any other audio file) returns an error message about the ALSA host being down.
    No media files can be played until PulseAudio is enabled again.
    A reboot also appears to be needed to make --disable or --enable take affect.

    I've even tried a clean install WITHOUT PulseAudio, but I still get the message:
    'ALSA error:snd_pcm_open failed:Host is down'
    when attempting to play any media unless PulseAudio is installed and enabled.

    It would be nice to eliminate PulseAudio altogether, but there appears to be some additional magic that is needed to do so.

    Any suggestions or advice would be greatly appreciated

    Suse level is 15.2. Hardware:AMD Ryzen/Asus X370 Prime Motherboard.

    Richard Rosa

    >pactl stat
    Currently in use: 16 blocks containing 88.0 KiB bytes total.
    Allocated during whole lifetime: 1757 blocks containing 3.0 MiB bytes total.
    Sample cache size: 0 B
    >pactl info
    Server String: /run/user/1000/pulse/native
    Library Protocol Version: 33
    Server Protocol Version: 33
    Is Local: yes
    Client Index: 7
    Tile Size: 65472
    Server Name: pulseaudio
    Server Version: 13.0-rebootstrapped
    Default Sample Specification: s16le 2ch 44100Hz
    Default Channel Map: front-left,front-right
    Default Sink: alsa_output.pci-0000_0d_00.3.analog-stereo
    Default Source: alsa_input.pci-0000_0d_00.3.analog-stereo
    Cookie: 4473:92fe
    >pactl list short
    0       module-device-restore
    1       module-stream-restore
    2       module-card-restore
    3       module-augment-properties
    4       module-switch-on-port-available
    5       module-udev-detect
    6       module-alsa-card        device_id="0" name="pci-0000_0a_00.1" card_name="alsa_card.pci-0000_0a_00.1" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
    7       module-alsa-card        device_id="1" name="pci-0000_0d_00.3" card_name="alsa_card.pci-0000_0d_00.3" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
    8       module-esound-protocol-unix
    9       module-native-protocol-unix
    10      module-gsettings
    11      module-zeroconf-discover
    12      module-default-device-restore
    13      module-rescue-streams
    14      module-always-sink
    15      module-intended-roles
    16      module-suspend-on-idle
    17      module-console-kit
    18      module-systemd-login
    19      module-position-event-sounds
    20      module-role-cork
    21      module-filter-heuristics
    22      module-filter-apply
    0       alsa_output.pci-0000_0d_00.3.analog-stereo      module-alsa-card.c      s16le 2ch 44100Hz       IDLE
    0       alsa_output.pci-0000_0d_00.3.analog-stereo.monitor      module-alsa-card.c      s16le 2ch 44100Hz       RUNNING
    1       alsa_input.pci-0000_0d_00.3.analog-stereo       module-alsa-card.c      s16le 2ch 44100Hz       RUNNING
    0       0       4       protocol-native.c       float32le 1ch 25Hz
    1       1       4       protocol-native.c       float32le 1ch 25Hz
    2       0       5       protocol-native.c       float32le 1ch 25Hz
    3       1       5       protocol-native.c       float32le 1ch 25Hz
    0       module-systemd-login.c  (null)
    1       protocol-native.c       pavucontrol
    2       protocol-native.c       palemoon
    3       protocol-native.c       plasmashell
    4       protocol-native.c       pavucontrol
    5       protocol-native.c       pavucontrol
    9       protocol-native.c       pactl
    0       alsa_card.pci-0000_0a_00.1      module-alsa-card.c
    1       alsa_card.pci-0000_0d_00.3      module-alsa-card.c

  2. #2
    Join Date
    Jun 2008
    West Yorkshire, UK

    Default Re: Sound recording problems

    Problem 1: Unless there is some input to Line 1, Pulseaudio will not show it. If you want to monitor what is on Line 1, do it in Audacity.
    Problem 2: Possibly you need to set "flat-volumes = no" in daemon.conf which may be in .config/pulse/ in your /home directory or /etc/pulse/. [Though /etc/pulse/daemon.conf.d/60-disable_flat_volumes.conf is supposed to do this, it did not seem to work; so I added daemon.conf (suitably edited) to .config/pulse/ and it seems to have done the trick.]
    Problem 3: sorry, cannot offer any sugestion for this.

  3. #3

    Default Re: Sound recording problems

    The problems I am facing are definitely due to PulseAudio.
    I suspect that Pulse is unhappy about something in the Motherboard Sound hardware (ASUS with Realtek S1220A).
    Removing Pulse allows me to make recordings with no problem. However, once Pulse is removed,
    there does not appear to be any way to direct a number of applications to send output through ALSA.
    Some apps (such as Audacious) provide the the ability to specify the output device.
    However, others (such as Chrome) appear to only output to whatever default is set (Pulse).

    I have spent the better part of the week (excluding the 24 hours without power)
    trying to find the way to utilize sound WITHOUT pulse.
    I have tried numerous incantations offered from various web sites,
    but none seem to break the spell.
    Suse appears to have firmly wedged PulseAudio between Alsa and my speakers...

    Does anyone have any suggestions on how to utilize the sound system WITHOUT PulseAudio?

    Richard Rosa

  4. #4
    Join Date
    Jun 2008
    West Yorkshire, UK

    Default Re: Sound recording problems

    This recent article ( suggests that you can do away with PulseAudio if you want and rely on ALSA and OSS. Presumably, ALSA will then become the default.
    Last edited by john_hudson; 07-Aug-2020 at 13:47. Reason: Additional comment

  5. #5
    Join Date
    Jun 2008
    Auckland, NZ
    Blog Entries

    Default Re: Sound recording problems

    Last edited by deano_ferrari; 07-Aug-2020 at 15:41.
    openSUSE Leap 15.2; KDE Plasma 5

  6. #6
    Join Date
    Mar 2008
    Phuket, Thailand
    Blog Entries

    Default Re: Sound recording problems

    As a 'work around' rather than totally disabling pulse audio, did you try launching audacity (only) with pulse audio disabled only for that app (audacity)?

    i.e. something like:
    pasuspender -- audacity
    I don't know if that would work, but as a 'work around' its worth a shot. Ultimately thou, you need to sort out why audacity is not recording for you. I suspect a pulse audio misconfiguration somewhere.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts