Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Switching Legacy Leap 15.2 install to UEFI on dual boot with Windows 10

  1. #1

    Default Switching Legacy Leap 15.2 install to UEFI on dual boot with Windows 10

    Hello,
    I have installed Leap 15.2 on a machine with Windows 10 and it appears that it's a Legacy install instead of UEFI because I cannot find a way to boot into Windows 10. When I run the "efibootmgr -v" command in Konsole I get "EFI variables are not supported on this system". Also, boot loader in Yast states GRUB2 under Boot Code Options, "Boot from Master Boot Record" is marked, "Set active Flag in Partition Table for Boot Partition" is marked and "do not change" appears under Protective MBR flag. Is switching to UEFI as simple as changing "GRUB2" to "GRUB2 for EFI" under Boot Loader drop down and clicking OK? I want to proceed with caution here as I don't want to freeze the machine and not be able to log into anything. Any help with fixing this so I can have access to both systems would be greatly appreciated.

    Cheers,

    Kris

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,260
    Blog Entries
    3

    Default Re: Switching Legacy Leap 15.2 install to UEFI on dual boot with Windows 10

    Quote Originally Posted by kp_auburn View Post
    Is switching to UEFI as simple as changing "GRUB2" to "GRUB2 for EFI" under Boot Loader drop down and clicking OK?
    Unfortunately, that will fail, with about the same error message that you got running "efibootmgr".

    To fix this, you first need to be able to boot to UEFI mode.

    Start with the install media. See if you can manage to boot that in UEFI mode. If you can boot it in UEFI mode to the rescue system, then it is fairly easy to switch your system.

    If you no longer have the install media, then try downloading the live Leap 15.2 media. Again, see if you can manage to boot it to UEFI mode. It might require BIOS configuration changes.

    When you are able to boot something (original install media or live media) to UEFI mode, tell us how you did that. And I can give you the next steps to complete your switchover.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

  3. #3

    Default Re: Switching Legacy Leap 15.2 install to UEFI on dual boot with Windows 10

    I still have the install media so I will check if booting in UEFI mode works and I'll report back.
    Thanks so much!

  4. #4
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,772
    Blog Entries
    1

    Default Re: Switching Legacy Leap 15.2 install to UEFI on dual boot with Windows 10

    Quote Originally Posted by kp_auburn View Post
    I want to proceed with caution here as I don't want to freeze the machine and not be able to log into anything. Any help with fixing this so I can have access to both systems would be greatly appreciated.
    Switched all linux systems from legacy bios to uefi some time ago: https://karlmistelberger.wordpress.c...fruehjahsputz/
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

  5. #5

    Default Re: Switching Legacy Leap 15.2 install to UEFI on dual boot with Windows 10

    nrickert
    I started up the computer with the USB installation media inserted, selected Rescue System from the options and I'm now looking at "openSUSE Leap 15.2 Rescue System" and "rescue login:" on the screen. I'm not sure if there is a way to verify if it's booting in UEFI mode at this stage. What are the next steps from here?
    Thank you.

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,260
    Blog Entries
    3

    Default Re: Switching Legacy Leap 15.2 install to UEFI on dual boot with Windows 10

    At the login prompt, you can login as root (password not required).

    Then run the command:
    Code:
    efibootmgr -v
    If you booted with UEFI, you will get a list of boot choices. Otherwise you will get that error message about "efivars".

    Maybe this will make it easier. I did a blog post on installing Leap 15.2. There are images of the installer boot screen, both for legacy booting and for UEFI booting. If you get used to the difference between those, it will be easier to tell how you are booting. Note that you can click on those images to enlarge them, as needed.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

  7. #7

    Default Re: Switching Legacy Leap 15.2 install to UEFI on dual boot with Windows 10

    [QUOTE=nrickert;2951728]At the login prompt, you can login as root (password not required).

    Then run the command:
    Code:
    efibootmgr -v
    If you booted with UEFI, you will get a list of boot choices. Otherwise you will get that error message about "efivars".

    It looks like I booted with UEFI. Picture of the screen with options is attached. https://photos.app.goo.gl/qdUGJWFoeqptpLCg6

    What do you advise from here?

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,260
    Blog Entries
    3

    Default Re: Switching Legacy Leap 15.2 install to UEFI on dual boot with Windows 10

    1: Mount your root partition at "/mnt". It will be something like:
    Code:
    mount /dev/sda3 /mnt
    except that it probably isn't "sda3". I'm assuming that you know which partition is which.

    2: Mount your EFI partition at "/mnt/boot/efi". You might need to first
    Code:
    mkdir /mnt/boot/efi
    if that directory does not exist.

    3: Some bind mounts:
    Code:
    mount --bind /dev /mnt/dev
    mount --bind /sys /mnt/sys
    mount --bind /proc /mnt/proc
    Next we go to "chroot" mode. I'll give the commands needed. Any line that starts with "###" is just my comment, and you need to type that in.
    Code:
    chroot /mnt
    ### this starts a session that see "/mnt" as the root file system
    mount -a
    ### that mounts anything missing.  In particular, it mounts "btrfs" subvolumes.
    yast
    ### this should start a command line "yast" session.  You want to go to the boot loader section
    The command line session is a little awkward to use, but I think you can get it to work.

    Make the changes that you mentioned in your first post in this thread:
    "GRUB2" is changed to "GRUB2 for EFI"

    If there is a box about the protective MBR flag, set that to remove flag.

    Select OK. And you should be done.
    Code:
    exit
    ### exit the chroot session
    shutdown -r now
    ### reboot, and see what happens
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

  9. #9

    Default Re: Switching Legacy Leap 15.2 install to UEFI on dual boot with Windows 10

    Quote Originally Posted by nrickert View Post
    1: Mount your root partition at "/mnt". It will be something like:
    Code:
    mount /dev/sda3 /mnt
    except that it probably isn't "sda3". I'm assuming that you know which partition is which.

    2: Mount your EFI partition at "/mnt/boot/efi". You might need to first
    Code:
    mkdir /mnt/boot/efi
    if that directory does not exist.

    3: Some bind mounts:
    Code:
    mount --bind /dev /mnt/dev
    mount --bind /sys /mnt/sys
    mount --bind /proc /mnt/proc
    Next we go to "chroot" mode. I'll give the commands needed. Any line that starts with "###" is just my comment, and you need to type that in.
    Code:
    chroot /mnt
    ### this starts a session that see "/mnt" as the root file system
    mount -a
    ### that mounts anything missing.  In particular, it mounts "btrfs" subvolumes.
    yast
    ### this should start a command line "yast" session.  You want to go to the boot loader section
    The command line session is a little awkward to use, but I think you can get it to work.

    Make the changes that you mentioned in your first post in this thread:
    "GRUB2" is changed to "GRUB2 for EFI"

    If there is a box about the protective MBR flag, set that to remove flag.

    Select OK. And you should be done.
    Code:
    exit
    ### exit the chroot session
    shutdown -r now
    ### reboot, and see what happens
    ---------------------------------------------------------------------------------------------------------------------

    @nrickert

    Thanks so much for all the instructions above! Below is the plan that I'm going to follow and we'll see if it works. If you are able to take a look at it and see if I missed anything or if anything looks wrong that would be great and feedback is really appreciated.

    My storage devices from Yast partitioner (screenshot): https://photos.app.goo.gl/x4UrvSaxEdv77jM87
    My Current System Device Graph from Yast partitioner (screenshot): https://photos.app.goo.gl/mhzuwtTEjh2ii3CB8

    1. Start system with installation media in UEFI mode
    2. Go to Rescue System
    3. Mount root partition:
    Code:
    mount /dev/sda6 /mnt
    4.
    Code:
    mkdir /mnt/boot/efi
    5.
    Code:
    sda6 /mnt/boot/efi
    6.
    Code:
    mount --bind /dev /mnt/dev
    7.
    Code:
    mount --bind /sys /mnt/sys
    8.
    Code:
    mount --bind proc /mnt/proc
    9.
    Code:
    chroot /mnt
    10.
    Code:
    mount -a
    11.
    Code:
    yast
    12. In Yast Command Line session change GRUB2 to GRUB2 with EFI and clear protective MBR flag box if checked.
    13. Select OK
    14.
    Code:
    exit
    15.
    Code:
    shutdown -r now
    If the above process does not look right to anyone please let me know what changes you recommend.

  10. #10
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,260
    Blog Entries
    3

    Default Re: Switching Legacy Leap 15.2 install to UEFI on dual boot with Windows 10

    Step 5 looks wrong.

    You need to actually mount your EFI partition to "/mnt/boot/efi"

    I don't know which partition that is. It might be "/dev/sda1", in which case you would use
    Code:
    mount /dev/sda1 /mnt/boot/efi
    To identify the EFI partition, you can try
    Code:
    parted -l
    That should list all partitions and the output should tell you which is an EFI partition.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •