Results 1 to 10 of 10

Thread: grass 7.8 from the science package

  1. #1

    Default grass 7.8 from the science package

    Code:
    grass
    Starting GRASS GIS...
    ERROR: wxGUI requires wxPython. No module named 'wx'
    I'm sure I can hack my way around this problem, but how do i contact the maintainer to fix this in the build.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,245

    Default Re: grass 7.8 from the science package

    I see no package names "science" in the OSS (or non-OSS) repo. Thus you probably have got it from another repo. Thus I would start my search for a maintainer by trying to find the maintainer of the repo you used.
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,840
    Blog Entries
    15

    Default Re: grass 7.8 from the science package

    Quote Originally Posted by gariac View Post
    Code:
    grass
    Starting GRASS GIS...
    ERROR: wxGUI requires wxPython. No module named 'wx'
    I'm sure I can hack my way around this problem, but how do i contact the maintainer to fix this in the build.
    Hi
    Since it's built with python3, you need python3-wxPython, I suggest the backports repository;

    https://software.opensuse.org/packag...ython-wxPython
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: grass 7.8 from the science package

    For situations like this that come up often (files missing, not found, unavailable, tec)
    It comes up often enough for every Linux user so I wrote a Wiki article on how to find needed files...

    https://en.opensuse.org/User:Tsu2/Mi...s_Dependencies

    And, of course I understand that your app is installed from the science repository, not science package.
    Please submit a bug to https://bugzilla.opensuse.org so that it can be fixed and others won't run into the same problem.

    HTH,
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,840
    Blog Entries
    15

    Default Re: grass 7.8 from the science package

    Quote Originally Posted by tsu2 View Post
    For situations like this that come up often (files missing, not found, unavailable, tec)
    It comes up often enough for every Linux user so I wrote a Wiki article on how to find needed files...

    https://en.opensuse.org/User:Tsu2/Mi...s_Dependencies

    And, of course I understand that your app is installed from the science repository, not science package.
    Please submit a bug to https://bugzilla.opensuse.org so that it can be fixed and others won't run into the same problem.

    HTH,
    TSU
    Hi
    Just be aware, it's not a packaging bug, the file in question is not in the distribution, and in this case won't get in and has to be obtained from the third party repository...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6

    Default Re: grass 7.8 from the science package

    I did the installation of wxpython. New errors:
    Code:
    grass
    Starting GRASS GIS...
    Traceback (most recent call last):
      File "/usr/lib64/grass78/gui/wxpython/gis_set.py", line 1146, in OnInit
        StartUp = GRASSStartup()
      File "/usr/lib64/grass78/gui/wxpython/gis_set.py", line 224, in __init__
        self._do_layout()
      File "/usr/lib64/grass78/gui/wxpython/gis_set.py", line 399, in _do_layout
        description=self.llocation)
      File "/usr/lib64/grass78/gui/wxpython/gis_set.py", line 376, in layout_list_box
        border=1)
    wx._core.wxAssertionError: C++ assertion "!(flags & wxALIGN_CENTRE_HORIZONTAL)" failed at /home/abuild/rpmbuild/BUILD/wxPython-4.1.0/ext/wxWidgets/src/common/sizer.cpp(2106) in DoInsert(): Horizontal alignment flags are ignored in horizontal sizers
    OnInit returned false, exiting...
    ERROR: Error in GUI startup. See messages above (if any) and if necessary, please report this error to the GRASS developers.
    On systems with package manager, make sure you have the right GUI package, probably named grass-gui, installed.
    To run GRASS GIS in text mode use the --text flag.
    Use '--help' for further options
         grass78 --help
    See also: https://grass.osgeo.org/grass78/manuals/helptext.html
    Exiting...
    Note when you go to the grass.osgeo.org website, they suggest using the geo repo. That has a older rev than science. Both have the same problem.

    Would I be better off just building grass myself? Incidentally grass was working fine on 15.1.

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,840
    Blog Entries
    15

    Default Re: grass 7.8 from the science package

    Quote Originally Posted by gariac View Post
    I did the installation of wxpython. New errors:
    Code:
    grass
    Starting GRASS GIS...
    Traceback (most recent call last):
      File "/usr/lib64/grass78/gui/wxpython/gis_set.py", line 1146, in OnInit
        StartUp = GRASSStartup()
      File "/usr/lib64/grass78/gui/wxpython/gis_set.py", line 224, in __init__
        self._do_layout()
      File "/usr/lib64/grass78/gui/wxpython/gis_set.py", line 399, in _do_layout
        description=self.llocation)
      File "/usr/lib64/grass78/gui/wxpython/gis_set.py", line 376, in layout_list_box
        border=1)
    wx._core.wxAssertionError: C++ assertion "!(flags & wxALIGN_CENTRE_HORIZONTAL)" failed at /home/abuild/rpmbuild/BUILD/wxPython-4.1.0/ext/wxWidgets/src/common/sizer.cpp(2106) in DoInsert(): Horizontal alignment flags are ignored in horizontal sizers
    OnInit returned false, exiting...
    ERROR: Error in GUI startup. See messages above (if any) and if necessary, please report this error to the GRASS developers.
    On systems with package manager, make sure you have the right GUI package, probably named grass-gui, installed.
    To run GRASS GIS in text mode use the --text flag.
    Use '--help' for further options
         grass78 --help
    See also: https://grass.osgeo.org/grass78/manuals/helptext.html
    Exiting...
    Note when you go to the grass.osgeo.org website, they suggest using the geo repo. That has a older rev than science. Both have the same problem.

    Would I be better off just building grass myself? Incidentally grass was working fine on 15.1.
    Hi
    More than likely needs updating if it's old and a bug report to get it updated, or if familiar with the Build Service, branching and updating?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8

    Default Re: grass 7.8 from the science package

    Well for yucks I decided to build grass. Pro tip: don't download the tar file. I didn't find a config file. Using github had the config file.
    https://github.com/OSGeo/grass/
    Second pro tip:
    Code:
    ./configure --with-freetype-includes=/usr/include/freetype2

    So I am running grass7.9. However since I built the binary I should have all the proper libraries for grass 7.8. However I get the previous error message trying to run that binary.

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,840
    Blog Entries
    15

    Default Re: grass 7.8 from the science package

    Quote Originally Posted by gariac View Post
    Well for yucks I decided to build grass. Pro tip: don't download the tar file. I didn't find a config file. Using github had the config file.
    https://github.com/OSGeo/grass/
    Second pro tip:
    Code:
    ./configure --with-freetype-includes=/usr/include/freetype2

    So I am running grass7.9. However since I built the binary I should have all the proper libraries for grass 7.8. However I get the previous error message trying to run that binary.
    Hi
    What is the python2-wxPython version installed, it needs to be =>4.0 AFAIK.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #10

    Default Re: grass 7.8 from the science package

    Quote Originally Posted by malcolmlewis View Post
    Hi
    What is the python2-wxPython version installed, it needs to be =>4.0 AFAIK.
    I have a python3-wxPython. It is 4.1.0.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •