Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Cannot connect to wifi with openSUSE on a Rosewill RNX-AC600NUBv2 USB adapter

  1. #1
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    472

    Default Cannot connect to wifi with openSUSE on a Rosewill RNX-AC600NUBv2 USB adapter

    I cannot connect to wifi with openSUSE on a Rosewill RNX-AC600NUBv2 USB adapter. It is plug and play with Windows 10. It works on one machine with Mint 19.3 and the driver recommended at https://forums.linuxmint.com/viewtop...57446#p1757446.

    On this openSUSE machine (Leap 15.2 KDE) I installed rtl8812AU_8821AU-kmp-default from https://download.opensuse.org/reposi...p_15.2_Update/

    When trying to connect to either our home network or the building wifi, I get two successive pop-up windows asking for the password, then a failure stating "No secrets were provided"
    I get:
    Code:
    howard@HP-oS15KDE:~> lsusb
    Bus 009 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 003: ID 0bda:a811 Realtek Semiconductor Corp. RTL8811AU 802.11a/b/g/n/ac WLAN Adapter
    Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 007 Device 002: ID 058f:9360 Alcor Micro Corp. 8-in-1 Media Card Reader
    Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 006 Device 002: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
    Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 002: ID 051d:0002 American Power Conversion Uninterruptible Power Supply
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 002 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    and
    Code:
    howard@HP-oS15KDE:~> sudo iwconfig; dmesg | grep wlx
    [sudo] password for root: 
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    tun0      no wireless extensions.
    
    wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
              Mode:Managed  Frequency=2.432 GHz  Access Point: Not-Associated   
              Sensitivity:0/0  
              Retry:off   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    howard@HP-oS15KDE:~>
    and
    Code:
    howard@HP-oS15KDE:~> inxi -Nn
    Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 
               IF: eth0 state: up speed: 100 Mbps duplex: full mac: 1c:1b:0d:ab:25:f5 
               Device-2: Realtek RTL8811AU 802.11a/b/g/n/ac WLAN Adapter type: USB driver: rtl8812au 
               IF: wlan0 state: down mac: 00:e0:4c:43:24:d9 
               IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
    howard@HP-oS15KDE:~>
    and
    Code:
    howard@HP-oS15KDE:~> sudo rfkill list
    0: phy0: Wireless LAN
            Soft blocked: no
            Hard blocked: no
    howard@HP-oS15KDE:~>
    Our router uses MAC address filtering, and this device is correctly allowed as shown by the Win10 and Mint connections.
    /etc/NetworkManager/NetworkManager.conf now contains
    Code:
     [device]
     wifi.scan-rand-mac-address=no
    in case that is still lurking in openSUSE.

    What needs to be done to get this connected with openSUSE?

    Thanks,
    Howard
    ThinkPads 310ED, 600E, T23, X41, X60, T61, X201, E550, X390

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,696

    Default AW: Cannot connect to wifi with openSUSE on a Rosewill RNX-AC600NUBv2 USB adapter

    Post:
    Code:
    zypper se -si rtl88
    Code:
    ip a

  3. #3
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    472

    Default Re: AW: Cannot connect to wifi with openSUSE on a Rosewill RNX-AC600NUBv2 USB adapter

    Quote Originally Posted by Sauerland View Post
    Post:
    Code:
    zypper se -si rtl88
    Code:
    ip a
    Code:
    howard@HP-oS15KDE:~> zypper se -si rtl88
    Loading repository data...
    Reading installed packages...
    
    S  | Name                         | Type    | Version                             | Arch   | Repository
    ---+------------------------------+---------+-------------------------------------+--------+-----------
    i+ | rtl8812AU_8821AU-kmp-default | package | 20200719_k5.3.18_lp152.26-lp152.2.1 | x86_64 | Sauerland
    howard@HP-oS15KDE:~>
    and
    Code:
    howard@HP-oS15KDE:~> ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host 
           valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether 1c:1b:0d:ab:25:f5 brd ff:ff:ff:ff:ff:ff
        inet 192.168.1.145/24 brd 192.168.1.255 scope global dynamic noprefixroute eth0
           valid_lft 86116sec preferred_lft 86116sec
        inet6 fe80::c873:5362:458f:178f/64 scope link noprefixroute 
           valid_lft forever preferred_lft forever
    4: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
        link/ether 00:e0:4c:43:24:d9 brd ff:ff:ff:ff:ff:ff
    5: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 100
        link/none 
        inet 184.23.191.89/25 brd 184.23.191.127 scope global noprefixroute tun0
           valid_lft forever preferred_lft forever
        inet6 fe80::4428:bad1:4e9c:9cbb/64 scope link stable-privacy 
           valid_lft forever preferred_lft forever
    howard@HP-oS15KDE:~>
    Howard
    ThinkPads 310ED, 600E, T23, X41, X60, T61, X201, E550, X390

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,369
    Blog Entries
    15

    Default Re: Cannot connect to wifi with openSUSE on a Rosewill RNX-AC600NUBv2 USB adapter

    Hi
    I suspect it's not built for the updated kernel, you need to be using this repo;

    https://download.opensuse.org/reposi...p_15.2_Update/
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,696

    Default AW: Cannot connect to wifi with openSUSE on a Rosewill RNX-AC600NUBv2 USB adapter

    Also you have to disable secure boot in the Bios/UEFI.

  6. #6
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    472

    Default Re: Cannot connect to wifi with openSUSE on a Rosewill RNX-AC600NUBv2 USB adapter

    Quote Originally Posted by malcolmlewis View Post
    Hi
    I suspect it's not built for the updated kernel, you need to be using this repo;

    https://download.opensuse.org/reposi...p_15.2_Update/
    I deleted version 20200719_k5.3.18_lp152.26-lp152.2.1, changed to the above repo, and installed the rtl8812AU_8821AU-kmp-default there. Now I get
    Code:
    howard@HP-oS15KDE:~> zypper se -si rtl88
    Loading repository data...
    Reading installed packages...
    
    S  | Name                         | Type    | Version                             | Arch   | Repository
    ---+------------------------------+---------+-------------------------------------+--------+-----------------
    i+ | rtl8812AU_8821AU-kmp-default | package | 20200719_k5.3.18_lp152.33-lp152.1.2 | x86_64 | Sauerland update
    howard@HP-oS15KDE:~>
    and
    Code:
    howard@HP-oS15KDE:~> ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host 
           valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether 1c:1b:0d:ab:25:f5 brd ff:ff:ff:ff:ff:ff
        inet 192.168.1.145/24 brd 192.168.1.255 scope global dynamic noprefixroute eth0
           valid_lft 86031sec preferred_lft 86031sec
        inet6 fe80::c873:5362:458f:178f/64 scope link noprefixroute 
           valid_lft forever preferred_lft forever
    3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
        link/ether 00:e0:4c:43:24:d9 brd ff:ff:ff:ff:ff:ff
    4: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 100
        link/none 
        inet 184.23.190.239/25 brd 184.23.190.255 scope global noprefixroute tun0
           valid_lft forever preferred_lft forever
        inet6 fe80::e47e:b833:69ae:239b/64 scope link stable-privacy 
           valid_lft forever preferred_lft forever
    howard@HP-oS15KDE:~>
    and
    Code:
    howard@HP-oS15KDE:~> uname -a
    Linux HP-oS15KDE 5.3.18-lp152.33-default #1 SMP Wed Jul 22 06:32:33 UTC 2020 (e5a8383) x86_64 x86_64 x86_64 GNU/Linux
    howard@HP-oS15KDE:~>
    but still no connection. Again, when trying to connect to either our home network or the building wifi, I get two successive pop-up windows asking for the password, then a failure stating "No secrets were provided"
    Thanks,
    Howard
    ThinkPads 310ED, 600E, T23, X41, X60, T61, X201, E550, X390

  7. #7
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    472

    Default Re: AW: Cannot connect to wifi with openSUSE on a Rosewill RNX-AC600NUBv2 USB adapter

    Quote Originally Posted by Sauerland View Post
    Also you have to disable secure boot in the Bios/UEFI.
    This old motherboard does not speak UEFI.
    Regards,
    Howard
    ThinkPads 310ED, 600E, T23, X41, X60, T61, X201, E550, X390

  8. #8
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,696

    Default AW: Cannot connect to wifi with openSUSE on a Rosewill RNX-AC600NUBv2 USB adapter

    Please post as root:
    Code:
    systemctl status network.service

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,696

    Default AW: Cannot connect to wifi with openSUSE on a Rosewill RNX-AC600NUBv2 USB adapter

    And try it without Lan-connection....

  10. #10
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    472

    Default Re: AW: Cannot connect to wifi with openSUSE on a Rosewill RNX-AC600NUBv2 USB adapter

    Quote Originally Posted by Sauerland View Post
    Please post as root:
    Code:
    systemctl status network.service
    Code:
    HP-oS15KDE:/home/howard # systemctl status network.service
    ● NetworkManager.service - Network Manager
       Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
      Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
               └─NetworkManager-ovs.conf
       Active: active (running) since Mon 2020-07-27 09:00:27 PDT; 44min ago
         Docs: man:NetworkManager(8)
     Main PID: 1195 (NetworkManager)
        Tasks: 7
       CGroup: /system.slice/NetworkManager.service
               ├─1195 /usr/sbin/NetworkManager --no-daemon
               ├─3585 /usr/lib/nm-openvpn-service --bus-name org.freedesktop.NetworkManager.openvpn.Connection_11
               └─3588 /usr/sbin/openvpn --remote ovpn.sonic.net 1194 udp --comp-lzo yes --nobind --dev tun --cipher AES-128-CBC --auth-nocache --tls-auth /home/howard/.local/share/ne>
    
    Jul 27 09:11:00 HP-oS15KDE NetworkManager[1195]: <warn>  [1595866260.6574] device (wlan0): Activation: (wifi) association took too long
    Jul 27 09:11:00 HP-oS15KDE NetworkManager[1195]: <info>  [1595866260.6575] device (wlan0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
    Jul 27 09:11:00 HP-oS15KDE NetworkManager[1195]: <warn>  [1595866260.6602] device (wlan0): Activation: (wifi) asking for new secrets
    Jul 27 09:11:00 HP-oS15KDE NetworkManager[1195]: <info>  [1595866260.7261] audit: op="statistics" arg="refresh-rate-ms" pid=2845 uid=1000 result="success"
    Jul 27 09:11:02 HP-oS15KDE NetworkManager[1195]: <warn>  [1595866262.7153] device (wlan0): no secrets: User canceled the secrets request.
    Jul 27 09:11:02 HP-oS15KDE NetworkManager[1195]: <info>  [1595866262.7153] device (wlan0): state change: need-auth -> failed (reason 'no-secrets', sys-iface-state: 'managed')
    Jul 27 09:11:02 HP-oS15KDE NetworkManager[1195]: <warn>  [1595866262.7191] device (wlan0): Activation: failed for connection 'SFTInternet'
    Jul 27 09:11:02 HP-oS15KDE NetworkManager[1195]: <info>  [1595866262.7198] device (wlan0): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
    Jul 27 09:11:06 HP-oS15KDE NetworkManager[1195]: <info>  [1595866266.8667] device (wlan0): supplicant interface state: disconnected -> inactive
    Jul 27 09:11:06 HP-oS15KDE NetworkManager[1195]: <info>  [1595866266.8670] device (p2p-dev-wlan0): supplicant management interface state: disconnected -> inactive
    
    HP-oS15KDE:/home/howard #
    Howard
    ThinkPads 310ED, 600E, T23, X41, X60, T61, X201, E550, X390

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •