Page 1 of 6 123 ... LastLast
Results 1 to 10 of 60

Thread: Leap 15.2. NVIDIA driver does not work

  1. #1

    Default Leap 15.2. NVIDIA driver does not work

    Hello everyone
    My vcard is NVIDIA GF108 [GeForce GT 630]. I’ve installed G04 driver from download.nvidia.com/opensuse/leap/15.2, but it doesn’t work. In NVIDIA Settings I got the following: You do not appear to be using the NVIDIA X driver. Run “nvidia-xconfig” as root.
    But this is followed with OS not to load after reboot, just a black screen with a flashing dash in the left upper corner. I didn’t have any problems with my vcard on all previous SUSE releases. Please give me a hint what can be done about that? Thank you in advance

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,407
    Blog Entries
    15

    Default Re: Leap 15.2. NVIDIA driver does not work

    Quote Originally Posted by blackcatt View Post
    Hello everyone
    My vcard is NVIDIA GF108 [GeForce GT 630]. I’ve installed G04 driver from download.nvidia.com/opensuse/leap/15.2, but it doesn’t work. In NVIDIA Settings I got the following: You do not appear to be using the NVIDIA X driver. Run “nvidia-xconfig” as root.
    But this is followed with OS not to load after reboot, just a black screen with a flashing dash in the left upper corner. I didn’t have any problems with my vcard on all previous SUSE releases. Please give me a hint what can be done about that? Thank you in advance
    Hi
    I would suggest making sure your system is all up to date esp. kernel wise and switch to the G05 driver since your card supports this one. I would also delete the /etc/X11/xorg.conf file created by running the nvidia-xconfig command, this should not be needed. You also need to ensure the nouveau driver isn't present in the output from lsmod.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Leap 15.2. NVIDIA driver does not work

    Malcolm, thank you for the response.
    I no doubt have my OS up-to-date. Then, on previous SUSE releases I used GO4, moreover this driver version was suggested automatically via Nvidia repo now. Do you really think I should try GO5?

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,407
    Blog Entries
    15

    Default Re: Leap 15.2. NVIDIA driver does not work

    Quote Originally Posted by blackcatt View Post
    Malcolm, thank you for the response.
    I no doubt have my OS up-to-date. Then, on previous SUSE releases I used GO4, moreover this driver version was suggested automatically via Nvidia repo now. Do you really think I should try GO5?
    Hi
    Either will (well should) work, but later driver will have additional features/fixes.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: Leap 15.2. NVIDIA driver does not work

    Have just tried G05. Even worse, in it's own way. Meaning after installation, NVIDIA Settings window can't be opened at all. With G04 I could open the Settings window at least. Fortunately removed G05 back.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,407
    Blog Entries
    15

    Default Re: Leap 15.2. NVIDIA driver does not work

    Quote Originally Posted by blackcatt View Post
    Have just tried G05. Even worse, in it's own way. Meaning after installation, NVIDIA Settings window can't be opened at all. With G04 I could open the Settings window at least. Fortunately removed G05 back.
    Hi
    Then something up with your process of installation...... there is no tweaking to do, install and go... are you sure there is no configuration changes down in /etc/X11? Is the nouveau driver blacklisted? Have you rebuild initrd to ensure the nouveau driver is gone?

    https://en.opensuse.org/SDB:NVIDIA_drivers

    Are you running Wayland perhaps? What desktop environment?

    I use the hard way... https://en.opensuse.org/SDB:NVIDIA_the_hard_way

    Miniatures attachées Miniatures attachées Click image for larger version. 

Name:	Screenshot from 2020-07-21 15-26-58.png 
Views:	241 
Size:	281.6 KB 
ID:	913  
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7

    Default Re: Leap 15.2. NVIDIA driver does not work

    Malcolm I have a freshly-installed Leap 15.2, with Mate environment. I guess you could take it as Gnome. While the OS was being installed, I chose "Disagree" with adding nouveau driver so it's not installed now and my OS is actually working without any driver at all.
    All what I've done I added nvidia repo and installed the suggested driver, I haven't corrected anything in Xorg or whatever else. As soon as I'm not much into the stuff.[IMG]/home/mike/Desktop/1.jpg[/IMG]

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,407
    Blog Entries
    15

    Default Re: Leap 15.2. NVIDIA driver does not work

    Quote Originally Posted by blackcatt View Post
    Malcolm I have a freshly-installed Leap 15.2, with Mate environment. I guess you could take it as Gnome. While the OS was being installed, I chose "Disagree" with adding nouveau driver so it's not installed now and my OS is actually working without any driver at all.
    All what I've done I added nvidia repo and installed the suggested driver, I haven't corrected anything in Xorg or whatever else. As soon as I'm not much into the stuff.[IMG]/home/mike/Desktop/1.jpg[/IMG]
    Hi
    The image didn't upload It is likely run the DXX driver, if you install inxi and post the output from;

    Code:
    inxi -SGxxz
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9

    Default Re: Leap 15.2. NVIDIA driver does not work

    Code:
    mike@localhost:~> inxi -SGxxz
    System:
      Kernel: 5.3.18-lp152.26-default x86_64 bits: 64 compiler: gcc v: 7.5.0 
      Desktop: MATE 1.24.0 wm: marco dm: LightDM Distro: openSUSE Leap 15.2 
    Graphics:
      Device-1: NVIDIA GF108 [GeForce GT 630] vendor: ZOTAC driver: nouveau 
      v: kernel bus ID: 01:00.0 chip ID: 10de:0f00 
      Display: x11 server: X.Org 1.20.3 compositor: marco driver: nouveau 
      unloaded: fbdev,modesetting,vesa alternate: nv,nvidia 
      resolution: 1680x1050~60Hz s-dpi: 96 
      OpenGL: renderer: llvmpipe (LLVM 9.0.1 256 bits) v: 3.3 Mesa 19.3.4 
      compat-v: 3.1 direct render: Yes
    Last edited by malcolmlewis; 21-Jul-2020 at 14:13. Reason: Add code tags

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,407
    Blog Entries
    15

    Default Re: Leap 15.2. NVIDIA driver does not work

    Hi
    So it is using the nouveau driver.... What do you want to do?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 1 of 6 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •