Results 1 to 6 of 6

Thread: BIOS error (bug) - ist das Hardware oder Software?

  1. #1
    Join Date
    Mar 2011
    Location
    Germany
    Posts
    34

    Default BIOS error (bug) - ist das Hardware oder Software?

    Hallo ins Forum,
    mit Suse Leap 15.2 betreibe ich einen Barebone von Gibabyte. GB-BKi7(H)A-7500.

    American Megatrend,
    BIOS Version von F5 Build 04/11/2017 angehoben auf F12 Build 05.03.2019.
    ME FW Version 11.6.20.1221 angehoben auf 11.8.60.3561.
    Die Erneuerung tat ich aufgrund der Fehlermeldung 'ACPI BIOS Error (bug)' beim Booten:

    [1.588615] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.SAT0.PRT0._GTF.DSSP], AE_NOT_FOUND (20190703/psargs-330)
    [1.588646] ACPI Error: Aborting method \_SB.PCI0.SAT0.PRT0._GTF due to previous error (AE_NOT_FOUND) (20190703/psparse-531)
    [1.588859] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.SAT0.PRT0._GTF.DSSP], AE_NOT_FOUND (20190703/psargs-330)
    [1.588886] ACPI Error: Aborting method \_SB.PCI0.SAT0.PRT0._GTF due to previous error (AE_NOT_FOUND) (20190703/psparse-531).
    Nach dem update ist diese Bootmeldung weiterhin da und verlangsamt den Prozess.
    Also habe ich bei Gigabyte nachgefragt, was zu tun sei.
    Von dort kommt, dass man für Linux nicht garantiert und ich mir hier weiterhelfen lassen soll.
    Mmh, ist beim Boot an dieser frühen Stelle das Linux eigentlich schon relevant, so dass ich hier richtig bin, oder werde ich der Manege herumgeführt?

  2. #2
    Join Date
    Mar 2011
    Location
    Germany
    Posts
    34

    Default AW: BIOS error (bug) - ist das Hardware oder Software?

    Oh, 80 Zuschauer, aber noch kein Tipp - dann robbe ich mich also weiter vor.
    Ich denke, schaue mal in YaST, ob dort etwas zu finden ist und siehe da:
    acpica = „Werkzeug, um BIOS ACPI Tabellen zu analysieren … nutzt die gleiche Programmierung, die in der ACPI Einbindung des Betriebssystemkerns verwendet wird…“

    Damit ist klar, der arg verkürzte GIGABYTE Hinweis auf das Betriebssystem hat Substanz und ich bin hier richtig.

    Dann sehe ich noch im YaST unter ‚System‘, dass man den ‚Bootloader‘ einrichten kann: Grub-für-EFI und anderes mir Unbekanntes.

    Alternativ habe ich mit Dolphin versucht, die Fehlermeldung zu dechiffrieren, indem ich Textteile suchte von: \_SB.PCI0.SAT0.PRT0._GTF.DSSP.
    Immerhin findet sich GTF im Verzeichnis /usr/share/man/man1
    – wieder mit ACPI - und entpuppt sich als Generalized Timing Formula und hat etwas mit der Bildschirmauflösung / grafischen Xorg Darstellung zu tun – was wiederum sehr gut zur Meldung „Could not resolve symbol“ paßt.

    PCI0 findet sich ebenfalls: /sys/devices - allerdings mit diversen, vermutlich Steuertabellen.

    Aber jetzt bin ich zu tief im Karnickelbau.
    Kann mir jemand weiterhelfen?

  3. #3
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,021

    Default AW: BIOS error (bug) - ist das Hardware oder Software?

    Wie immer:
    Der Hersteller baut Mist und sagt dann es liegt nicht an ihm......

    Such mal nach den Fehlermeldungen im Netz.....

  4. #4
    Join Date
    Mar 2011
    Location
    Germany
    Posts
    34

    Default AW: BIOS error (bug) - ist das Hardware oder Software?

    Wikipedia klärt etwas weiter auf:
    Das Advanced Configuration and Power Interface (ACPI) ... stellt Schnittstellen zur Hardware-Erkennung, Gerätekonfiguration und zur Energieverwaltung zur Verfügung.
    ... Wegen Fehlern in der ACPI-Implementierung vieler Hardwarekomponenten muss das Betriebssystem dieses undokumentierte Verhalten mit verschiedenen Methoden korrigieren.
    Das Betriebssystem Linux gibt sich dem BIOS gegenüber als Windows aus, um den besser getesteten Windows-Modus zu erhalten.

    ACPI ist also ein gutes Suchwort, somit habe ich gesucht nach "ACPI Could not resolve symbol".
    Und in Bugzilla ist tatsächlich auch schon eine Meldung Nr. 204567 - allerdings geschlossen mit dem Hinweis "But this is a BIOS error that we can not fix in Linux kernel."
    Booten ist offenbar eine ziemlich komplizierte Sache und wie im Wiki zu lesen ist, womöglich in Teilen von Microsoft absichtlich so.
    Ich betrachte die Fehlermeldung jetzt als 'Schluckauf', da geht die Zeit drüber.
    Dies hier kann geschlossen werden.

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,021

    Default AW: BIOS error (bug) - ist das Hardware oder Software?

    qed.........

  6. #6

    Default Re: BIOS error (bug) - ist das Hardware oder Software?

    Auch wenn schön zu lesen scheinbar einiges durcheinander gewürfelt.

    Ich lehn mich mal weit aus dem Fenster auf die Gefahr hin raus zu fallen:

    "Could not resolve symbol" heißt grundsätzlich erstmal "Konnte Symbol nicht auflösen" und hat nichts mit Grafik zu tun. "Symbol" ist hier eher als "Bezeichnung" zu verstehen. Die Fehlermeldung sagt also grundsätzlich erstmal nur auf, dass das System etwas "nicht verstanden" hat weil es eine benötige Information nicht finden konnte.

    Dann zerlegen wir mal die "Adresse":

    \_SB - SouthBridge - also der Chipsatz des Boards - schon mal noch sehr viel weiter von irgendwas mit Auflösung und Xorg weg - da das alles wenn dann über die GPU läuft - und die sind heutzutage direkt an die CPU angebunden - vielleicht noch über eine NorthBridge
    PCI0 - als der erste PCI(-E) Kanal des Chipsatzes - meist für solchen Kram wie Laufwerke da die erstmal am wichtigsten vor allem Anderen sind
    SAT0 - da mir sonst nichts einfallen will was mit SAT beginnt würde ich aufgrund des PCI0 mal auf den S-ATA Controller tippen - aha - wir sind also schon mal irgendwo im Bereich Storage - nix mit Xorg
    PRT0 - gut - wieder einfach: Port

    Bis hierhin sind wir also schon mal über die SouthBridge und dem darin enthaltenen PCI-E Controller bis zum ersten Port des S-ATA Controllers gekommen ...

    Was _GTF und DSSP sein sollen habe ich keinen Plan - bei DSSP würde ich noch an sowas wie "digital signal processor" denken - dafür ist es aber ein S zu viel - werfe ich das aber bei Google rein komm ich hier hin: https://debianforum.de/forum/viewtopic.php?t=176193 - und da steht gleich im ersten Code ne ganze menge was von verschiedenen Platten und deren Partionen - also scheine ich bis hierhin ja schon mal gar nicht so falsch zu sein.

    Dann hab ich mal in den von dir angemerkten Bug-Report geguckt - was springt mich an:
    Code:
    ata4.00: configured for UDMA/133<6>[    3.206465] ata1.00: ATA-9: BIWIN SSD, R0123A0, max UDMA/133
    <6>[    3.206470] ata1.00: 468862128 sectors, multi 1: LBA48 NCQ (depth 32), AA
    Noch mehr Krams zum Thema Storage ...

    Scheint alles in allem vermutlich irgend ein Bug entweder im BIOS oder dessen Treiber für den S-ATA Chip zu sein - aber auf jeden Fall irgendwas in Richtung Platten - wie du da auf den Ast mit "Bildschirmauflösung" (das nennt man im Englisch dann übrigens wiederum "resolution" - was auf Deutsch übersetzt "Lösung (eines Problems/Falls)" heißen würde) und Xorg gekommen bist erschließt sich mir absolut nicht.
    Auch muss ich jetzt im Nachgang noch mal bisschen Salz streuen: An einigen Stellen wird ja auch vermerkt: "bist nicht der einzige mit dem Fehler" - und da das aber nicht Reihenweise zu Problemen führt wird wohl die Idee "kannste ignorieren" schon nicht so schlimm sein.

    Erinnert mich grad irgendwie an die eine StarTrek Voyager Folge zum Thema "Selbstdiagnose eine Patienten": Doc zu Seven of Nine: "Wenn Sie wieder Beschwerden haben, konsultieren Sie nicht die Datenbank sondern mich." - Seven drauf: "Aber Sie sind die Datenbank."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •