Results 1 to 5 of 5

Thread: Bluetooth Headset kein Mikrofon

  1. #1

    Default Bluetooth Headset kein Mikrofon

    Hallo,

    ich habe mein Bluetooth-Headset JBLTune110BT unter Opensuse Leap 15.2/KDE angeschlossen. Der Ton wird auch wiedergegeben, das Mikrofon wird jedoch nicht als verfügbares Gerät angezeigt. In den KDE-Systemeinstellungen wird das Headset auch "nur" als Kopfhörer angezeigt.

    Code:
    maik@maik-laptop:~> pacmd list-cards
    3 card(s) available.
        index: 0
            name: <alsa_card.pci-0000_01_00.1>
            driver: <module-alsa-card.c>
            owner module: 6
            properties:
                    alsa.card = "1"
                    alsa.card_name = "HDA ATI HDMI"
                    alsa.long_card_name = "HDA ATI HDMI at 0xf0040000 irq 32"
                    alsa.driver_name = "snd_hda_intel"
                    device.bus_path = "pci-0000:01:00.1"
                    sysfs.path = "/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1"
                    device.bus = "pci"
                    device.vendor.id = "1002"
                    device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
                    device.product.id = "aa68"
                    device.product.name = "Cedar HDMI Audio [Radeon HD 5400/6300/7300 Series]"
                    device.string = "1"
                    device.description = "Cedar HDMI Audio [Radeon HD 5400/6300/7300 Series]"
                    module-udev-detect.discovered = "1"
                    device.icon_name = "audio-card-pci"
            profiles:
                    output:hdmi-stereo: Digital Stereo (HDMI)-Ausgabe (priority 5900, available: no)
                    output:hdmi-surround: Digital Surround 5.1 (HDMI)-Ausgabe (priority 800, available: no)
                    output:hdmi-surround71: Digital Surround 7.1 (HDMI)-Ausgabe (priority 800, available: no)
                    off: Aus (priority 0, available: unknown)
            active profile: <off>
            ports:
                    hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
                            properties:
                                    device.icon_name = "video-display"
        index: 1
            name: <alsa_card.pci-0000_00_1b.0>
            driver: <module-alsa-card.c>
            owner module: 7
            properties:
                    alsa.card = "0"
                    alsa.card_name = "HDA Intel MID"
                    alsa.long_card_name = "HDA Intel MID at 0xf4c00000 irq 31"
                    alsa.driver_name = "snd_hda_intel"
                    device.bus_path = "pci-0000:00:1b.0"
                    sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
                    device.bus = "pci"
                    device.vendor.id = "8086"
                    device.vendor.name = "Intel Corporation"
                    device.product.id = "3b56"
                    device.product.name = "5 Series/3400 Series Chipset High Definition Audio"
                    device.form_factor = "internal"
                    device.string = "0"
                    device.description = "Internes Audio"
                    module-udev-detect.discovered = "1"
                    device.icon_name = "audio-card-pci"
            profiles:
                    input:analog-stereo: Analog Stereo-Eingabe (priority 65, available: unknown)
                    output:analog-stereo: Analog Stereo-Ausgabe (priority 6500, available: unknown)
                    output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6565, available: unknown)
                    off: Aus (priority 0, available: unknown)
            active profile: <output:analog-stereo+input:analog-stereo>
            sinks:
                    alsa_output.pci-0000_00_1b.0.analog-stereo/#0: Internes Audio Analog Stereo
            sources:
                    alsa_output.pci-0000_00_1b.0.analog-stereo.monitor/#0: Monitor of Internes Audio Analog Stereo
                    alsa_input.pci-0000_00_1b.0.analog-stereo/#1: Internes Audio Analog Stereo
            ports:
                    analog-input-internal-mic: Internal Microphone (priority 8900, latency offset 0 usec, available: unknown)
                            properties:
                                    device.icon_name = "audio-input-microphone"
                    analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: no)
                            properties:
                                    device.icon_name = "audio-input-microphone"
                    analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
                            properties:
                                    device.icon_name = "audio-speakers"
                    analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
                            properties:
                                    device.icon_name = "audio-headphones"
        index: 2
            name: <bluez_card.5C_FB_7C_82_B6_89>
            driver: <module-bluez5-device.c>
            owner module: 29
            properties:
                    device.description = "JBL TUNE110BT"
                    device.string = "5C:FB:7C:82:B6:89"
                    device.api = "bluez"
                    device.class = "sound"
                    device.bus = "bluetooth"
                    device.form_factor = "headset"
                    bluez.path = "/org/bluez/hci0/dev_5C_FB_7C_82_B6_89"
                    bluez.class = "0x240404"
                    bluez.alias = "JBL TUNE110BT"
                    device.icon_name = "audio-headset-bluetooth"
                    device.intended_roles = "phone"
            profiles:
                    headset_head_unit: Headset Head Unit (HSP/HFP) (priority 30, available: unknown)
                    a2dp_sink: High Fidelity Playback (A2DP-Ziel) (priority 40, available: unknown)
                    off: Aus (priority 0, available: yes)
            active profile: <a2dp_sink>
            sinks:
                    bluez_sink.5C_FB_7C_82_B6_89.a2dp_sink/#1: JBL TUNE110BT
            sources:
                    bluez_sink.5C_FB_7C_82_B6_89.a2dp_sink.monitor/#2: Monitor of JBL TUNE110BT
            ports:
                    headset-output: Headset (priority 0, latency offset 0 usec, available: unknown)
                            properties:
    
                    headset-input: Headset (priority 0, latency offset 0 usec, available: unknown)
                            properties:
    Wie bekomme ich das Mikrofon zum laufen?

    Unter Windows 10(Dualboot) funktioniert alles ohne Probleme. Der Bluetooth-Adapter und das Headset sind also "kompatibel".

    Gruß
    mairo

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,161

    Default AW: Bluetooth Headset kein Mikrofon

    Kannst du es unter pavucontrol umstellen?
    Oder im alsamixer?

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,881
    Blog Entries
    14

    Default Re: Bluetooth Headset kein Mikrofon

    Quote Originally Posted by mairo View Post
    Hallo,

    ich habe mein Bluetooth-Headset JBLTune110BT unter Opensuse Leap 15.2/KDE angeschlossen. Der Ton wird auch wiedergegeben, das Mikrofon wird jedoch nicht als verfügbares Gerät angezeigt. In den KDE-Systemeinstellungen wird das Headset auch "nur" als Kopfhörer angezeigt.

    Code:
    maik@maik-laptop:~> pacmd list-cards
    3 card(s) available.
        index: 0
            name: <alsa_card.pci-0000_01_00.1>
            driver: <module-alsa-card.c>
            owner module: 6
            properties:
                    alsa.card = "1"
                    alsa.card_name = "HDA ATI HDMI"
                    alsa.long_card_name = "HDA ATI HDMI at 0xf0040000 irq 32"
                    alsa.driver_name = "snd_hda_intel"
                    device.bus_path = "pci-0000:01:00.1"
                    sysfs.path = "/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1"
                    device.bus = "pci"
                    device.vendor.id = "1002"
                    device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
                    device.product.id = "aa68"
                    device.product.name = "Cedar HDMI Audio [Radeon HD 5400/6300/7300 Series]"
                    device.string = "1"
                    device.description = "Cedar HDMI Audio [Radeon HD 5400/6300/7300 Series]"
                    module-udev-detect.discovered = "1"
                    device.icon_name = "audio-card-pci"
            profiles:
                    output:hdmi-stereo: Digital Stereo (HDMI)-Ausgabe (priority 5900, available: no)
                    output:hdmi-surround: Digital Surround 5.1 (HDMI)-Ausgabe (priority 800, available: no)
                    output:hdmi-surround71: Digital Surround 7.1 (HDMI)-Ausgabe (priority 800, available: no)
                    off: Aus (priority 0, available: unknown)
            active profile: <off>
            ports:
                    hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
                            properties:
                                    device.icon_name = "video-display"
        index: 1
            name: <alsa_card.pci-0000_00_1b.0>
            driver: <module-alsa-card.c>
            owner module: 7
            properties:
                    alsa.card = "0"
                    alsa.card_name = "HDA Intel MID"
                    alsa.long_card_name = "HDA Intel MID at 0xf4c00000 irq 31"
                    alsa.driver_name = "snd_hda_intel"
                    device.bus_path = "pci-0000:00:1b.0"
                    sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
                    device.bus = "pci"
                    device.vendor.id = "8086"
                    device.vendor.name = "Intel Corporation"
                    device.product.id = "3b56"
                    device.product.name = "5 Series/3400 Series Chipset High Definition Audio"
                    device.form_factor = "internal"
                    device.string = "0"
                    device.description = "Internes Audio"
                    module-udev-detect.discovered = "1"
                    device.icon_name = "audio-card-pci"
            profiles:
                    input:analog-stereo: Analog Stereo-Eingabe (priority 65, available: unknown)
                    output:analog-stereo: Analog Stereo-Ausgabe (priority 6500, available: unknown)
                    output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6565, available: unknown)
                    off: Aus (priority 0, available: unknown)
            active profile: <output:analog-stereo+input:analog-stereo>
            sinks:
                    alsa_output.pci-0000_00_1b.0.analog-stereo/#0: Internes Audio Analog Stereo
            sources:
                    alsa_output.pci-0000_00_1b.0.analog-stereo.monitor/#0: Monitor of Internes Audio Analog Stereo
                    alsa_input.pci-0000_00_1b.0.analog-stereo/#1: Internes Audio Analog Stereo
            ports:
                    analog-input-internal-mic: Internal Microphone (priority 8900, latency offset 0 usec, available: unknown)
                            properties:
                                    device.icon_name = "audio-input-microphone"
                    analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: no)
                            properties:
                                    device.icon_name = "audio-input-microphone"
                    analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
                            properties:
                                    device.icon_name = "audio-speakers"
                    analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
                            properties:
                                    device.icon_name = "audio-headphones"
        index: 2
            name: <bluez_card.5C_FB_7C_82_B6_89>
            driver: <module-bluez5-device.c>
            owner module: 29
            properties:
                    device.description = "JBL TUNE110BT"
                    device.string = "5C:FB:7C:82:B6:89"
                    device.api = "bluez"
                    device.class = "sound"
                    device.bus = "bluetooth"
                    device.form_factor = "headset"
                    bluez.path = "/org/bluez/hci0/dev_5C_FB_7C_82_B6_89"
                    bluez.class = "0x240404"
                    bluez.alias = "JBL TUNE110BT"
                    device.icon_name = "audio-headset-bluetooth"
                    device.intended_roles = "phone"
            profiles:
                    headset_head_unit: Headset Head Unit (HSP/HFP) (priority 30, available: unknown)
                    a2dp_sink: High Fidelity Playback (A2DP-Ziel) (priority 40, available: unknown)
                    off: Aus (priority 0, available: yes)
            active profile: <a2dp_sink>
            sinks:
                    bluez_sink.5C_FB_7C_82_B6_89.a2dp_sink/#1: JBL TUNE110BT
            sources:
                    bluez_sink.5C_FB_7C_82_B6_89.a2dp_sink.monitor/#2: Monitor of JBL TUNE110BT
            ports:
                    headset-output: Headset (priority 0, latency offset 0 usec, available: unknown)
                            properties:
    
                    headset-input: Headset (priority 0, latency offset 0 usec, available: unknown)
                            properties:
    Wie bekomme ich das Mikrofon zum laufen?

    Unter Windows 10(Dualboot) funktioniert alles ohne Probleme. Der Bluetooth-Adapter und das Headset sind also "kompatibel".

    Gruß
    mairo
    Hab das gleiche Problem, keine definitive Lösung aber:
    Code:
    pacmd set-card-profile 2 headset_head_unit
    soll das in dein Fall funkzionieren lassen.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: Bluetooth Headset kein Mikrofon

    Hallo, vielen Dank!

    Das mit
    Code:
    pacmd set-card-profile 2 headset_head_unit
    bing zumindest eine termporäre Lösung. Vor dem Befehl wurde das Mikro in Pavucontrol nicht angezeigt, danach schon.
    Weiß denn jemand eine dauerhafte Lösung?

    Gruß
    mairo

    Nachtrag: Die Wiedergabequalität des Headsets ist nach dem Umstellen eher schlecht :-( ..also der Ton auf den Kopfhörern... mhh...
    Das Profil wird dann nämlich von A2DP auf HSP/HFP umgestellt.... Das kann ich auch manuell in den Systemeinstellungen von KDE machen....

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,881
    Blog Entries
    14

    Default Re: Bluetooth Headset kein Mikrofon

    Quote Originally Posted by mairo View Post
    Hallo, vielen Dank!

    Das mit
    Code:
    pacmd set-card-profile 2 headset_head_unit
    bing zumindest eine termporäre Lösung. Vor dem Befehl wurde das Mikro in Pavucontrol nicht angezeigt, danach schon.
    Weiß denn jemand eine dauerhafte Lösung?

    Gruß
    mairo

    Nachtrag: Die Wiedergabequalität des Headsets ist nach dem Umstellen eher schlecht :-( ..also der Ton auf den Kopfhörern... mhh...
    Das Profil wird dann nämlich von A2DP auf HSP/HFP umgestellt.... Das kann ich auch manuell in den Systemeinstellungen von KDE machen....
    Problem ist hier daß das BT Gerät jedesmal beim Einschalten eine neue Indexnummer bekommt. Mit
    Code:
    pacmd list-cards
    kann man diese Nummer finden, und im Kommando benützen.

    Aber, eigentlich wäre es besser wenn man das irgendwo speichern konnte.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •