Results 1 to 5 of 5

Thread: Wine 5.13 not launching UNLESS disconnected from networks

  1. #1

    Question Wine 5.13 not launching UNLESS disconnected from networks

    Greetings all,

    Having an issue where wine refuses to display an application until all network connections are disconnected. If a program is launched (say "wine notepad"), the program will hang in limbo until the network is disconnected. Once the network is disconnected, notepad will appear.

    An application will continue to run if reconnected to a network, but if it launches child processes, like an installer needing to run regserv or something like that, again the program will hang until the network disconnects.

    This became an issue for me because I run Overwatch through Lutris and need both Wine and an internet connection to run the game. Wine was working 2 days ago, then yesterday I did a "zypper dup" and something obviously went wrong. I had an Ext4 partition so I could not use snapper.

    I have since reinstalled my distro, snappy enabled, but again the updates seem to have crippled wine to run in an "off network", not even "offline" state.

    I would not know were to begin to debug this, but the following is the output of "wine notepad" while connected to a network.

    Code:
    003c:err:service:process_send_command service protocol error - failed to write pipe!
    003c:fixme:service:scmdatabase_autostart_services Auto-start service L"PlugPlay" failed to start: 1053
    0050:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
    0050:err:winediag:nodrv_CreateWindow The explorer process failed to start.
    0050:err:ole:apartment_createwindowifneeded CreateWindow failed with error 0
    0050:err:ole:apartment_createwindowifneeded CreateWindow failed with error 0
    0050:err:ole:apartment_createwindowifneeded CreateWindow failed with error 0
    003c:err:service:process_send_command service protocol error - failed to write pipe!
    003c:fixme:service:scmdatabase_autostart_services Auto-start service L"winebus" failed to start: 1053
    003c:err:service:process_send_command service protocol error - failed to write pipe!
    003c:fixme:service:scmdatabase_autostart_services Auto-start service L"wineusb" failed to start: 1053
    003c:err:service:process_send_command service protocol error - failed to write pipe!
    003c:fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 1053
    Disconnecting from the network and running "wine notepad" yields no output and notepad launches normally.

    Any help would be appreciated. Thank you.

  2. #2

    Default Re: Wine 5.13 not launching UNLESS disconnected from networks

    UPDATE: Found an ISO online of Snapshot20200714-Media and installed it on a Virtual Machine. The Virtual Machine loaded wine no problem.

    So, I wiped my distro again, installed the older version without updates, installed wine, et voila, it works.

    Not gonna update until I know the issue is fixed, but at least I can make snapshots now!

  3. #3

    Angry Re: Wine 5.13 not launching UNLESS disconnected from networks

    I'm not sure what updated, but I got hit with this bug again. Reloading from a snapshot.

  4. #4

    Default Re: Wine 5.13 not launching UNLESS disconnected from networks

    Snapshot load worked for a few hours, then my system mysteriously updated again. Decided to do a full zypper dup to see if the issue had been fixed upstream yet. No dice.

    Really could use some help here! Lutris, Proton, and Wine are all not working!

  5. #5

    Default Re: Wine 5.13 not launching UNLESS disconnected from networks

    Fired up wireshark and saw a lot of requests to localhost.localdomain failing coming from wine's IP address. I simply added "127.0.0.1 localhost.localdomain" to my /etc/hosts file, and it magically works again!

    I hope anyone who has this problem finds this post to fix it!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •