Results 1 to 2 of 2

Thread: Luks password prompt gone after update

  1. #1

    Post Luks password prompt gone after update

    I just did
    Code:
    zypper dup
    a couple of minutes ago. Admittedly I didn't have a close look on the output, but zypper appeared to finish successfully. After a system reboot I cannot get to the Luks password prompt any more.

    What I still see is Grub and the kernel loading, and then the screen goes black and that is.
    Recovery mode or choosing the previous kernel image does not help.

    Maybe someone around with an idea about how and where to start?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,544
    Blog Entries
    3

    Default Re: Luks password prompt gone after update

    It is hard to guess what went wrong.

    The first thing I would do, is boot from rescue media (such as the installer rescue system or the Tumbleweed rescue live CD)

    And then, from a root command line, I would try to access the luks enccrypted system.

    Code:
    cryptsetup luksOpen /dev/sda5 cr_mydisk
    except change "/dev/sda5" to whatever is the encrypted device.

    If that works, you can look in "/dev/mapper" and perhaps try to mount from there. Since you have not indicated if this is just an encrypted file system or an encrypted LVM, I can't tell you what commands to use for that.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •