Results 1 to 6 of 6

Thread: Can’t update software packages

  1. #1

    Question Can’t update software packages

    Hello,

    I’m still new to oST and getting familiar with it (though not new to Linux). Currently running oST w/KDE.

    My system frequently says that it encounters an error when checking for software packages. I force a refresh and it finds them. It’s been a couple of days (I thought I updated a day or so ago) but I noticed today that it keeps saying that I still have 596 packages to update - even though I keep selecting install updates on the KDE system tray tool (sorry if that’s the wrong name). I think this was also happening when I updated a day or two ago and why it didn’t work but I didn’t realize I was encountering issues. I finally found an error in the KDE notifications and it says:

    problem with installed package libavcodec58-4.2.3-4.4.x86_64
    problem with installed package libavdevice58-4.2.3-4.4.x86_64
    problem with installed package libavfilter7-4.2.3-4.4.x86_64
    problem with installed package libavformat58-4.2.3-4.4.x86_64
    problem with installed package libavutil56-4.2.3-4.4.x86_64
    problem with installed package libpostproc55-4.2.3-4.4.x86_64
    problem with installed package libswresample3-4.2.3-4.4.x86_64
    problem with installed package libswscale5-4.2.3-4.4.x86_64

    So, I tried to look through the list of packages on the KDE software update tool and un-select these so I could at least update the rest of the packages but it didn’t seem to work. I went to YaST and went to both Online Updates and Software Management hoping to be able to do the updates from YaST but no updates are showing up. I watched some videos on YT to try to learn about how to use YaST and figure out what I’m doing wrong. These show going to the area that I went to (Online Updates) and they showed a bunch of updates right away but mine doesn’t - even though there are nearly 600 of them.

    I feel like such an idiot. I can’t seem to do the simplest of things and things that I would expect to work (like updating via YaST) aren’t working as expected. I’m sure it’s all me and I’m not blaming oS or YaST or anything else but that doesn’t make it any less frustrating or any easier to figure out.

    With the specific above problems, I searched for some of the titles in YaST and I’m showing, for instance, libavcodec58 the installed version is 4.2.3-4.4 and the available version is 4.2.3-1.1 - same for libavdevice58 and I’m sure all the others. I was told to install Packman repos when I did the install (which I did) using the simple OBS/Opi command line method - which worked like a charm. It said it was replacing some of the installed versions with the new repo, which I let it do. Is there some glitch that’s screwing this up?

    Why am I not seeing all my other updates in YaST? I thought I should always be able to do updates in YaST rather than having to use the KDE system tray tool - not that I mind that if it actually works. But I’ve heard so many awesome things about YaST that I assumed I could update there. I’m at a loss as to why I’m not seeing the updates on my system that I did on the videos.

    Thanks in advance for any help. I’m so lost. Really looking forward to you replies.

    EDIT: I decided to search for the first couple of software packages listed in the KDE update tray notification within YaST. I found ImageMagick and saw that each item had a green check mark by it but showed a newer available package. I manually clicked on each green check mark and it changed to the blue update icon. I clicked accept and it informed me of some dependency updates, I agreed and let it update. I refreshed the KDE update tray tool and it saw that ImageMagick was indeed updated and removed it from the list. I’m only mentioning this because, in a sense, I was able to perform an update via YaST but only by manually searching and forcing the update. It wasn’t even selected to update when I searched, even though it clearly “saw” that updates were available. Is there a setting somewhere that’s not turned on or that should have been turned on during the install that maybe a glitch prevented from happening? I can’t manually search and select 596 packages every few days. This may not be helpful info but I wanted to share in case it is - and I’m really trying to put in the work to figure this all out.

  2. #2
    Join Date
    Mar 2020
    Location
    São Leopoldo, RS, Brazil
    Posts
    244

    Default Re: Can’t update software packages

    For today's conflict, see: https://forums.opensuse.org/showthre...Today-s-Update

    Quote Originally Posted by raeyn View Post
    So, I tried to look through the list of packages on the KDE software update tool and un-select these so I could at least update the rest of the packages but it didn’t seem to work. I went to YaST and went to both Online Updates and Software Management hoping to be able to do the updates from YaST but no updates are showing up. I watched some videos on YT to try to learn about how to use YaST and figure out what I’m doing wrong. These show going to the area that I went to (Online Updates) and they showed a bunch of updates right away but mine doesn’t - even though there are nearly 600 of them.
    Did you watch a video about Leap? TW doesn't work the same way

    Also see:

    https://forums.opensuse.org/showthre...eed+packagekit

    https://forums.opensuse.org/showthre...eed+packagekit

    https://forums.opensuse.org/showthre...eed+packagekit
    openSUSE Tumbleweed

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,443
    Blog Entries
    3

    Default Re: Can’t update software packages

    Quote Originally Posted by raeyn View Post
    I feel like such an idiot.
    That's not needed.

    Other people are seeing the same problems. See https://forums.opensuse.org/showthre...Today-s-Update
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

  4. #4

    Default Re: Can’t update software packages

    Quote Originally Posted by nrickert View Post
    That's not needed.

    Other people are seeing the same problems. See https://forums.opensuse.org/showthre...Today-s-Update
    @nrickert, Thanks so much for this comment. I almost cried when I read it. Seriously. I’ve been pretty discouraged feeling so inept. I really appreciate it.

  5. #5

    Default Re: Can’t update software packages

    Oh, I’m not actually sure if it was Leap or Tumbleweed. I’m not sure it even specified. I’ve come to realize that there is a bug with these packages. So, from that standpoint, I think we’re waiting till it’s fixed.

    But having said that, should the updates in Tumbleweed show up in YaST or am I wrong on that?

    I’ll definitely check out those links. Thanks for sharing.

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,443
    Blog Entries
    3

    Default Re: Can’t update software packages

    Quote Originally Posted by raeyn View Post
    But having said that, should the updates in Tumbleweed show up in YaST or am I wrong on that?
    Best to use "zypper dup" at the command line for Tumbleweed.

    Yast online update looks for patches. But because Tumbleweed is a rolling distribution, every update is really a new release rather than a patch. So there aren't any patches for Tumbleweed.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •