Page 1 of 6 123 ... LastLast
Results 1 to 10 of 51

Thread: Another Problem With Today's Update

  1. #1

    Default Another Problem With Today's Update

    I'm getting this problem message:
    Code:
    > sudo zypper dup                                                                      
    Loading repository data...
    Reading installed packages...
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Computing distribution upgrade...
    10 Problems:
    Problem: problem with installed package libavcodec58-4.2.3-4.3.x86_64
    Problem: problem with installed package libavdevice58-4.2.3-4.3.x86_64
    Problem: problem with installed package libavfilter7-4.2.3-4.3.x86_64
    Problem: problem with installed package libavformat58-4.2.3-4.3.x86_64
    Problem: problem with installed package libavutil56-4.2.3-4.3.x86_64
    Problem: problem with installed package libpostproc55-4.2.3-4.3.x86_64
    Problem: problem with installed package libswresample3-4.2.3-4.3.x86_64
    Problem: problem with installed package libswscale5-4.2.3-4.3.x86_64
    Problem: libffms2-4-2.23.1-1.10.x86_64 requires libavresample.so.4()(64bit), but this requirement cannot be provided
    Problem: libffms2-4-2.23.1-1.10.x86_64 requires libavresample.so.4()(64bit), but this requirement cannot be provided
    
    Problem: problem with installed package libavcodec58-4.2.3-4.3.x86_64
     Solution 1: install libavcodec58-4.2.3-1.1.x86_64 (with vendor change)
      http://packman.links2linux.de  -->  openSUSE
     Solution 2: keep obsolete libavcodec58-4.2.3-4.3.x86_64
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c/d/?] (c): c
    On my system, the first eight packages are from packman, but libffms2-4 is from Main Repository (OSS). I don't see libffms2-4 available from packman, so does this mean that I just need to wait for libffms2-4 to be upgraded in the OSS repo?

    Regards,
    Gene

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,830
    Blog Entries
    14

    Default Re: Another Problem With Today's Update

    Please show
    Code:
    zypper lr -d
    , I think you did not do the vendor change on the Packman repo.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Mar 2020
    Location
    São Leopoldo, RS, Brazil
    Posts
    231

    Default Re: Another Problem With Today's Update

    Same here. And I have done the vendor change to packman already.

    Some packages were renamed, i.e. appended a number to them, see https://build.opensuse.org/request/show/820572

    It looks like https://build.opensuse.org/package/s...AFactory/ffms2 wasn't updated. You could ping the maintainer over there.
    openSUSE Tumbleweed

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,275
    Blog Entries
    3

    Default Re: Another Problem With Today's Update

    For my update, it wanted to switch those package to the openSUSE oss repo. I think that was 8 vendor changes.

    I allowed it. But I assume that they will be able to switch back as soon as the packman maintainers rebuild those packages.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

  5. #5

    Default Re: Another Problem With Today's Update

    I did do the vendor change when I installed the recommended media codecs. It changed conky to packman as well the codecs. Looks like libffms2-4 needs to be updated.

    Gene

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,275
    Blog Entries
    3

    Default Re: Another Problem With Today's Update

    A bit more detail. I did my update with allow-vendor-change. And I got:
    Code:
    The following 11 packages are going to be downgraded:
      ffmpeg-4 gstreamer-plugins-libav libavcodec58 libavdevice58 libavfilter7
      libavformat58 libavresample4 libavutil56 libpostproc55 libswresample3
      libswscale5
    
    The following 11 packages are going to change vendor:
      ffmpeg-4                 http://packman.links2linux.de -> openSUSE
      gstreamer-plugins-libav  http://packman.links2linux.de -> openSUSE
      libavcodec58             http://packman.links2linux.de -> openSUSE
      libavdevice58            http://packman.links2linux.de -> openSUSE
      libavfilter7             http://packman.links2linux.de -> openSUSE
      libavformat58            http://packman.links2linux.de -> openSUSE
      libavresample4           http://packman.links2linux.de -> openSUSE
      libavutil56              http://packman.links2linux.de -> openSUSE
      libpostproc55            http://packman.links2linux.de -> openSUSE
      libswresample3           http://packman.links2linux.de -> openSUSE
      libswscale5              http://packman.links2linux.de -> openSUSE
    I will note that this was in a virtual machine that I use for testing. I have not yet updated my real machines. I usually wait for Saturday to do that.

    I expect that this is a temporary glitch until the packman maintainers update these packages. And, since I am allowing vendor change for this VM, I'll see that happen.

    One way to get around the problem would be to use "zypper up" instead of "zypper dup". That gives an incomplete update, but it will avoid this problem. And by the time of the next "zypper dup", it will probably have been fixed.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

  7. #7

    Default Re: Another Problem With Today's Update

    Did this update today on my wifes notebook (with vendor changes fom packman to opensuse), now no Youtube videos play. Not funny!

    Tried to shift in YaST all packages to packman again, but get three more warnings, which I can not resolve.
    Kind regards

    raspu

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    29,374
    Blog Entries
    15

    Default Re: Another Problem With Today's Update

    Quote Originally Posted by suse_rasputin View Post
    Did this update today on my wifes notebook (with vendor changes fom packman to opensuse), now no Youtube videos play. Not funny!

    Tried to shift in YaST all packages to packman again, but get three more warnings, which I can not resolve.
    Hi
    It won't help as nothing is rebuilding on the packman build service (no API or WEBUI working), it's dead as the proverbial dodo... so all the links to new/updated packages on the openSUSE Build service won't get built.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9

    Default Re: Another Problem With Today's Update

    Only thing I understand is this dodo thing. Rest: What's next? Reinstall TW? In the meantime I downloaded the relevant workout vids (cough) with youtube-dl, downgraded vlc to version 3 (as 4dev is a nightmare), found out that the machine explodes with highest resolution downloaded by youtube-dl by default... now the vid plays an I lost 2 h of my life time.

    What's going on in TW repos? Parents on holiday, kiddies do the update stuff? :-/
    Kind regards

    raspu

  10. #10
    Join Date
    Mar 2020
    Location
    São Leopoldo, RS, Brazil
    Posts
    231

    Default Re: Another Problem With Today's Update

    Quote Originally Posted by suse_rasputin View Post
    Only thing I understand is this dodo thing. Rest: What's next? Reinstall TW?
    Do you have snapshots enabled? Boot into the last, and revert. There's instructions around the forum and wiki.
    openSUSE Tumbleweed

Page 1 of 6 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •