20200712 After upgrade to LEAP 15.2 using DEs XFCE and KDE I find that AppImage works on
XFCE
Plasma
Plasma (Wayland)
BUT does not work, i.e. application just fails to load in
Plasma (Full Wayland).

Is there any reason for this inconsistency?

I have used Plasma and Plasma (Wayland) in LEAP 15.1 successfully. XFCE worked in LEAP 15.1 and in LEAP 15.2.
Computer Dell E6530, i7, 16G RAM.

I was trying out Plasma (full Wayland) when I his this error. on clicking on AppImage {already set as executable) it opened a pop-up box with "make this AppImage executable" when box ticked to make executable the AppImage crashed. (or rather pop up box disappeared, AppImage did not load)
AppImage is LBRY AppImage.

Thanks for any answers in advance.
Regards
EionMac