Results 1 to 4 of 4

Thread: Why Is Netbeans Not In The Repositories?

  1. #1
    Join Date
    Jul 2020
    Posts
    15

    Default Why Is Netbeans Not In The Repositories?

    Hi folks. I just tried to install Netbeans through YaST And found that a few components of Netbeans are in the repositories, but the actual IDE itself is not. The Apache foundation took stewardship of Netbeans a while ago, didn't it? Has some licensing change during the transition to the Apache foundation meant that Netbeans can't be included in the repositories? Henk said that I should just wait for the Packman and Nvidia repositories to be added to 15.2 so that I can install the video codecs and my GPU driver. Is it likely that Netbeans will be in the Packman repositories for similar reasons that the video codecs are, or should I be looking to download, install and keep it up-to-date manually?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    21,742
    Blog Entries
    1

    Default Re: Why Is Netbeans Not In The Repositories?

    Here's another means to an end...
    https://snapcraft.io/install/netbeans/opensuse
    openSUSE Leap 15.2; KDE Plasma 5

  3. #3
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,705
    Blog Entries
    1

    Default Re: Why Is Netbeans Not In The Repositories?

    Quote Originally Posted by deano_ferrari View Post
    Here's another means to an end...
    https://snapcraft.io/install/netbeans/opensuse
    Hm?

    Code:
    karl@erlangen:~> netbeans
    snap-confine has elevated permissions and is not confined but should be. Refusing to continue to avoid permission escalation attacks: Operation not permitted
    karl@erlangen:~>
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

  4. #4

    Default Re: Why Is Netbeans Not In The Repositories?

    Quote Originally Posted by Ray View Post
    Hi folks. I just tried to install Netbeans through YaST And found that a few components of Netbeans are in the repositories, but the actual IDE itself is not. The Apache foundation took stewardship of Netbeans a while ago, didn't it? Has some licensing change during the transition to the Apache foundation meant that Netbeans can't be included in the repositories? Henk said that I should just wait for the Packman and Nvidia repositories to be added to 15.2 so that I can install the video codecs and my GPU driver. Is it likely that Netbeans will be in the Packman repositories for similar reasons that the video codecs are, or should I be looking to download, install and keep it up-to-date manually?
    For me, IDE like NetBeans or Eclipse is always better to install manually, not via package manager. And not only on openSUSE, but almost on all distros.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •