Results 1 to 4 of 4

Thread: Leap 15.2: После свежей установки нужно понижать версию VLC до 3.0.10 для кодеков из Packman

  1. #1

    Exclamation Leap 15.2: После свежей установки нужно понижать версию VLC до 3.0.10 для кодеков из Packman

    Leap 15.2: После свежей установки (не обновления с предыдущего выпуска) нужно понижать версию VLC до 3.0.10 для установки кодеков из 3.0.10.
    По умолчанию ставится VLC 3.0.11. Кодеки в Packman собираются для 3.0.10, ибо в Leap 15.1 и 15.2 glibc 2.26, а нужна 2.29+.
    Вопрос поднят, сообщения об ошибке созданы:

    https://bugzilla.opensuse.org/show_bug.cgi?id=1173734
    https://bugzilla.opensuse.org/show_bug.cgi?id=1173761

    , обновить glibc можно.

    Обновления VLC выше 3.0.10 с кодеками 3.0.10 пока что не будет. Если только руками собирать, причём не в OBS.

    О кодеках: https://forums.opensuse.org/showthre...-be-installed)

    Если брать из VLC: https://download.videolan.org/pub/vi...uSE/Leap_15.2/ - не пробовал ещё.

  2. #2
    Join Date
    Jun 2010
    Location
    Кропоткин, Краснодарский край
    Posts
    160

    Default Re: Leap 15.2: После свежей установки нужно понижать версию VLC до 3.0.10 для кодеков из Packman

    Quote Originally Posted by Svyatko View Post
    Leap 15.2: После свежей установки (не обновления с предыдущего выпуска) нужно понижать версию VLC до 3.0.10 для установки кодеков из 3.0.10.
    По умолчанию ставится VLC 3.0.11.......
    Вы вообще о чём?!!

    VLC в основном репозиторие 3.0.10 ВОТ (в установочном ISO образе тоже, если что)
    VLC в репозиторие packman 3.0.10 ВОТ
    (ну и, не забываем нажать "Перевести системные пакеты на версии из этого репозитория (Packman Repository)")

    Вы выдумали проблему, на пустом месте!

  3. #3

    Default Re: Leap 15.2: После свежей установки нужно понижать версию VLC до 3.0.10 для кодеков из Packman

    Quote Originally Posted by e_dimas View Post
    Вы вообще о чём?!!

    VLC в основном репозиторие 3.0.10 ВОТ (в установочном ISO образе тоже, если что)
    VLC в репозиторие packman 3.0.10 ВОТ
    (ну и, не забываем нажать "Перевести системные пакеты на версии из этого репозитория (Packman Repository)")

    Вы выдумали проблему, на пустом месте!
    Вчера для 15.2 был VLC 3.0.11.
    Можете почитать: https://forums.opensuse.org/showthre...-be-installed)

    Hi,

    I installed OpenSUSE Leap 15.2 and installed 'vlc' media player. To play MPEG4 videos, I need 'vlc-codecs' from VideoLanClient repository or packman repository. Both of them have 'vlc-codecs (3.0.11-4.2)' which were built against 'glic (2.29)'. When I try to install the vlc-codecs, zypper or YaST complain that "nothing provides libm.so.6(GLIBC_2.29)(64bit)" The OpenSUSE Leap 15.2 seems to be built with GLIBC 2.26, which is 3 years old. I thought of downloading and installing GLIBC-2.29 (or even the latest GLIBC-2.31), but after digging through little bit, it appears to be a very risky thing and could break the many packages and even kernel.
    My question is, why is OpenSUSE Leap 15.2 released in July 2020 using glibc-2.26 released in 2017? More importantly, how do I fix the vlc media player? This also seems to cause some issues with 'gstreamer' (libav: avenc_mpeg4). Is there a general solution to this problem that fixes all such version mismatch problems with glibc in Leap 15.2? I appreciate any suggestions, solutions, workarounds, or information on this.
    Вопрос был решён.

    Есть решение лучше - использовать пакеты от Videolan:

    для Leap 15.1: https://download.videolan.org/pub/vi...uSE/Leap_15.1/
    для Leap 15.2: https://download.videolan.org/pub/vi...uSE/Leap_15.2/

    С ними получил VLC 3.0.11 с закрытыми кодеками на Leap 15.1.

  4. #4
    Join Date
    Jun 2010
    Location
    Кропоткин, Краснодарский край
    Posts
    160

    Default Re: Leap 15.2: После свежей установки нужно понижать версию VLC до 3.0.10 для кодеков из Packman

    Quote Originally Posted by Svyatko View Post
    Вчера для 15.2 был VLC 3.0.11
    У меня - Сегодня, Вчера, и Позавчера был VLC 3.0.10
    (систему установил на следующий день после релиза, версия VLC за эти дни не менялась. Если что, обновления каждый день проверяю/устанавливаю)

    Quote Originally Posted by Svyatko View Post
    Есть решение лучше...
    Есть решение ЕЩЁ лучше!

    -> openSUSE-Community -> "Перевести системные пакеты на Packman Repository" -> Повысить приоритет репозитория Packman (И можно забыть о не соответствии версий пакетов, навсегда)

    P.S.
    Плееры из основного репозитория всегда не корректно работали с кодеками из Packman.
    По этому и плееры, и кодеки нужно, обязательно, ставить из одного репозитория. (в данном случае, имею ввиду, Packman)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •