Results 1 to 2 of 2

Thread: buildinfo invalid - how to fix

  1. #1

    Default buildinfo invalid - how to fix

    It looks like some metadata is invalid for my project, at least locally. For a local build I get:

    rger@localhost:~/osc/home:rainergerhards:branches:home:rgerhards/rsyslog> osc build xUbuntu_19.10 x86_64
    Building rsyslog-xUbuntu_19.10.dsc for xUbuntu_19.10/x86_64
    Getting buildconfig from server and store to /home/rger/osc/home:rainergerhards:branches:home:rgerhards/rsyslog/.osc/_buildconfig-xUbuntu_19.10-x86_64
    Getting buildinfo from server and store to /home/rger/osc/home:rainergerhards:branches:home:rgerhards/rsyslog/.osc/_buildinfo-xUbuntu_19.10-x86_64.xml
    buildinfo is broken... it says:
    unresolvable: nothing provides rzsz

    The same platforms builds without problems on the OBS web builders. I also have nowhere defined a dependency "rzsz". Does anybody know how to remove this invalid piece of metadata (or whatever it actually is)?

    Thanks,
    Rainer

    PS: Here it builds: https://build.opensuse.org/package/s...rhards/rsyslog

  2. #2
    Join Date
    Oct 2018
    Location
    Atlantis
    Posts
    179

    Default Re: buildinfo invalid - how to fix

    I personally just delete the local build folder and just osc co again. Maybe not the best method but it work for my case.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •