Results 1 to 6 of 6

Thread: gramps for 15.2?

  1. #1

    Default gramps for 15.2?

    During the upgrade process from 15.1 to 15.2 there is a notification that the interfaces for gramps 5.1.2 cannot be provided. The reason is that gramps version 4 is available in the main repository, gramps 5.1.2 (with sqlite) being available in Tumbleweed only.

    Would I create a problem for myself if I added Tumbleweed to my repos? Gramps 5.1.2 (incl. sqlite) works fine with 15.1.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    14,023
    Blog Entries
    3

    Default Re: gramps for 15.2?

    Well, yes, that might cause a problem.

    We have had people add a Tumbleweed repo, without realizing quite what they were doing, and then finding a thousand updates. And if they apply those updates, they finish up running Tumbleweed by mistake.

    If you really want to try that, then:

    1: give the Tumbleweed a priority of 100 or more. Note that a lower priority number is favored. So a higher number for the Tumbleweed repo means that it won't be used for most updates;
    2: when your package is installed, and you are happy with it after testing, then it is best to disable the Tumbleweed repo. You could occasionally re-enable if needed to update that package.
    openSUSE Leap 15.2; KDE Plasma 5.18.5;

  3. #3
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,531

    Default Re: gramps for 15.2?

    Add the GNOME Apps repo and you will find version 5 there.

  4. #4

    Default Re: gramps for 15.2?

    Quote Originally Posted by john_hudson View Post
    Add the GNOME Apps repo and you will find version 5 there.
    Thanks. That's good to know....although only gramps 5.1.1 shows up under Leap 15.0

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,409
    Blog Entries
    2

    Default Re: gramps for 15.2?

    Quote Originally Posted by nrickert View Post
    Well, yes, that might cause a problem.

    We have had people add a Tumbleweed repo, without realizing quite what they were doing, and then finding a thousand updates. And if they apply those updates, they finish up running Tumbleweed by mistake.

    If you really want to try that, then:

    1: give the Tumbleweed a priority of 100 or more. Note that a lower priority number is favored. So a higher number for the Tumbleweed repo means that it won't be used for most updates;
    2: when your package is installed, and you are happy with it after testing, then it is best to disable the Tumbleweed repo. You could occasionally re-enable if needed to update that package.
    I would generally recommend an alternative...
    If you are installing an app using a "one click install," there are a number of checked boxes on the first screen that should be <unchecked>. This enables to install to grab that package from the repo, but won't add the repo to the system. If a repo isn't added to the system, then there is no way mistakes can be made like accidentally pulling down other TW packages.

    Alternative is to manually download the individual packages without adding the repo which accomplishes the same thing, but can be a lot more work.

    Suggesting,
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  6. #6

    Default Re: gramps for 15.2?

    Quote Originally Posted by tsu2 View Post
    I would generally recommend an alternative...
    If you are installing an app using a "one click install," there are a number of checked boxes on the first screen that should be <unchecked>. This enables to install to grab that package from the repo, but won't add the repo to the system. If a repo isn't added to the system, then there is no way mistakes can be made like accidentally pulling down other TW packages.

    Alternative is to manually download the individual packages without adding the repo which accomplishes the same thing, but can be a lot more work.

    Suggesting,
    TSU
    I have to admit that this is somewhat irritating. I have been using gramps 5.1.2 from GNOME:/Apps for a while now. It is a significant improvement over 4.x., but I certainly do not want to get tangled up in tumbleweed. Can I hope that 5.1.2+ will appear in GNOME:/Apps again soon, I wonder?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •